Ubuntu

Nautilus appearance without colour or theme

Reported by kikl on 2011-09-26
146
This bug affects 31 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

I started Nautilus. Browsing through files and folders appears to be working. However, the appearance, i.e. buttons and layouts has virtually no colours. I uploaded a screen shot of nautilus in order to illustrate the bug.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.1.92-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Mon Sep 26 17:22:15 2011
ExecutablePath: /usr/bin/nautilus
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: Upgraded to oneiric on 2011-09-25 (1 days ago)

kikl (kilian-klaiber) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Eric Green (eric-green-5-0) wrote :

Also same, except on initial start up it looks normal and then after a while of use everything suddenly appears grey with icons that look similar to simple document icons. Also the highlight selection box created from dragging the cursor on the desktop is no longer orange and also turns grey.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you add your .xsession-errors to the bug? What theme do you use?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
kikl (kilian-klaiber) wrote :

The Xsession-errors is added to the bug report. It says over and over again: "Im Modulpfad »pixmap« konnte keine Themen-Engine gefunden werden", which means in English: No theme engine could be found in the module path "pixmap". I used the standard ubuntu theme.

Regards

Kikl

Hernando Torque (htorque) wrote :

This happens from time to time when closing applications. Nautilus (and desktop icons) lose the theme (default Ambiance here). To restore theming, restart Nautilus from a terminal:

killall nautilus ; (nautilus &)

Hernando Torque (htorque) wrote :
Hernando Torque (htorque) wrote :

Seems to be a problem with gnome-settings-daemon's clipboard plugin.

I can reliably reproduce the theme issue by opening Opera, putting some text in the clipboard using Ctrl+c, and then closing Opera. However, this is _not_ limited to Opera, it's just reliably reproducible with it here.

Backtrace attached (note, that I didn't run this with GDK_SYNCHRONIZED=1 as this would cause the bug to not show).

Paul Kishimoto (khaeru) wrote :

Bug #879793 may be a duplicate.

Matthijs ten Kate (igadget) wrote :

Bug #874457 might be a duplicate as well, although in that case (my case), the problem only occurs after resuming from suspend.
So should we consider this the master bug as this was the first to be reported? I added my .xsession-errors for your reference.

Hernando Torque (htorque) wrote :

You are getting a different error though:

(gnome-settings-daemon:2034): Gdk-WARNING **: The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'XI_BadDevice (invalid Device parameter)'.

Where in my case it's:

(gnome-settings-daemon:6546): Gdk-WARNING **: The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.

And in bug #879793 it's:

(gnome-settings-daemon:2108): Gdk-WARNING **: The program 'gnome-settings-daemon' received an X Window System error.
 This probably reflects a bug in the program.
 The error was 'BadMatch (invalid parameter attributes)'.

Matthijs ten Kate (igadget) wrote :

So the question is - are these errors actually related to different bugs, or is there one bug which causes different errors to appear in the log but actually has the same root cause?

Steffen Röcker (sroecker) wrote :

Since today I have the same problem on two computers.
I just noticed that the guest account is working fine.

Steffen Röcker (sroecker) wrote :

I could reproduce and fix this.
My dconf got corrupted by lightdm --test-mode. After deleting .config/dconf/user everything works again.
See bug #882986.

Matthias Niess (mniess) wrote :

I've got the same problem and it occurs 95% of the time when I quit the Opera Browser. I've got this problem on a freshly installed machine (I only copied over some documents and my .ssh from a backup). I'll try the solution of #14 and report back if it solves the problem.

Hernando Torque (htorque) wrote :

Steffen, I don't think that bug is connected to this one. I still could reproduce it with a new user (hence a working dconf database).

Question for others: did you ever get this with any application other than Opera? I'm quite sure I've seen it happen before with XChat and Nautilus itself, but I haven't been able yet to reproduce it with anything else but Opera.

Adam Reichold (adamreichold) wrote :

I do see this behavior on a regular basis but I also run Opera, so I start to believe that Opera at least triggers something other programs don't.

Christopher Taylor (timrod) wrote :

I'm seeing this behaviour as well since the upgrade to 11.10. My .xsession-errors (attached) contains many of the following messages:

(nautilus:18981): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

and

(nautilus:22664): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

The number (timestamp?) after nautilus varies, but there are always many consecutive messages with the same number.

Christopher Taylor (timrod) wrote :

I set the status back to Confirmed since there are now multiple .xsession-errors file attached, as requested in comment #4. Hope that's alright.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed

I too have the same issue but never installed Opera on my system. So I don't think Opera somehow at the root of this bug.

Also the missing 'pixmap' modulepath error, but to me it seems they are not related, because nautilus worked fine yesterday and the pixmap issue was already present then.

Aljaz (godecaljaz) wrote :

Same here, irrespective of whether Opera is installed or not. In my case the problem
always occurs sometime after login on battery power and sometimes (but less frequently)
on AC power. I ran 11.4 before on the same machine, absolutely problem free.

I have tried a all the suggested workarounds and none of them works. I could 'live' with
the 'appearance issues' but for me the most critical part is that the power indicator
stops working when the error kicks in. In turn, it happened on several occasions that
while I was running some urgent jobs on my laptop the computer just shut down.

Now, given its low priority is there any hope for a fix or is a downgrade unavoidable?

Hernando Torque (htorque) wrote :

Aljaz: are you sure it's only Nautilus (and the desktop) that loses the theme? If not, then that's probably a different bug ('powe manager not working' sounds like a crashed g-s-d, and it doesn't crash for me).

Aljaz (godecaljaz) wrote :

Well, not really. The whole theme is messed up. The appearance of any window, icon, etc. is messed up. I get the same 'gnome-settings-daemon' errors, and if I kill it and then re-run it, the unity bar is restored (for a few seconds) and is then killed again, reporting a segmentation fault for 'gnome-settings-daemon'.

But even for the short period that it works after rerunning it the icons on the desktop are not restored.

The funny thing is, that a terminal window looks fine (I attached a screenshot).

On AC power, the power indicator works fine, on battery it is there but it just
does not work.

I found several related bug reports, but this one seems to be the closest one ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers