Unity launcher progress bar not working for file sizes >= 2GiB

Bug #845188 reported by Hernando Torque on 2011-09-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

The progress bar seems to fail showing progress whenever the total file size limit of the copy process is larger or equal than 2147483648 bytes (= 2 GiB).

TEST CASE:
 1. Create a bad dummy file:
     dd if=/dev/zero of=dummy.fail bs=1073741824 count=2
 2. Create a working dummy file (one byte less):
     cp dummy.bad dummy.good
     truncate -s 2147483647 dummy.good
 3. Open Nautilus and copy each one separately to a different place. Filesystems and partitions shouldn't matter.

RESULT:
 * dummy.good: The progress bar follows the progress shown in Nautilus' file dialog.
 * dummy.bad: The progress bar doesn't follow the progress shown in Nautilus' file operation dialog.

Using Nautilus 1:3.1.90-0ubuntu2 on up-to-date Oneiric.

Related branches

Changed in nautilus (Ubuntu):
status: New → Confirmed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Sorry, this was really a stupid mistake. I forgot an "int" around that lead to this overflow... :/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.0-0ubuntu3

---------------
nautilus (1:3.2.0-0ubuntu3) oneiric; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/patches/12_unity_launcher_support.patch:
    - Fixed a typo that lead to bad computation of progress for
      files with size >= 2GB due to a type overflow (LP: #845188)

  [ Ted Gould ]
  * debian/patches/05_desktop_menu_export.patch: Update for Nautilus 3.x
    (LP: #805252)

  [ Didier Roche ]
  * clean the above patch from duplication and add DEP3 info
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 09:40:29 +0200

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers