Background wallpaper briefly appears shifted horizontally by around 15 pixels on startup

Bug #839610 reported by Florian Boucault on 2011-09-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
Unity
Invalid
Low
Unassigned
unity-2d
Medium
Gerry Boland
nautilus (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

When logging in the background wallpaper briefly appears shifted horizontally to the right by around 15 pixels. A grey-ish border is therefore briefly displayed on the left hand side of the desktop.

To reproduce it:
1. killall nautilus
2. nautilus -n

Changed in unity-2d:
milestone: none → 4.6
status: New → Confirmed
importance: Undecided → Medium
description: updated
tags: added: login
Gerry Boland (gerboland) on 2011-09-05
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Gerry Boland (gerboland) wrote :

Bug reported upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=658906

This occurs under both Compiz and Metacity (compositing on & off).

Florian Boucault (fboucault) wrote :

Does it occur with Unity?

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Omer Akram (om26er) on 2011-09-14
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Florian Boucault (fboucault) wrote :

Chris Coulson believes that it is the same bug as bug #804435 for which a patch to GTK is underway.

Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in nautilus:
status: New → Fix Released
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
status: New → Confirmed

I still see this bug.. the wallpaper now is shifted vertically when the top panel appears.

Changed in nautilus (Ubuntu):
status: New → Fix Released
importance: Undecided → Low
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released

as comment #5
I still have this bug.. it is a fresh install with unity 5.0 from staging ppa.
ideas?

it shift to the bottom and not to the right like the OP

Omer Akram (om26er) wrote :

Not happening in 12.04+

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.