Ubuntu

Browsing EnhancedCD's crashes Nautilus

Reported by Severin Schoepke on 2007-01-31
2
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Hi all!

Today I wanted to watch a video clip on an EnhancedCD (EnhancedCD's are audio cd's that contain additional tracks with data). When I inserted the disk, a popup came up asking me wether I want to browse the disk or play the audio tracks on it. No matter which button I clicked there was always Sound Juicer coming up...
Since I wanted to watch clips on the data part, I started Nautilus and then clicked onto the cd drive in the tree-view on the left. As soon as I clicked, Nautilus crashed...
So it seems that Nautilus can't open data parts of EnhancedCD's (I tried 3 different EnhancedCD's and all of them crashed Nautilus when trying to browse the data part. On a side note: all of them play fine in Rythmbox (the audio part)).

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

What version of Ubuntu do you use?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Download full text (7.6 KiB)

Backtrace:

Distribution: Ubuntu 6.10 (edgy)
Gnome Release: 2.16.1 2006-10-02 (Ubuntu)
BugBuddy Version: 2.16.0

Memory status: size: 98619392 vsize: 0 resident: 98619392 share: 0 rss:
32624640 rss_rlim: 0
CPU usage: start_time: 1170270382 rtime: 0 utime: 2976 stime: 0
cutime:2589 cstime: 0 timeout: 387 it_real_value: 0 frequency: 1460

Backtrace was generated from '/usr/bin/nautilus'

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1226832208 (LWP 7241)]
0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb769634b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7e2d1b6 in gnome_gtk_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3 <signal handler called>
#4 0x080e1d39 in nautilus_directory_async_state_changed
(directory=0x8705380)
    at nautilus-directory-async.c:1917
#5 0x080e5587 in nautilus_directory_monitor_add_internal (
    directory=0x8705380, file=0x0, client=0x886d0d0,
monitor_hidden_files=0,
    monitor_backup_files=0, file_attributes=4740,
    callback=0x80d51d0 <files_changed_callback>, callback_data=0x8af07e0)
    at nautilus-directory-async.c:669
#6 0x0812a6ce in vfs_file_monitor_add (directory=0x8705380,
    client=0x886d0d0, monitor_hidden_files=0, monitor_backup_files=0,
    file_attributes=4740, callback=0x80d51d0 <files_changed_callback>,
    callback_data=0x8af07e0) at nautilus-vfs-directory.c:105
#7 0x080e903a in nautilus_directory_file_monitor_add (directory=0x8705380,
    client=0x886d0d0, monitor_hidden_files=0, monitor_backup_files=0,
    file_attributes=4740, callback=0x80d51d0 <files_changed_callback>,
    callback_data=0x8af07e0) at nautilus-directory.c:1619
#8 0x080d4db7 in update_monitoring (model=0x886d0d0, node=0x8be8b68)
    at fm-tree-model.c:1071
#9 0x080d4e89 in update_monitoring_idle_callback (callback_data=0x886d0d0)
    at fm-tree-model.c:1437
#10 0xb7620aa1 in g_source_is_destroyed () from /usr/lib/libglib-2.0.so.0
#11 0xb7622802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0xb76257df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#13 0xb7625b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#14 0xb7b63574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x0807bb4a in main (argc=5, argv=0xbf88cc34) at nautilus-main.c:372
#16 0xb73aa8cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#17 0x08067621 in _start ()

Thread 1 (Thread -1226832208 (LWP 7241)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb769634b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7e2d1b6 in gnome_gtk_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3 <signal handler called>
No symbol table info available.
#4 0x080e1d39 in nautilus_directory_async_state_changed
(directory=0x8705380)
    at nautilus-directory-async.c:1917
No locals.
#5 0x080e5587 in nautilus_directory_monitor_add_internal (
    directory=0x8705380, file=0x0, client=0x886d0d0,
monitor_hidden_files=0,
    monitor_backup_files=0, file_...

Read more...

Sebastien Bacher (seb128) wrote :

The backtrace looks like http://bugzilla.gnome.org/show_bug.cgi?id=320020 upstream which should be fixed on feisty, could you try on feisty if you get that problem (maybe with a liveCD)?

> The backtrace looks like
> http://bugzilla.gnome.org/show_bug.cgi?id=320020 upstream which should
> be fixed on feisty, could you try on feisty if you get that problem
> (maybe with a liveCD)?

I could check it with a live CD if that is possible (removing the live
CD while the system is running and put in an EnhancedCD). I have to
download a live CD first, so I can't report back before tomorrow...

Changed in nautilus:
status: Unknown → Confirmed

I finally checked it in Feisty... Everything works like it should there... So I think this means case closed?

Sebastien Bacher (seb128) wrote :

looks like, marking fixed then, feel free to reopen if you get the problem again though

Changed in nautilus:
status: Needs Info → Fix Released
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.