3 problems with renaming / deleting .desktop files in nautilus

Bug #815389 reported by Sven K. on 2011-07-24
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

tested with nautilus in newest ubuntu 11.04:

Files whose name ends with ".desktop" seem to be handled very special in nautilus (without any mime-type check) and there are three bugs with it:

1) Inside the directory "~/.local/share/applications" (and only there!): When you rename some file "example.desktop" (you might create a new empty file for this test) to "example2.desktop", then the filename will be "example2.desktop.desktop". You must rename it to "example2" to achieve "example2.desktop"

2) Inside the directory "/tmp" you might create some file named "example.desktop". When you want to rename it, a popup tells "renaming is not possible" and when you want to move it to trash it then a popup tells "cannot move to trash, do you want to delete directly?"

3) Inside other directories, e.g., home, you might create some file named "example.desktop". When you want to rename it, a popup tells "renaming is not possible", but in opposite to the case inside the /tmp directory, you can just move it to trash without problems.

####

So, there seems to be something wrong in this special handling. Further, I would suggest that any special handling of .desktop files should be disabled anyway. Especially, because you cannot open a .desktop file with a texteditor from nautilus.

Daniel Manrique (roadmr) on 2011-07-24
affects: ubuntu → nautilus (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The .desktop are special because that's how launcher are made, it tries to rename the actual name of the launcher and not the file on disk, that's a corner case

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

The issue is fixed in nautilus 3.30

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.