appmenu shows wrong menu when desktop is displayed (not the tweaked desktop one)

Bug #805252 reported by Doug McMahon on 2011-07-03
122
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Unity Foundations
High
Ted Gould
gtk+3.0 (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
nautilus (Ubuntu)
Medium
Ted Gould
Oneiric
Medium
Ted Gould

Bug Description

The file, edit and view menus are the same as seen in nautilus. This means there are options unsuitable for use on the desktop.
Some may actually cause issue if selected, Ex. File > new tab or window, ect.

TEST CASE:
1. Press SUPER+d to minimize all the windows
2. Move the mouse over the top panel

Result:
It displays the nautilus menu.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: appmenu-gtk 0.3.0~r135-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-9.43lp760131v201106060906-generic 2.6.38.7
Uname: Linux 2.6.38-9-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Jul 3 18:03:47 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: appmenu-gtk
UpgradeStatus: Upgraded to oneiric on 2011-07-03 (0 days ago)

Doug McMahon (mc3man) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

I confirm that when the desktop if shown (no window opened or all windows are minimized) appmenu-gtk shows the nautilus menu which shouldn't be.

Setting to triaged/high

Changed in appmenu-gtk (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in appmenu-gtk (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
summary: - The nautilus appmenu with focus on desktop contain options that
- shouldn't be available
+ appmenu shows nautilus menu when desktop is displayed
Changed in appmenu-gtk (Ubuntu Oneiric):
milestone: none → oneiric-alpha-2
description: updated
tags: added: regression-release

The issue is recorded as a work item on the desktop-o-gtk3-gnome3 blueprint:
"Update nautilus indicator-appmenu patch:"

The issue is that the patch in nautilus need to be rewritten for GNOME3

affects: appmenu-gtk (Ubuntu Oneiric) → nautilus (Ubuntu Oneiric)
affects: nautilus (Ubuntu Oneiric) → appmenu-gtk (Ubuntu Oneiric)
affects: appmenu-gtk (Ubuntu Oneiric) → nautilus (Ubuntu Oneiric)
Martin Pitt (pitti) wrote :

Not an alpha-2 blocker. Also, the "Go to", "Bookmarks", and perhaps "Help" menus are actually useful on the desktop. Can we keep those?

Changed in nautilus (Ubuntu Oneiric):
milestone: oneiric-alpha-2 → oneiric-alpha-3
importance: High → Medium
Quackers (quackers) wrote :

I too have the above symptoms in unity.
However, in gnome-shell the system loads fine but when the pointer is moved to top left to get the Applications menu, the desktop crashes and defaults to fallback.

Jeremy Bicha (jbicha) wrote :

I disagree with the "Go to" and "Bookmarks" menus being useful on the Desktop. People should use the Files app for file management (which I think already has a Unity quicklist). The Desktop is not a file browser because it can only show one folder. The Help menu is also confusing since it points to file management help. A few people really like GNOME 2's easy access to the Connect to... button but that's not too hard to find in Files.

Doug McMahon (mc3man) wrote :

Jeremy Bicha wrote >
I disagree with the "Go to" and "Bookmarks" menus being useful on the Desktop. People should use the Files app for file management

The bookmarks menu is quite useful on the desktop, why the desire to push people to one way only.
As I remember the appmenu on desktop focus was part of the design in natty (& clearly specified what it should show
Has that 'design' changed?

Doug McMahon (mc3man) wrote :

As discussed here
Bug 692194

Didier Roche (didrocks) wrote :

Raise the importance of this bug as it's really visible at login time in particular and for gnome-shell session.

Changed in nautilus (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-2
importance: Medium → High
Ted Gould (ted) on 2011-09-06
Changed in unity-foundations:
status: New → Triaged
importance: Undecided → High
Changed in nautilus (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Ted Gould (ted)
Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
milestone: none → oneiric-beta-2
tags: added: rls-mgr-o-tracking
Dmitry Shachnev (mitya57) wrote :

Also, when using Unity 2D, desktop menu is not visible by default, but if you click on the left indicator and press the left-arrow-key, it will be shown. (Or should I file a new bug for this?)

Florian Boucault (fboucault) wrote :

@Dmitry, it is indeed a separate issue specific to Unity 2D.

Dmitry Shachnev (mitya57) wrote :

@Jeremy:

> People should use the Files app for file management (which I think already has a Unity quicklist)
No, it doesn't, see bug 723862.

Andrea Cimitan (cimi) wrote :

Updated ubuntu menu proxy patch... someone to review it?

The attachment "043_ubuntu_menu_proxy.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

I am just not 100% sure that, in size_allocate, I should set the allocation to -1, -1, 1, 1 or to 0, 0, 0, 0 but still moving the window to -1, -1, 1, 1. Opinions?

Andrea Cimitan (cimi) wrote :

Another issue related to this new patch might need a bit more discussion. Ted please ping me on IRC

tags: added: testcase
manny (estelar57) wrote :

well i just broke my desktop using "New Tab"... :

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/854875

Matthieu Baerts (matttbe) wrote :

I have used this new patch and I confirm that it fixes the bug (I didn't see any other bug at the first look but I didn't analyse the patch carefully)

PS: if someone wants to test it, this new version is available there: https://launchpad.net/~matttbe/+archive/ppa

Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
milestone: oneiric-beta-2 → oneiric-final
Dave Walker (davewalker) on 2011-09-23
Changed in nautilus (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Martin Pitt (pitti) wrote :

I don't quite understand how this is a bug? The menu is hidden by default, and once you are over it you might actually want to work with the desktop icons? E. g. use the bookmarks menu to connect to a remote server, or create a new folder on your desktop, etc.?

Changed in nautilus (Ubuntu Oneiric):
importance: High → Medium
Didier Roche (didrocks) on 2011-09-27
summary: - appmenu shows nautilus menu when desktop is displayed
+ appmenu shows normal nautilus menu when desktop is displayed (not the
+ tweaked desktop one)
Didier Roche (didrocks) on 2011-09-27
tags: added: didrocks-oneiric-list

@pitti, ubuntu-desktop-team: please don't change the importance! If we don't use the Gnome-Panel or the Unity panel, the desktop is ugly with this (dark) menu bar on the top of the screen :-/
I no longer have this bug because I use a modified version of gtk+3.0 by using the new version of this patch given in this bug report by cimi: 043_ubuntu_menu_proxy.patch

Matthieu Baerts (matttbe) wrote :

This is what I have without the new version of the patch.

Ted Gould (ted) wrote :
Changed in unity-foundations:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in gtk+3.0 (Ubuntu Oneiric):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.0-0ubuntu3

---------------
nautilus (1:3.2.0-0ubuntu3) oneiric; urgency=low

  [ Marco Trevisan (Treviño) ]
  * debian/patches/12_unity_launcher_support.patch:
    - Fixed a typo that lead to bad computation of progress for
      files with size >= 2GB due to a type overflow (LP: #845188)

  [ Ted Gould ]
  * debian/patches/05_desktop_menu_export.patch: Update for Nautilus 3.x
    (LP: #805252)

  [ Didier Roche ]
  * clean the above patch from duplication and add DEP3 info
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 09:40:29 +0200

Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Fix Released
Dmitry Shachnev (mitya57) wrote :

Now the last entry in Bookmarks menu is "x-nautilus-desktop". Should I report a new bug for that?

Doug McMahon (mc3man) wrote :

With a fresh install of 09/27 daily which updated "nautilus (1:3.2.0-0ubuntu2) to 1:3.2.0-0ubuntu4", it is still using the 'normal' nautilus menu.
No change whatsoever

Didier Roche (didrocks) wrote :

@Dmitry: please open a new bug with a screenshot yeah
@Doug: did you logout/login again after the update? Seem Dmitry had the new menu and I confirm the menu is different now, there is no File -> open a new tab, and there is a help menu with only one entry "Ubuntu Help"

Doug McMahon (mc3man) wrote :

Yes - I've done log out/ins & full restarts.
This 09/27 daily image install also seems to showing some poor behavior in other area's, I think I'll dump it & install either todays or tomorrows daily (or go back to beta 2 updated

Dmitry Shachnev (mitya57) wrote :

@Didier: It seems to be my fault, not a bug.

But there is another issue: Ctrl+T shortcut is still working and breaks the desktop (see bug 814799).

Didier Roche (didrocks) wrote :

@Dmitry: yeah, this one is known and we can't do anything about it at this point. Thanks for the new bug with it :)

Ted Gould (ted) on 2011-09-29
Changed in unity-foundations:
status: Fix Committed → Fix Released
Matthieu Baerts (matttbe) wrote :

@Didier: I confirm what said Doug. I still have the bug and I'm using the latest version of nautilus 1:3.2.0-0ubuntu4 (and gtk+3-0 without cimi's patch)

Doug McMahon (mc3man) wrote :

I'm now on a new 09/29 fully updated (main repos) and still see the old 'normal' menu
Note that this initially also inc. a unity-4.20 upgrade, though had to downgrade unity to 4.18 for hopefully obvious reasons

Martin Pitt (pitti) wrote :

Now I don't get any desktop menu or the Ubuntu icon/"Desktop" string at all until I open a nautilus window once. nautilus is running by default (with -n), so that's not it.

Martin Pitt (pitti) wrote :

More precisely, it doesn't need to be a nautilus window. Any window with a menu will do (tried d-feet and gnome-terminal). So it seems the initial nautilus menu needs a kind of a "poke" to be shown in the app menu?

Changed in nautilus (Ubuntu Oneiric):
status: Fix Released → Triaged
summary: - appmenu shows normal nautilus menu when desktop is displayed (not the
- tweaked desktop one)
+ appmenu shows wrong menu when desktop is displayed (not the tweaked
+ desktop one)
Martin Pitt (pitti) wrote :

Ah, Didier pointed out that it's actually a focus bug: It already works if you click on the empty desktop once.

Matthieu Baerts (matttbe) wrote :

@ pitti: but what about cimi's patch for gtk+3-0? I've tested and it fixes the bug but I don't know if it's a problem for something else (didn't see anything wrong)

Dmitry Shachnev (mitya57) wrote :

@Matthieu Baerts: What you experience is bug 826771, which is a separate issue. Does patch from Cimi fix that?

Matthieu Baerts (matttbe) wrote :

@Dmitry: ok thank you! Yes this patch fixes my problem ( bug 826771 ).

Doug McMahon (mc3man) wrote :

The 'tweaked' desktop focus appmenu is now showing up correctly (09/29 install, 09/30 live session

Michael (idmer) wrote :

I haven't see a menu, but panel still exists!
Version: 1:3.2.0-0ubuntu5.

Didier Roche (didrocks) wrote :

@Michael: you are using GNOME Shell, not Unity. This bug is about the appmenu integration in Unity.

Martin Pitt (pitti) wrote :

This was fixed recently, the desktop now shows the reduced nautilus menu.

Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Fix Released

Is it possible to complete eliminate (or hide) the Nautilus menu on the desktop?

I have just accepted the automatic update from Ubuntu Natty to Ubuntu Oneiric,
I am using the fallback mode of Gnome 3 (gnome-panel instead of gnome-shell:
http://www.vuntz.net/journal/post/2011/04/13/gnome-panel-is-dead,-long-live-gnome-panel! ),
and I was not used to this bar on the desktop.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers