Wallpaper is loaded twice with different alignment by gnome-session and nautilus (Oneiric)

Bug #804435 reported by Lucazade on 2011-07-01
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
unity-2d
High
Gerry Boland
Ubuntu
Low
Chris Coulson
nautilus (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

When using Unity-2D and gnome-session-fallback in Oneiric the wallpaper, painted by nautilus,
is not loaded correctly at session startup.
For some seconds is not aligned with screen, there is a large left margin colored grey,
then after some seconds is reloaded correctly and well-aligned.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.1.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic i686
Architecture: i386
Date: Fri Jul 1 18:51:10 2011
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Pedro Villavicencio (pedro) wrote :

that's is not an issue here, are you still seeing it with latest updates? does that only happens with the fallback?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

yes, I still see with latest updates and it happens only in the gnome-session-fallback.

I have to correct myself, the issue is present also using Unity-2D.

summary: - Wallpaper in the gnome-session-fallback is not loaded correctly
+ Wallpaper in Oneiric is not loaded correctly
description: updated

disabling nautilus feature to draw wallpaper and icons on desktop the issue is no more present (the wallpaper is painted instead by gnome-session).

org.gnome.desktop.background show-desktop-icons from true to false.

summary: - Wallpaper in Oneiric is not loaded correctly
+ Wallpaper is loaded twice with different alignment by gnome-session and
+ nautilus (Oneiric)
Changed in unity-2d:
importance: Undecided → High
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: none → 4.4
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Alberto Mardegan (mardy) wrote :

I confirm this bug, and it really seems to be caused by nautilus. In fact, if you disable nautilus autostart (by removing the /etc/xdg/autostart/nautilus.desktop file), the desktop background will not be painted.

Then, if you start "nautilus -n" manually from a terminal, you'll see the desktop background being shifted a few pixels to the right, and then reverting back to the correct position. This happens also when metacity is not running, which seem to exclude a window manager bug.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
tags: added: login
Alberto Mardegan (mardy) wrote :

@Lucazade: does bug 839610 describe the same behaviour you are seeing?
The "large left margin" you are seeing painted in grey, how many pixels (approximately) is it wide?

@Alberto
left margin seems small, just few pixels.. anyway it is not the only movement and stretch of wallpaper.
I made a video to explain the issue better, it is a bit slow becuase it is in a virtualmachine, from 0:36 to the end is relevant.

Florian told me a couple of days ago on irc that these issues are different, sincerly things are not so clear for me.
if you need anything else, i'm here!

Alberto Mardegan (mardy) wrote :

Thanks Lucazade!
Indeed, the issue that I experienced is what Florian described in bug 839610: it's also visible in your video, when the background quickly shift to the right by a few pixels. I couldn't reproduce the grey band on the left.

It seems you have disabled compositing; did you do it on purpose? If so, can you enable it again and see if things behave differently?

@Alberto
the big grey band on the left is visible only when metacity compositor is disabled.
(I usually disable it with low powered machines, like virtualbox and my intel gma500, because composite kill some performances, like scrolling in web browsers!)

instead the small grey band seems 15px wide

enabling comoposite things behave differently so i made another video

Florian Boucault (fboucault) wrote :

I had the issue here with compositing activated I am afraid.

Didier Roche (didrocks) wrote :

In addition to this, reverting to the natty version didn't fix it, all seems to due to compositing activated.

in gconf, disable: /apps/metacity/general/compositing_manager

Didier Roche (didrocks) wrote :

sorry, enter pressed:

In addition to this, reverting to the natty version didn't fix it, all seems to due to compositing activated.

in gconf, disable: /apps/metacity/general/compositing_manager and you won't get any more issue (that's why we didn't get any issue in metacity in natty).

In oneiric, if you enable compositing, you get tons of:

Inexplicable intersection with new extents!
resize_win (XSR): 1 rects, bounds: -9,17 (1938,1074)
expose_area (XSR): 1 rects, bounds: 0,24 (1920,1056)
repair_win (XSR): 1 rects, bounds: -9,17 (1938,1074)
determine_mode (XSR): 1 rects, bounds: -9,17 (1938,1074)
resize_win (XSR): 1 rects, bounds: -15,9 (1956,1092)
expose_area (XSR): 1 rects, bounds: 804,275 (708,21)
expose_area (XSR): 1 rects, bounds: 804,296 (4,550)
expose_area (XSR): 1 rects, bounds: 1508,296 (4,550)
expose_area (XSR): 1 rects, bounds: 804,846 (708,4)
repair_win (XSR): 1 rects, bounds: 795,268 (726,593)
expose_area (XSR): 1 rects, bounds: 1920,24 (1920,21)
repair_win (XSR): 1 rects, bounds: 1911,17 (1938,1194)
repair_win (XSR): 1 rects, bounds: -66,101 (66,379)
paint_all (XSR): 5 rects, bounds: -66,9 (3915,1202)
 -15,17 (3864,84)
 -66,101 (3915,379)
 -15,480 (3864,621)
 1911,1101 (1938,110)
repair_win (XSR): 1 rects, bounds: -35,376 (4,4)
repair_win (XSR): 1 rects, bounds: 0,45 (1920,1035)
configure notify 0 0 1
 extents (XSR): 1 rects, bounds: 20,96 (1884,708)
 xy (29 103), wh (1866 677)

which seems to be those rectangles.

Didier Roche (didrocks) wrote :

ok, wrong tab… /me takes more coffee…

Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Gerry Boland (gerboland) on 2011-09-14
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Chris Coulson (chrisccoulson) wrote :

This is a bug in gtk - patch sent upstream already

affects: unity-2d (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Changed in gtk:
importance: Unknown → Medium
status: Unknown → New
Gerry Boland (gerboland) wrote :

Can also be seen during login sequence of Unity. To reproduce, run

compiz --replace&

and watch the background wallpaper redraw.

Changed in unity-2d:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thanks Chris for finding the issue, there is a patch in accept commit upstream now ;-)

affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → Low
Changed in gtk:
status: New → Fix Released
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
status: Fix Released → Invalid
Changed in unity-2d (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: Invalid → Fix Released
Sebastien Bacher (seb128) wrote :

gtk+3.0 (3.1.92-0ubuntu1) oneiric; urgency=low

  * New upstream bug fix release.
  * Drop 000git_updates_since_3.1.90.patch
  * Refresh patches.

affects: gtk+3.0 (Ubuntu) → ubuntu
Changed in ubuntu:
status: In Progress → Fix Released
Changed in unity-2d:
status: Invalid → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.