Segmentation fault: nautilus_icon_container_search_entry_flush_timeout

Bug #804133 reported by André Ventura on 2011-07-01
This bug affects 184 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
High
Canonical Desktop Team
Oneiric
High
Canonical Desktop Team

Bug Description

Ubuntu oneiric (development branch)
nautilus 1:3.1.2-0ubuntu2

--

nautilus is crashing "randomly" and I've seen it happen when I open some folders (not one in specific), when I change from one open tab to another or even by scrolling on a folder:

Program received signal SIGSEGV, Segmentation fault.
nautilus_icon_container_search_entry_flush_timeout (container=0x27e3bc0) at nautilus-icon-container.c:4948
4948 nautilus-icon-container.c: No such file or directory.
 in nautilus-icon-container.c

--

Full backtrace attached.

André Ventura (afv) wrote :
André Ventura (afv) wrote :

Crashed again, this time on a folder with image files; I was changing from icon to list view (ctrl+2). Not reproducible…
Backtrace attached (it seems to have the same info as the one above).

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been sent upstream at https://bugzilla.gnome.org/show_bug.cgi?id=653800; feel free to subscribe to it.

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → New
tags: added: bugpattern-needed
Changed in nautilus:
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Medium → High
Changed in nautilus (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: removed: bugpattern-needed
florin (florin-arjocu) wrote :

Might be connected with another bug I reported and was maked as a duplicate of this one:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/834272

tags: added: rls-mgr-o-tracking
Svivi (svivi) wrote :

Hi,

I think I have the same problem. My system is up-to-date, but the Nautilus still freezes or crashes regularly.
For example when I try to open a folder or a file.
Moreover I can't open a file (or open to the preference menu) which is in the Desktop as the Nautilus immediately freezes.

I don't know what to do with it.

Svivi (svivi) wrote :

I hope it will help you to fix the bug.

When this bug happens to me the icon on the top where we can shutdown the system closes!

Yeah me too, I just get left with my username on the right. I can logout and shutdown that way but hopefully this bug'll be squashed soon :)

This crash happened to me while running Nautilus in GNOME Shell.

Changed in nautilus:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :
Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.0-0ubuntu5

---------------
nautilus (1:3.2.0-0ubuntu5) oneiric; urgency=low

  [ Jeremy Bicha ]
  * debian/patches/05_desktop_menu_export.patch:
    - Disable a few more items that don't work right in desktop mode

  [ Sebastien Bacher ]
  * git_handle_missing_icon.patch:
    - don't segfault on missing icon (lp: #860659)
  * git_gsettings_signals.patch:
    - don't segfault on preferences changes (lp: #807234)
  * git_no_typeahead_timeout_segfault.patch:
    - better handle the flush timeout, should avoid segfaults (lp: #804133)
  * git_dont_preview_empty_selection.patch:
    - check that the selection is non empty to avoid a segfault (lp: #812015)
  * git_correct_signal_handling.patch,
    git_no_signal_order_assert.patch,
    git_slot_closing.patch:
    - clean some signal handling issues leading to segfaults (lp: #795708)
  * git_close_pane_cleaning.patch:
    - needed changes for the previous patch
 -- Sebastien Bacher <email address hidden> Fri, 30 Sep 2011 12:23:46 +0200

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.