Use Unity as a registered XDG environment

Bug #803519 reported by Michael Terry on 2011-06-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Won't Fix
Medium
GNOME Disks
Fix Released
Medium
GNOME Keyring
Fix Released
Medium
GNOME Settings Daemon
Fix Released
Medium
Jockey
Undecided
Unassigned
Light Display Manager
Wishlist
Unassigned
Nautilus
Fix Released
Medium
Xdg User Dirs
Confirmed
Medium
Yelp
Fix Released
Medium
at-spi
Fix Released
Medium
gconf
Fix Released
Medium
gnome-control-center
Fix Released
Medium
gnome-menus
Fix Released
Wishlist
gnome-orca
Fix Released
Medium
gnome-power
Fix Released
Medium
gnome-user-share
Won't Fix
Medium
libcanberra
Confirmed
Medium
vino
Fix Released
Medium
apport (Ubuntu)
Medium
Martin Pitt
at-spi2-core (Ubuntu)
Undecided
Unassigned
gconf (Ubuntu)
Undecided
Unassigned
gnome-bluetooth (Ubuntu)
Undecided
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-disk-utility (Ubuntu)
Undecided
Unassigned
gnome-keyring (Ubuntu)
Undecided
Unassigned
gnome-menus (Ubuntu)
Undecided
Unassigned
gnome-orca (Ubuntu)
Undecided
Luke Yelavich
gnome-power-manager (Ubuntu)
Undecided
Unassigned
gnome-session (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
gnome-terminal (Debian)
Fix Released
Unknown
gnome-terminal (Ubuntu)
Undecided
Unassigned
gnome-user-share (Ubuntu)
Undecided
Unassigned
gwibber (Ubuntu)
Undecided
Unassigned
libcanberra (Ubuntu)
Undecided
Unassigned
lightdm (Ubuntu)
Wishlist
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned
policykit-1-gnome (Ubuntu)
Undecided
Unassigned
vino (Ubuntu)
Undecided
Unassigned
xdg-user-dirs-gtk (Ubuntu)
Undecided
Unassigned
yelp (Ubuntu)
Undecided
Unassigned

Bug Description

Currently, Unity pretends to be GNOME. It's a registered XDG environment (http://standards.freedesktop.org/menu-spec/latest/apb.html) but no tools look for its value, and few .desktop files use it.

But that's changing. At least indicator-datetime's preference window wants to be only shown in Unity and not shown in GNOME. So that's a solid example of why this would be useful. And it may be useful for other things in the future.

So many things need to change:
 * lightdm needs to set XDG_CURRENT_DESKTOP
 * gnome-menus needs to respect XDG_CURRENT_DESKTOP (gnome bug 653440)
 * desktop files throughout GNOME likely need to add "Unity;" to their OnlyShowIn or NotShowIn values

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.1.2-0ubuntu2

---------------
nautilus (1:3.1.2-0ubuntu2) oneiric; urgency=low

  * debian/nautilus-home.patch,
    debian/patches/10_show_in_unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Wed, 29 Jun 2011 17:10:55 +0100

Changed in nautilus (Ubuntu):
status: New → Fix Released
Changed in gnome-menus:
importance: Unknown → Wishlist
status: Unknown → New
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.0.2-1ubuntu6

---------------
gnome-control-center (1:3.0.2-1ubuntu6) oneiric; urgency=low

  * debian/patches/show_in_unity.patch:
    - Add Unity to many OnlyShowIn values (LP: #803519)
 -- Michael Terry <email address hidden> Wed, 29 Jun 2011 17:32:28 +0100

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in lightdm:
status: New → Triaged
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.0.1-0ubuntu2

---------------
gnome-bluetooth (3.0.1-0ubuntu2) oneiric; urgency=low

  * debian/patches/nodisplay_autostart.patch:
    - Don't display in "Startup Applications" (LP: #803917)
  * debian/patches/onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn values (LP: #803519)
 -- Michael Terry <email address hidden> Thu, 30 Jun 2011 16:00:55 +0100

Changed in gnome-bluetooth (Ubuntu):
status: New → Fix Released
Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → New
Changed in lightdm (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in gnome-control-center:
status: New → Fix Released
Michael Terry (mterry) on 2011-07-01
Changed in jockey:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 3.1.2-0ubuntu2

---------------
vino (3.1.2-0ubuntu2) oneiric; urgency=low

  * debian/patches/nodisplay_autostart.patch:
    - Don't show in "Startup Applications" (LP: #803917)
  * debian/patches/onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Fri, 01 Jul 2011 10:30:25 +0100

Changed in vino (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.0.0-1ubuntu2

---------------
gnome-disk-utility (3.0.0-1ubuntu2) oneiric; urgency=low

  * debian/patches/04_nodisplay_autostart.patch:
    - Don't show in "Startup Applications" (LP: #803917)
  * debian/patches/05_onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Fri, 01 Jul 2011 10:55:56 +0100

Changed in gnome-disk-utility (Ubuntu):
status: New → Fix Released
Changed in vino:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-disk-utility:
importance: Unknown → Medium
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-user-share - 3.0.0-2ubuntu2

---------------
gnome-user-share (3.0.0-2ubuntu2) oneiric; urgency=low

  * debian/patches/06_nodisplay_autostart.patch:
    - Don't show in "Startup Applications" (LP: #803917)
  * debian/patches/07_onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Fri, 01 Jul 2011 12:22:57 +0100

Changed in gnome-user-share (Ubuntu):
status: New → Fix Released
Changed in gconf:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-user-share:
importance: Unknown → Medium
status: Unknown → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-user-dirs-gtk - 0.8-1ubuntu2

---------------
xdg-user-dirs-gtk (0.8-1ubuntu2) oneiric; urgency=low

  * debian/patches/nodisplay_autostart.patch:
    - Don't show in "Startup Applications" (LP: #803917)
  * debian/patches/onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Fri, 01 Jul 2011 13:51:52 +0100

Changed in xdg-user-dirs-gtk (Ubuntu):
status: New → Fix Released
Changed in xdg-user-dirs:
importance: Unknown → Medium
status: Unknown → Confirmed
Michael Terry (mterry) on 2011-07-01
affects: gconf2 (Ubuntu) → gconf (Ubuntu)
Changed in gconf (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 3.0.2-0ubuntu2

---------------
gnome-power-manager (3.0.2-0ubuntu2) oneiric; urgency=low

  * debian/patches/15-nodisplay-autostart.patch:
    - Don't show in "Startup Applications" (LP: #803917)
  * debian/patches/16-onlyshowin-unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Fri, 01 Jul 2011 14:38:34 +0100

Changed in gnome-power-manager (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcanberra - 0.28-0ubuntu6

---------------
libcanberra (0.28-0ubuntu6) oneiric; urgency=low

  * debian/patches/02_nodisplay_autostart.patch:
    - Don't show in "Startup Applications" (LP: #803917)
  * debian/patches/03_onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn (LP: #803519)
 -- Michael Terry <email address hidden> Fri, 01 Jul 2011 15:03:38 +0100

Changed in libcanberra (Ubuntu):
status: New → Fix Released
Changed in libcanberra:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → Fix Released
Martin Pitt (pitti) on 2011-07-01
Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Changed in gnome-bluetooth:
status: New → Won't Fix
Martin Pitt (pitti) on 2011-07-01
Changed in apport (Ubuntu):
importance: Undecided → Medium
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.21.2-0ubuntu1

---------------
apport (1.21.2-0ubuntu1) oneiric; urgency=low

  * New upstream bug fix release. Changes since our trunk snapshot:
    - generic hook: Don't report package installation failures due to
      segfaulting maintainer scripts. We want the actual crash report only.
      Thanks Brian Murray.
    - hookutils.py, attach_wifi(): Also include wpasupplicant logs. Thanks
      Mathieu Trudel-Lapierre!
    - report.py: Fix bug patterns to correctly match against compressed report
      fields.
  * gtk/apport-gtk.desktop.in: Also show in Unity. Cherrypicked from trunk.
    (LP: #803519)
  * etc/default/apport: Turn Apport back on by default for Alpha 2.
 -- Martin Pitt <email address hidden> Fri, 01 Jul 2011 16:32:38 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Changed in vino:
status: New → Fix Released
Changed in gnome-disk-utility:
status: New → Fix Released
Michael Terry (mterry) on 2011-07-05
Changed in gnome-keyring (Ubuntu):
status: New → Fix Released
Changed in gnome-keyring:
importance: Unknown → Medium
status: Unknown → Fix Released
Michael Terry (mterry) on 2011-07-15
Changed in gnome-session (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.1.2-0ubuntu2

---------------
gwibber (3.1.2-0ubuntu2) oneiric; urgency=low

  * debian/gwibber.desktop:
    - Add Unity to OnlyShowIn value (LP: #803519)
 -- Michael Terry <email address hidden> Tue, 19 Jul 2011 14:40:13 -0400

Changed in gwibber (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.1.3-0ubuntu7

---------------
gnome-settings-daemon (3.1.3-0ubuntu7) oneiric; urgency=low

  * debian/patches/42_onlyshowin_unity.patch:
    - Add Unity to OnlyShowIn value (LP: #803519)
  * debian/control.in:
    - Remove Debian's Vcs fields
 -- Michael Terry <email address hidden> Tue, 19 Jul 2011 15:02:18 -0400

Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.0.1-0ubuntu3

---------------
gnome-terminal (3.0.1-0ubuntu3) oneiric; urgency=low

  * debian/patches/01_onlyshowin.patch:
    - Add Unity to OnlyShowIn value (LP: #803519)
 -- Michael Terry <email address hidden> Tue, 19 Jul 2011 18:21:19 -0400

Changed in gnome-terminal (Ubuntu):
status: New → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
Changed in at-spi:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gnome-orca:
importance: Unknown → Medium
status: Unknown → New
Changed in yelp:
importance: Unknown → Medium
status: Unknown → New
Luke Yelavich (themuso) on 2011-07-20
affects: orca (Ubuntu) → gnome-orca (Ubuntu)
Changed in gnome-orca (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-orca - 3.1.3-0ubuntu2

---------------
gnome-orca (3.1.3-0ubuntu2) oneiric; urgency=low

  * debian/patches: Some patch clean-up, as follows:
    - 02_no_default_desktop_item.patch: Drop
    - 06_orca_kill_speechd.patch: Drop, lets see how things behave without it
    - 07_orca_desktop_environment.patch: Moved higher in the list, and renamed
    - Deleted some other patches that were no longer included in the series file
    - 03_show_in_unity.patch: Orca needs to be loaded at unity startup, thanks to
      Michael Terry for the patch (LP: #803519)
 -- Luke Yelavich <email address hidden> Wed, 20 Jul 2011 12:13:30 +1000

Changed in gnome-orca (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-1-gnome - 0.101-2ubuntu4

---------------
policykit-1-gnome (0.101-2ubuntu4) oneiric; urgency=low

  * debian/polkit-gnome-authentication-agent-1.desktop:
    - Add Unity to OnlyShowIn value (LP: #803519)
 -- Michael Terry <email address hidden> Wed, 20 Jul 2011 11:21:26 -0400

Changed in policykit-1-gnome (Ubuntu):
status: New → Fix Released
Michael Terry (mterry) on 2011-07-20
Changed in lightdm:
status: Triaged → Invalid
Changed in lightdm (Ubuntu):
status: Triaged → Invalid
Michael Terry (mterry) on 2011-07-20
affects: at-spi (Ubuntu) → at-spi2-core (Ubuntu)
Changed in at-spi2-core (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.0.1-0ubuntu4

---------------
gnome-menus (3.0.1-0ubuntu4) oneiric; urgency=low

  * debian/patches/24_xdg_current_desktop.patch:
    - Support XDG_CURRENT_DESKTOP when parsing OnlyShowIn and NotShowIn
      keys. LP: #803519
 -- Michael Terry <email address hidden> Wed, 20 Jul 2011 13:48:25 -0400

Changed in gnome-menus (Ubuntu):
status: New → Fix Released
Changed in gnome-terminal (Debian):
status: Unknown → New
Changed in gnome-menus:
status: New → Fix Released
Changed in gnome-orca:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package yelp - 3.1.2-0ubuntu1

---------------
yelp (3.1.2-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Fixes LP: #809425
    - Adds Unity to OnlyShowIn (LP: #803519)
  * debian/patches/04_new_ubuntu_layout.patch
    - Dropped, obsolete
  * debian/patches/07_build_with_dsolink.patch
    - Dropped, obsolete
  * debian/patches/06_make_ubuntu_docs_default.patch
    - Use ubuntu-help as default instead of gnome-help
      (LP: #819158)
 -- Jeremy Bicha <email address hidden> Tue, 16 Aug 2011 09:49:09 +0200

Changed in yelp (Ubuntu):
status: New → Fix Released
Changed in gnome-settings-daemon:
status: New → Fix Released
Changed in yelp:
status: New → Fix Released
Changed in nautilus:
status: New → Fix Released
Changed in gconf:
status: New → Fix Released
Changed in gnome-terminal (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.