nautilus crashed with SIGSEGV in nautilus_window_slot_get_current_uri()

Bug #795708 reported by Cristian Aravena Romero on 2011-06-10
This bug affects 199 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus-open-terminal
Invalid
Undecided
Unassigned
nautilus (Ubuntu)
High
Dmitry Shachnev
Oneiric
High
Unassigned

Bug Description

Binary package hint: nautilus

Install dropbox and restart nautilus... crash nautilus

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.0.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Fri Jun 10 15:48:10 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110531.1)
ProcCmdline: nautilus -n
ProcEnviron:
 LANGUAGE=es_ES:en
 PATH=(custom, no user)
 LANG=es_ES.utf8
 LC_MESSAGES=es_ES.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x486984 <nautilus_window_slot_get_current_uri+4>: mov 0xb0(%rdi),%rax
 PC (0x00486984) ok
 source "0xb0(%rdi)" (0x000000b0) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 nautilus_window_slot_get_current_uri (slot=0x0) at nautilus-window-slot.c:655
 update_places (sidebar=0x20c46a0) at nautilus-places-sidebar.c:468
 g_closure_invoke (closure=0x2246e90, return_value=0x0, n_param_values=1, param_values=0x1c04ec0, invocation_hint=<value optimized out>) at /build/buildd/glib2.0-2.29.6/./gobject/gclosure.c:771
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x1d8e290, emission_return=0x0, instance_and_params=0x1c04ec0) at /build/buildd/glib2.0-2.29.6/./gobject/gsignal.c:3256
 g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=0x7fff6233b908) at /build/buildd/glib2.0-2.29.6/./gobject/gsignal.c:2987
Title: nautilus crashed with SIGSEGV in nautilus_window_slot_get_current_uri()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Changed in nautilus:
importance: Unknown → Critical
status: Unknown → New
Changed in nautilus (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
description: updated
Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
importance: Medium → High

Just had this crash happen to me while running GNOME Shell on Oneiric. I had Nautilus open for a while with two tabs open on my second workspace, then it crashed when I came back later from my first workspace to close it.

Changed in nautilus:
status: New → Fix Released
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.0-0ubuntu5

---------------
nautilus (1:3.2.0-0ubuntu5) oneiric; urgency=low

  [ Jeremy Bicha ]
  * debian/patches/05_desktop_menu_export.patch:
    - Disable a few more items that don't work right in desktop mode

  [ Sebastien Bacher ]
  * git_handle_missing_icon.patch:
    - don't segfault on missing icon (lp: #860659)
  * git_gsettings_signals.patch:
    - don't segfault on preferences changes (lp: #807234)
  * git_no_typeahead_timeout_segfault.patch:
    - better handle the flush timeout, should avoid segfaults (lp: #804133)
  * git_dont_preview_empty_selection.patch:
    - check that the selection is non empty to avoid a segfault (lp: #812015)
  * git_correct_signal_handling.patch,
    git_no_signal_order_assert.patch,
    git_slot_closing.patch:
    - clean some signal handling issues leading to segfaults (lp: #795708)
  * git_close_pane_cleaning.patch:
    - needed changes for the previous patch
 -- Sebastien Bacher <email address hidden> Fri, 30 Sep 2011 12:23:46 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Vince Marsters (vincemarsters) wrote :

I submitted a bug on Nautilus (lp: #867676) last night that has been marked as a duplicate of this but I am running 1:3.2.0-0ubuntu5

In summary I had nautilus opened (in Gnome Shell) for a while but when I went to close it Nautilus crashed

Pedro Villavicencio (pedro) wrote :

This seems to be still an issue with latest package, the upstream commit is applied to the package though, so i'll comment on the upstream report to let them know about it, thanks all.

Changed in nautilus (Ubuntu):
status: Fix Released → Triaged

I can also confirm that this is still an issue, as another crash just occurred when I tried quitting Nautilus through the Unity launcher's right-click menu. nautilus 1:3.2.0-0ubuntu5.

Changed in nautilus:
status: Fix Released → New
Matthieu Baerts (matttbe) wrote :

Hello,

Your crash is maybe due to the 'nautilus-open-terminal' package: have a look to the bug #869131

Mg_bob (robert-flatters) wrote :

Just install a version of 11.10 and have found that there is no menu option bar displayed anywhere. having to select different routes to get access to either the internet or application. Not sure if anyone else is suffering from this effect

#8

Yes that seems to be the problem...
by purging nautilus-open-terminal nautilus stopped crashing.

androith (androith) wrote :

sudo apt-get remove nautilus-open-terminal

fixes the issue for me as well.

Steffen Röcker (sroecker) wrote :

I don't have nautilus-open-terminal installed and get this crash.

Dmitry Shachnev (mitya57) wrote :

I have neither nautilus-open-terminal nor dropbox installed, and I just got this crash.

Changed in nautilus (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
Dmitry Shachnev (mitya57) wrote :

I've added a patch from upstream to the linked branch, it fixes the issue for me. The package should soon become available for testing in ppa:mitya57/nautilus.

Changed in nautilus:
status: New → Fix Released
Changed in nautilus-open-terminal:
status: New → Invalid
Changed in nautilus (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu6

---------------
nautilus (1:3.2.1-0ubuntu6) precise; urgency=low

  * debian/patches/18_fix_crash_in_get_current_uri.patch:
    - Upstream patch to fix crash in nautilus_window_slot_get_current_uri()
      (LP: #795708)
 -- Dmitry Shachnev <email address hidden> Mon, 05 Dec 2011 15:26:42 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

oneiric SRU uploaded, awaiting ubuntu-sru processing.

Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Fix Committed

Hello Cristian, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Bartosz Kosiorek (gang65) wrote :

I installed nautilus from proposed on Oneiric and the crash stop appearing.

Thanks.

Martin Pitt (pitti) on 2012-01-16
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu3.2

---------------
nautilus (1:3.2.1-0ubuntu3.2) oneiric-proposed; urgency=low

  * debian/patches/18_fix_crash_in_get_current_uri.patch:
    - Upstream patch to fix crash in nautilus_window_slot_get_current_uri()
      (LP: #795708)
 -- Dmitry Shachnev <email address hidden> Fri, 02 Dec 2011 20:37:11 +0400

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.