nautilus crashed with SIGSEGV in gtk_ui_manager_add_ui_from_string()

Bug #750788 reported by Perfecto on 2011-04-04
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Richard

Bug Description

Binary package hint: nautilus

Nothing

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: nautilus 1:2.32.2.1-0ubuntu11.1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Apr 4 23:47:30 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100804)
ProcCmdline: nautilus
ProcEnviron:
 LANGUAGE=es_ES:en
 PATH=(custom, user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fa3150f95d1: movdqu (%rdi),%xmm1
 PC (0x7fa3150f95d1) ok
 source "(%rdi)" (0x040526a0) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 gtk_ui_manager_add_ui_from_string () from /usr/lib/libgtk-x11-2.0.so.0
 nautilus_desktop_window_init (window=0x7fa304002150) at nautilus-desktop-window.c:114
 g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in gtk_ui_manager_add_ui_from_string()
UpgradeStatus: Upgraded to natty on 2011-03-27 (8 days ago)
UserGroups: adm admin audio avahi avahi-autoipd backup bin bluetooth cdrom clamav clamsmtp couchdb crontab daemon davac4 dialout dip disk fax floppy fuse games gdm gnats gnokii haldaemon iocard irc kmem libuuid list lp lpadmin mail man messagebus mlocate netdev news ntp operator pcscd plugdev postdrop postfix powerdev proxy pulse pulse-access rtkit sambashare saned sasl shadow src ssh ssl-cert staff sudo sys syslog tape timidity tty users usrp utempter utmp uucp video voice www-data

Related branches

Perfecto (perfecto) wrote :

StacktraceTop:
 __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:32
 IA__gtk_ui_manager_add_ui_from_string (self=0x7fa3040088f0, buffer=0x40526a0 <Address 0x40526a0 out of bounds>, length=-1, error=0x0) at /build/buildd/gtk+2.0-2.24.4/gtk/gtkuimanager.c:1686
 nautilus_desktop_window_init (window=0x7fa304002150) at nautilus-desktop-window.c:114
 g_type_create_instance (type=<value optimized out>) at /build/buildd/glib2.0-2.28.5/./gobject/gtype.c:1889
 g_object_constructor (type=<value optimized out>, n_construct_properties=3, construct_params=0x9b71b0) at /build/buildd/glib2.0-2.28.5/./gobject/gobject.c:1615

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

visibility: private → public
Changed in nautilus (Ubuntu):
importance: Medium → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Ted, that seems to be due to your desktop menu update

Changed in nautilus (Ubuntu):
importance: Low → High
status: Incomplete → Confirmed
assignee: nobody → Ted Gould (ted)
SaCroJazz (sacrojazz) wrote :

While trying to rename a file placed in the desktop a nautilus process crashed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.32.2.1-0ubuntu13

---------------
nautilus (1:2.32.2.1-0ubuntu13) natty; urgency=low

  * 16_desktop_menu_export.patch:
    * Protect on not being able to find the UI description file and
      getting an error. (LP: #750788)
 -- Ted Gould <email address hidden> Fri, 08 Apr 2011 14:35:50 -0500

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
Perfecto (perfecto) wrote :

In my case, I can confirm the fix is good because I can't reproduce the bug.

Changed in nautilus (Ubuntu):
assignee: Ted Gould (ted) → Richard (rattlesnakerich)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers