Desktop icons move after login

Bug #737758 reported by Nicolas Delvaux on 2011-03-18
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Wishlist
Unassigned
unity-2d
Wishlist
Unassigned
nautilus (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned
unity-2d (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Just after login my desktop is like screenshot 1.
Then if I open a window (ie Nautilus), maximize it and then close it, icons "warp" and my desktop becomes like screenshot 2.

I only notice this when the launcher has been resized (I tested with min and max size).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Fri Mar 18 20:03:07 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110311)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-03-18 (0 days ago)

Nicolas Delvaux (malizor) wrote :
Alex Launi (alexlauni) on 2011-03-23
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: bitesize
Didier Roche (didrocks) wrote :

This is between nautilus and unity, in fact, nautilus change the icon position depending if unity is running or not. so there are two possible fixes:
- delaying the *first* nautilus listening
- unity declaring on the bug way before nautilus…

Not a bitesize anyway.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Changed in nautilus (Ubuntu):
status: New → Confirmed
tags: removed: bitesize
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
Changed in unity-2d:
importance: Undecided → Wishlist
status: New → Confirmed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
importance: Undecided → Wishlist
Philipp (sacridex) wrote :

I have a similar problem. It does not depend on opening a window and i have only seen it in Unity, because i do not use Unity2D.
Sometimes after the login, my Desktop Icons are "tightened".
On my Screenshots you can see what i mean.
This does not occur in one step, but with every new bootup the Icons are more and more pulled towards each other.

Philipp (sacridex) wrote :

Here is the second Screenshot.

Philipp (sacridex) wrote :

Um there is no edit function, but more Details:
I have seen this occur on Ubuntu 11.10 as well as on 12.04 with latest patches(Jan 25th: Unity 5.0.0, Nautilus 3.2.1, Compiz 0.9.6)

Gaetano Gambilonghi (gaegae-o) wrote :

HI! Me too, i have the same problem. If i can help sending you some system information, i can do it. i'm on ubuntu 11.10 (updated).

Gaetano Gambilonghi (gaegae-o) wrote :

p.s. (even if my problem is more similar to bug #886667 and #943848)

Status changed to 'Triaged' because the bug is:

- Valid.
- Well described.
- Reported in the upstream bug tracker (Launchpad).
- Ready to be worked on by a developer.

Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged

Priority set to "low" because the bug is a cosmetic issue that does not limit the functionality of a non-core application.

Changed in nautilus (Ubuntu):
importance: Wishlist → Low
Changed in unity-2d (Ubuntu):
importance: Wishlist → Low
Changed in unity (Ubuntu):
importance: Wishlist → Low
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers