Nautilus trying to stat its bookmarks at startup makes bad interaction with nfs

Bug #72607 reported by Vincenzo Ciancia on 2006-11-20
10
Affects Status Importance Assigned to Milestone
Nautilus
Unknown
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

I have a bookmark in nautilus to an NFS-mounted partition, if I log in in gnome, with autofs/NFS enabled, I cannot log in, nautilus blocks the entire login process by hanging on NFS because the server is unavailable. While it's true that the problem lies in the NFS architecture, I think that nautilus should not stat/test existence for its bookmarks - not sure how to handle the problem. In any case, I cannot login now even rebooting the system (of course I will disable NFS), a timeout to the existence test should be added. Attaching a backtrace in case it helps.

(gdb) where
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb746fc76 in access () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7632506 in IA__g_file_test (
    filename=0x8231ec8 "/net/zapotek/media/hda6/users/gina/Amule-Incoming",
    test=G_FILE_TEST_EXISTS) at gfileutils.c:282
#3 0x080d6bb3 in nautilus_bookmark_uri_known_not_to_exist (bookmark=0x822d260)
    at nautilus-bookmark.c:563
#4 0x080d6f5a in nautilus_bookmark_connect_file (bookmark=0x822d260)
    at nautilus-bookmark.c:461
#5 0x080d70de in nautilus_bookmark_new_with_icon (
    uri=0x822ee18 "file:///net/zapotek/media/hda6/users/gina/Amule-Incoming",
    name=0x8231f00 "Amule-Incoming", has_custom_name=0,
    icon=0x8231cc0 "gnome-fs-directory") at nautilus-bookmark.c:494
#6 0x0806bf7f in nautilus_bookmark_list_load_file (bookmarks=0x822d1c8)
    at nautilus-bookmark-list.c:115
#7 0x0806cb59 in nautilus_bookmark_list_init (bookmarks=0x822d1c8)
    at nautilus-bookmark-list.c:166
#8 0xb76e789a in IA__g_type_create_instance (type=136504368) at gtype.c:1567
#9 0xb76ce952 in g_object_constructor (type=136504368,
    n_construct_properties=0, construct_params=0x0) at gobject.c:1041
#10 0xb76ccbdb in IA__g_object_newv (object_type=136504368, n_parameters=0,
    parameters=0x0) at gobject.c:937
#11 0xb76cd73f in IA__g_object_new_valist (object_type=136504368,
---Type <return> to continue, or q <return> to quit---
    first_property_name=0x0, var_args=0xbf9480e8 "\003") at gobject.c:981
#12 0xb76cd8f0 in IA__g_object_new (object_type=136504368,
    first_property_name=0x0) at gobject.c:795
#13 0x0806c243 in nautilus_bookmark_list_new () at nautilus-bookmark-list.c:511
#14 0x080951bc in nautilus_get_bookmark_list ()
    at nautilus-window-bookmarks.c:57
#15 0x0809521a in nautilus_window_initialize_bookmarks_menu (window=0x81f4068)
    at nautilus-window-bookmarks.c:303
#16 0x0809d463 in nautilus_window_init (window=0x81f4068)
    at nautilus-window.c:174
#17 0xb76e76ce in IA__g_type_create_instance (type=136257488) at gtype.c:1559
#18 0xb76ce952 in g_object_constructor (type=136257488,
    n_construct_properties=3, construct_params=0x81f2da8) at gobject.c:1041
#19 0x0809d1b3 in nautilus_window_constructor (type=136257488,
    n_construct_properties=3, construct_params=0x81f2da8)
    at nautilus-window.c:656
#20 0xb76ccbdb in IA__g_object_newv (object_type=136257488, n_parameters=4,
    parameters=0x81f3028) at gobject.c:937
#21 0xb76cd7e9 in IA__g_object_new_valist (object_type=136257488,
    first_property_name=0x813ba32 "app", var_args=0xbf948504 "")
    at gobject.c:1022
#22 0xb7ca1038 in gtk_widget_new () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x08071a20 in nautilus_desktop_window_new (application=0x81b6db0,
---Type <return> to continue, or q <return> to quit---
    screen=0x81910e0) at nautilus-desktop-window.c:116
#24 0x0806a8a9 in nautilus_application_open_desktop (application=0x81b6db0)
    at nautilus-application.c:776
#25 0xb7725cd0 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#26 0x08067889 in Nautilus_Shell_start_desktop (_obj=0x81e6c20, ev=0xbf948624)
    at nautilus-shell-interface-stubs.c:144
#27 0x0806b418 in nautilus_application_startup (application=0x81b6db0,
    kill_shell=0, restart_shell=0, no_default_window=0, no_desktop=0,
    do_first_time_druid_check=1, browser_window=0,
    startup_id=0x81c3f08 "_TIME109067060", geometry=0x0, session_to_load=0x0,
    urls=0x0) at nautilus-application.c:631
#28 0x0807badc in main (argc=1, argv=0xbf948944) at nautilus-main.c:360
#29 0xb73c78cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#30 0x08067621 in _start ()

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That is known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=322507. I've updated the bug with your comment

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in hardy?

Changed in nautilus:
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to 'New'. Thanks again!

Changed in nautilus:
status: Incomplete → Invalid
Changed in nautilus:
status: New → Invalid
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.