Nautilus freezes when the target of a symbolic link that is a parent of the current folder is deleted

Bug #708291 reported by Andrew on 2011-01-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

To reproduce the problem,

1) Create a symbolic link to a folder that contains a subfolder:
    mkdir -p a/b
    ln -s a c
2) Open Nautilus to the subfolder through the symbolic link:
    nautilus c/b
3) Remove the original subfolder and its parent:
    rm -r a

As expected, Nautilus displays an error dialog with the message "Could not display '/home/user/c'. The location is not a folder."

Unexpectedly, Nautilus continues to open duplicate error dialogs in an infinite loop, causing the computer to quickly become unresponsive. A screenshot of this is attached.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.32.0-0ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
Architecture: amd64
Date: Wed Jan 26 12:22:00 2011
ExecutablePath: /usr/bin/nautilus
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nautilus
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1462): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (awn-applet:1505): GLib-CRITICAL **: g_string_overwrite: assertion `val != NULL' failed
 (awn-applet:1505): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
 (awn-applet:1498): Wnck-CRITICAL **: wnck_application_get_windows: assertion `WNCK_IS_APPLICATION (app)' failed

Andrew (andrewkvalheim) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in nautilus (Ubuntu):
status: Incomplete → Expired
Andrew (andrewkvalheim) wrote :

This is still occurring in Oneiric Ocelot Beta 2.

Changed in nautilus (Ubuntu):
status: Expired → New
summary: - Nautilus produces error dialogs in an infinite loop
+ Nautilus freezes when the current folder is deleted if its parent is a
+ symbolic link
Andrew (andrewkvalheim) on 2011-09-25
summary: - Nautilus freezes when the current folder is deleted if its parent is a
- symbolic link
+ Nautilus freezes when the target of a symbolic link that is a parent of
+ the current folder is deleted
Robert Roth (evfool) on 2011-10-26
Changed in nautilus (Ubuntu):
status: New → Confirmed
Bryan Quigley (bryanquigley) wrote :

This appears to be fixed in Ubuntu Saucy.. can anyone else confirm?

Changed in nautilus (Ubuntu):
status: Confirmed → Incomplete
Andrew (andrewkvalheim) wrote :

Looks good to me in Nautilus 1:3.8.2-0ubuntu2; no duplicates of the error message.

Changed in nautilus (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers