DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered

Bug #699840 reported by Ralf Hersel on 2011-01-07
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

When i click on a FTP bookmark in Nautilus it comes up with this error message:
"DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered"

Mike McKee (reach-supermike) wrote :

I found that I can use it reliably without this DBus error, but only if I do this sequence of steps:

1. If I know the FTP point may have timed out, or if I have received a DBus error, I can go Places, Computer, and then look for the little eject icon next to my FTP point in the left sidebar of Nautilus (should you have that turned on) where I can see ftp as xxxx, right underneath the Network icon. I click it and it kills the Nautilus window. That may be a bug, but nomatter -- it works.

2. Then, I just go back up to Places, Connect To Server..., and type it in again.

Bonus if someone can either fix the bug or figure out how to make it so that I can have an icon on my desktop, or script, that does this reconnection step for me again. I mean, I have to connect to FTP points all day for my clients.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, are you still able to reproduce the bug? Could you attach your ~/.xsession-errors file to the report? thanks.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

I run a Samba server on a Xubuntu machine (11.04). That serves a laptop (Xubuntu 11.04 now with Gnome-panel installed) which works perfectly but I now get the error described on my main machine (Ubuntu 11.04 Classic). This is a new error. Up to recently it has worked perfectly.
Under 'Network' I normally see 2 icons:
'Server' & 'Windows Network'.
I don't get the server icon at all now but just the 'Windows Network'. When I click upon it I get:-
Unable to Mount Location
DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Kip Warner (kip) wrote :

I get this error frequently when opening files over sftp. I'm using gedit 2.30.4.

Could not open the file sftp://...

Unexpected error: DBus error
org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered

If I close the file that failed to open and then re-open it, it seems to work.

el_gallo_azul (el-gallo-azul) wrote :

I only think that 'duplicate status' might be wrong because bug #386417 refers to Samba, and I am not using Samba because I only use Linux computers at home, and also because Samba wrecked everything for me (made my desktop computer unusable, requiring me to reinstall Ubuntu) when I tred it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers