Uncaught crash when importing DVD as image

Bug #697699 reported by David Nielsen on 2011-01-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nautilus

Currently in Natty I am seeing a crash in Nautilus that is uncaught by Apport.

(likely requires libdvdcss)

1) insert DVD
2) in the Computer nautilus view right click DVD and select copy disc.
3) set as an image
4) when finished, insert new disc.
5) Now for some reason you need to hit reload or the copy disc option does not appear
6) Click copy disc

Now Nautilus crashes, however the DVD can be imported once Nautilus has been restarted.

Why this is uncaught by apport I don't know, also launch Nautilus in a terminal does not provide any helpful output.

In dmesg this seems to appear after every crash.

[224415.045326] nautilus[27315]: segfault at 700000008 ip 00007f0f5799c378 sp 00007fffd7555530 error 4 in libgobject-2.0.so.0.2705.0[7f0f57966000+50000]

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nautilus 1:2.32.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic x86_64
Architecture: amd64
Date: Wed Jan 5 15:27:11 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANGUAGE=da_DK:da:en_GB:en
 LANG=da_DK.UTF-8
 LC_MESSAGES=da_DK.utf8
 SHELL=/bin/bash
SourcePackage: nautilus
usr_lib_nautilus: nautilus 1:2.32.2.1-0ubuntu1file-roller 2.32.1-0ubuntu1nautilus-open-terminal 0.18-1gnome-disk-utility 2.32.1-0ubuntu3ubuntuone-client-gnome 1.5.1-0ubuntu2nautilus-share 0.7.2-14ubuntu1brasero 2.32.1-0ubuntu1evince 2.32.0-0ubuntu3ubuntuone-client-gnome 1.5.1-0ubuntu2nautilus-sendto 2.32.0-0ubuntu1totem 2.32.0-0ubuntu3ubuntuone-client-gnome 1.5.1-0ubuntu2

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
status: New → Invalid
Josh Leverette (coder543) wrote :

This is massively affecting me right now as I'm attempting to copy home videos which have been shot over the years and burned to DVDs into iso files. Its crashing when I request it to Copy a Disc immediately after copying one. Reopening.

Changed in nautilus (Ubuntu):
status: Invalid → Confirmed
Josh Leverette (coder543) wrote :

And Pedro... he doesn't need a crash report for this as he says Apport does not detect the event. I am able to reproduce this. Have you even tried?

Dan Wood (dan-wood) wrote :

Just to add that this affects me too.
Very annoying because when it happens I'm often in the middle of coying other files across my network, and when Nautilus crashes I lose those transfers mid way!

Let me know if there is anything useful I can test for you, although the crash doesn't seem to get 'caught' by Apport...

Sebastien Bacher (seb128) wrote :

there has been no such issue reported in years, assuming it doesn't exist in the current version of the code and closing

Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers