Can't create empty file with right click

Bug #63934 reported by Florent Mertens on 2006-10-04
50
Affects Status Importance Assigned to Milestone
Nautilus
Unknown
Medium
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Hi,

Since the last update of nautilus (2.16.1) you can't no more create empty file with right-click>create new document>empty file. Every time, you fall to a permission error :
"you do not have permissions to write to the destination"

William Grant (wgrant) wrote :

I can confirm this.

Changed in nautilus:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks for your bug. I've forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=359564

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Was due to a distro patch, this upload fixes the issue:

" nautilus (2.16.1-0ubuntu2) edgy; urgency=low
 .
   * debian/patches/02_umask.patch:
     - dropped for now, it creates issues on file creation (Ubuntu: #63934)
"

Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus:
status: Unknown → Rejected

Hi, what about using the 02_umask.patch from Debian? Like in

nautilus (2.17.1-0ubuntu1) feisty; urgency=low

 [...]
  * debian/patches/02_umask.patch:
    - updated version from Debian

It works fine in Debian and should not create issues for Ubuntu.

Sebastien Bacher (seb128) wrote :

Philipp it's fixed in feisty

Sebastien, I meant as a fix for edgy

Sebastien Bacher (seb128) wrote :

The bug doesn't apply to edgy, it was created by the patch which has been dropped before edgy

That's right, but the patch was intended to fix: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=314796

It is fixed in 2.16.3: http://bugzilla.gnome.org/show_bug.cgi?id=327249
It works in Debian experimental and is with the same patch fixed in Debian testing: http://packages.debian.org/changelogs/pool/main/n/nautilus/nautilus_2.14.3-8/changelog.html

I don't find a seperate bug for that issue in Ubuntu, but the bug is present and caused by removal of the prementioned patch.

I've created a separate bug for the umask issue: https://launchpad.net/ubuntu/+source/nautilus/+bug/88994

Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.