Ubuntu

nautilus location bar no longer recognizes ~ as /home/username

Reported by Reed Lipman on 2010-09-04
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned
Maverick
Low
Unassigned

Bug Description

Binary package hint: nautilus

TEST CASE:
1. open nautilus and enter '~' into the address bar see you get an error window
2. now install nautilus from maverick-proposed and see /home dir opens

In lucid, entering ~ in the address bar took you to $HOME. This isn't recognized in maverick, instead trying to take you to the relative path ./~

Steps to reproduce:
Navigate to /bin
In address bar, type ~

Error is "Could not find /~, please check the spelling and try again"

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.31.90-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Sep 4 18:43:04 2010
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nautilus

Reed Lipman (rmlipman) wrote :
Reed Lipman (rmlipman) on 2010-09-04
summary: - nautilus address bar no longer recognizes ~ as /home/username
+ nautilus location bar no longer recognizes ~ as /home/username
Changed in nautilus:
status: Unknown → New
Bruno Girin (brunogirin) wrote :

Confirmed on Maverick Beta.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Reed Lipman (rmlipman) wrote :

I submitted a patch upstream, but just in case I'm attaching it here as well.

tags: added: patch
Changed in nautilus:
importance: Unknown → Medium
Vadim Peretokin (vperetokin) wrote :

So 10.10 is out and ~ is still broken. Unfortunate because it was real helpful to use in instructions to clueless users who didn't know what their home folder is.

tags: added: patch-forwarded-upstream
removed: patch
Greg A (etulfetulf) on 2011-01-03
tags: added: regression-release
Omer Akram (om26er) on 2011-01-03
description: updated
Changed in nautilus (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Low
Omer Akram (om26er) wrote :

is fixed in Natty with nautilus 2.32.2.1-0ubuntu1

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Changed in nautilus:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Subscribed sponsors.

Sebastien Bacher (seb128) wrote :

thank you, I've rebased the changelog on the current version and upload, it will need to wait for the current proposed version to go in -updates before going in though

Changed in nautilus (Ubuntu Maverick):
status: Triaged → Fix Committed

Accepted nautilus into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Jake Tolbert (crazybilly) wrote :

Just updated from maverick-proposed. The test seems to be working great. If I run into any other problems with it, I'll post further--for now, it seems to be working great.

Great work, very much appreciated here.

Martin Pitt (pitti) on 2011-01-26
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.32.0-0ubuntu1.3

---------------
nautilus (1:2.32.0-0ubuntu1.3) maverick-proposed; urgency=low

  * debian/patches/100_dont_treat_tilda_as_a_relative_path.patch: (LP: #630512)
    - Open the user's home dir when '~' is entered into the address bar.
 -- Omer Akram <email address hidden> Mon, 03 Jan 2011 20:35:02 +0500

Changed in nautilus (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.