files deleted from usb storage devices mishandled

Bug #62642 reported by muszek on 2006-09-27
2
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Unknown
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nautilus

When user "deletes" file(s) from a USB storage device (such as an mp3 player or pendrive), they're moved to /media/$devicename/.Trash-$username and the space is not freed. Problems:
1. user experiences a shrinking space on the device (because those files are not really deleted).
2. those files do not appear in Gnome's Trash utility and can't be deleted via it.
3. nautilus doesn't show hidden folders by default, so user can't see .Trash-$username

It should be handled differently. Possible solutions:
1. Files are deleted permamenly from USB devices.
2. While nautilus shows contents of USB devices, it also shows hidden folders.
3. Gnome's Trash utility also checks for .Trash-$username of USB devices.

Scott Abbey (malakhi) on 2006-09-27
Changed in nautilus:
status: Unconfirmed → Confirmed
Luca Falavigna (dktrkranz) wrote :

This bug has been marked as a duplicate of bug #12893.

Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.