Nautilus browser doesn't automatically refresh

Bug #573160 reported by SeanK on 2010-05-01
88
This bug affects 17 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Since I installed Lucid, Nautilus no longer updates automatically when outside forces create or change files. I have to hit refresh in order for the changes to be visible. This also happens if I make a change (such as renaming, adding or deleting a file) in a second tab in Nautilus. The first tab must be refreshed in order to see the changes that occurred in the second tab.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: nautilus 1:2.30.0-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat May 1 09:54:27 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nautilus

SeanK (seank) wrote :
Leo Arias (elopio) wrote :

I tried to reproduce your issue, but I couldn't.
My version:
nautilus:
  Installed: 1:2.30.0-0ubuntu4

thanks,
pura vida.

m4cph1sto (dlreid) wrote :

I confirm this bug in 10.04, and I had it in 9.10 also. It's extremely annoying. Actually I have 10.04 installed on 2 systems, one 64-bit that experiences this bug, the other 32-bit and does not have this bug. So maybe it's exclusive to 64-bit systems. Just a guess.

Brendan_P (brendan-p) wrote :

Same issues, latest Lucid.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Does it happen on any directory? Could you try gvfs-monitor-dir on the directory and see if it lists changes?

 This will help us to find and resolve the problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Ok, so I have opened my ~/Pictures folder and on an open terminal I have executed "gvfs-monitor-dir ~/Pictures".
Using firefox I find an image and save it to ~/Pictures. However I see no message on the terminal. There seems to be no change. Looking at Nautilus, the window I have open at ~/Pictures, I don't see the photo in the folder, it doesn't show up until I hit F5 to refresh the page. Or, go back a folder and forth again. Then it shows up.

Another example. I take an archive. I open it and drag the folder (with files) it has inside it into a folder on a window of nautilus. The folder doesn't show up. If I refresh the window, it does.

I tried the following:
1) in a terminal "rm -rf <a folder>"
while having a nautilus window open at that folder. The folder disappears automatically from the window.

2) I delete a file/folder using delete key, in a nautilus window. The file/folder disappear automatically.

3) I go to the trash, restore the folder/file, it appears back where I deleted it from, automatically.

Maybe these help. Sorry for posting twice.

I don't know if this helps at all but I noticed that now, that this bug is happening, when I loaded a dvd into my drive, the dvd wasn't mounted automatically. I didn't appear in nautilus and no window poped up.
I had to go to "Places"->"Computer" and then click on it. Then it opened.

I attached a snapshot of my running processes right now, maybe it will help.
I am thinking that maybe some process that is supposed to detect those changes (on hard disk or on the hardware in general, I don't know) is not there and that is causing the issue.
If I restart my computer I don't know if the bug will happen again. I don't know what's causing it, I just know the symptoms :)

My running processes at the time the bug is happening.

Massimo Cora' (pescio) wrote :

Same thing here.

I've an opened nautilus window monitoring /tmp. From terminal I give a touch /tmp/a but nothing happens.

Massimo Cora' (pescio) wrote :

a killall -HUP nautilus solves the thing.
IMHO it's a nautilus problem.

johnthehick (jorgen43) wrote :

same here..

I did this:

sudo /etc/init.d/dbus-1 restart

and nautilus began to show me a running size update on a video being rendered. Prior to this, it wouldn't.

johnthehick (jorgen43) wrote :

oops, sorry, it was the reinstall of

gamin

and installation of

python-gamin

second one was done just for a test... so I'm not sure which one really did fix it.

The

sudo /etc/init.d/dbus-1 restart

gave me

sudo /etc/init.d/dbus-1: command not found error, so that is not the fix.

It's working right now so I don't want to uninstall python-gamin

Pete Bartel (pbartel) wrote :

I've had this problem for some time, too, on two 10.04 systems. Reinstalling gamin, installing python-gamin, killing nautilus all had no effect. However, someone mentioned Dropbox in a thread related to this problem, so I stopped Dropbox, and the autorefresh suddenly started working again. I restarted Dropbox, and the autorefresh continues to work (for now).

In my case, the autorefresh usually works after a reboot, but at some point in time it stops working until the next reboot. However, stopping Dropbox is the only way I've been able to recover autorefresh without a reboot.

It would be interesting to see how many of the people who have experienced this problem also have Dropbox installed.

Sebastien Bacher (seb128) wrote :

using gamin doesn't do a difference, nautilus and gvfs are using inotify

Brendan_P (brendan-p) wrote :

I can confirm I have dropbox installed and am effected by this.

Me too.

m4cph1sto (dlreid) wrote :

I have Dropbox installed on 2 systems, one with 32-bit Ubuntu one with 64-bit Ubuntu. The 32-bit system does not suffer from this bug. The 64-bit system does. Don't know if 32 vs 64 has anything to do with it, but it seems Dropbox is a common thread.

SeanK (seank) wrote :

I have recently reinstalled and no longer have the problem, but I can also confirm that I had Dropbox installed.

SeanK (seank) wrote :

I should also note that I stepped back down to 32 bit, mostly for Flash related reasons.

Daniel Pendolino (dpendolino) wrote :

This happens to me too running lucid 64bit with or without dropbox running. It says this bug will expire if there is no further activity, what other information is needed to change the incomplete status? This is a pretty annoying and harmful issue for me.

Is there some process that manages the auto-refreshing? Maybe if we could see the running processes at the time the bug is occuring we would find that someone has crashed. But we should know first how is nautilus doing the "auto refresh" :)

Daniel Pendolino (dpendolino) wrote :

I believe it's is all done via inotify. I've managed to seemingly solve the problem by increasing the value of /proc/sys/fs/inotify/max_user_watches from the default to 32000. I initially tried an increase of 16000 and tested a few directories and they refreshed automatically, I doubled it just to be safe.

clockworkpc (clockworkpc) wrote :

@ Daniel Pendolino

Did you have any trouble editing /proc/sys/fs/inotify/max_user_watches?

I tried:
gksudo gedit /proc/sys/fs/inotify/max_user_watches

And it told me "Unexpected error: Error writing to file: Invalid argument"

Funnily enough when I re-ran:
gksudo gedit /proc/sys/fs/inotify/max_user_watches

The value had changed to 32000. But I couldn't make a backup copy of the file either via gedit, nautilus, or even the terminal. According to sudo nautilus the File Properties windows has the file size as 0 bytes.

Daniel Pendolino (dpendolino) wrote :

@ clockworkpc

No, I didn't have any trouble but that's because I echoed the value into it and didn't try to edit it like a file. Since /proc is a special file system gedit may not be able to handle it or it just doesn't behave exactly as expected. I was able to use vim with no problem.

Also you can always append 'fs.inotify.max_user_watches=3200' to to your sysctl.conf and then reboot. That's also how to make the change persistent. Once you got the value changed did you see the bug anymore?

clockworkpc (clockworkpc) wrote :

@ Daniel Pendolino

Thanks for the tip :)

It seems to have worked. I've tested it and Nautilus refreshes immediately. I'll see how it goes though.

Thanks for explaining how to make the change persistent. I've appended the line 'fs.inotify.max_user_watches=32000' to /etc/sysctl.conf and will check it out on the next reboot.

clockworkpc (clockworkpc) wrote :

I recently set up Ubuntu on a new computer and came across this problem again. I only noticed it after installing Dropbox, so this reinforces my suspicion that Dropbox has something to do with it. Additionally, Dropbox seems to drag on Nautilus.

Does anyone know of a good alternative to Dropbox?

Leo Arias (elopio) on 2010-12-09
Changed in nautilus (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in nautilus (Ubuntu):
status: New → Incomplete
giuliano69 (giuliano-lotta) wrote :

I can confirm that with THREE PC in which I installed Dropbox, I'm experimenting the same problem.

Ubuntu lucid 10.04 32 bit

Fabio Marconi (fabiomarconi) wrote :

Hello
I've tested tis in Oneiric and I cannot reproduce, so it is fixed for me, can you confirm?
Thanks
Fabio

Changed in nautilus (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Mathieu Comandon (strycore) wrote :

Fabio,
The bug is triggered by running out of available inotify watches. Depending on your setup (number of files in Ubuntu One, size of music collection, etc) it may take a while before triggering this bug.

If you have manually increased the number of inotify watches to a reasonnable value, you shouldn't run into that bug at all.

I would mark this bug as duplicate of #879902 , but I'm not sure it's the correct thing to do so I'm just putting it in confirmed.

Changed in nautilus (Ubuntu):
status: Incomplete → New
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers