Ubuntu

Search button does not toggle search field

Reported by Jan Klopper on 2006-08-22
62
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Jaunty by Sebastien Bacher
Declined for Karmic by Sebastien Bacher

Bug Description

Binary package hint: nautilus

The search button in the nautilus toolbar does not toggle the location bar to become the location bar again.

as in:

notice the folder buttons in the location bar.
Press the search button.
Notice you cannot return to the folder button view by clicking search again.

The search button should toggle this. (maybe even change its icon)

Related branches

Greek Ordono (grexk) wrote :

Yes its a bug

Simon Law (sfllaw) wrote :

This is in the Browser Nautilus mode.

As a workaround, you may hit the Esc key to return to the location bar.

Changed in nautilus:
importance: Untriaged → Wishlist
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unknown → Unconfirmed

Actually, the ESC key doesn't work on browser mode with "folder buttons path", you have to change folder to make the search box disappear.

Changed in nautilus:
assignee: nobody → desktop-bugs
Radek Svarz (roseta) wrote :

Additionaly CTRL-F should follow the same behavior, i.e. toggling the search bar and changing the state of the search button. It is also described in https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/164839
which was marked as duplicate to this bug.

Changed in nautilus:
status: Confirmed → Triaged
Brian Kennedy (ekspiulo) wrote :

I agree that the behavior of the search button is unintuitive. There is no clear way to return to the state before you clicked the search button. The search should either open in a new tab by default or the search button should also remove the search interface and restore you to the directory you were currently browsing. It isn't logical that the search should replace the current directory unless it is operating on the current directory in some way, and in Ubuntu I believe this isn't the default behavior (ie the search takes place at Home regardless of the current folder, a behavior I also find confusing).

Changed in hundredpapercuts:
status: New → Confirmed
summary: - search button does not toggle
+ Search button does not toggle search field
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in hundredpapercuts:
milestone: none → round-2
Changed in hundredpapercuts:
milestone: round-2 → round-1
milestone: round-1 → none
milestone: none → round-1
Changed in hundredpapercuts:
assignee: nobody → Jean-Louis Dupond (dupondje)
Jean-Louis Dupond (dupondje) wrote :

I just uploaded a patch on the Gnome bugreport which fixes the bug!

Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in nautilus:
status: New → Confirmed

Jean-Louis, can you please attend to your patch upstream? Cosimo has given some feedback.

Jean-Louis Dupond (dupondje) wrote :

I've been trying to fix the comments :( but without luck atm :(

black (blackborn) wrote :

I've created a patch in the upstream bug with fixes for the feedback. Can someone please review it?
This is the last bug before round-1 of the papercuts is completed ;)

Michael Rooney (mrooney) wrote :

Marking as Triaged against the upstream bug with patch attached.

Changed in hundredpapercuts:
status: In Progress → Triaged
Stefan Hammer (j-4) wrote :

@black: I have tested your patch. Everything works fine, even the scenario mentioned in the feedback.
But there is a little blemish when toggling between search field and navigation window. The search window is some pixels smaller, so the content of the whole nautilus-window jumps up and down. This probably is because of the removed toggle between button and text-based location bar in the search window.

Is it possible to make both "windows" the same height? It looks really awful.

Rich Jones (richwjones) wrote :

Pics, Jango?

Stefan Hammer (j-4) wrote :

A pic is attached, where you can see, that the search window is some pixels smaller, than the navigation window.
When toggle to search window, the sidebar, and the folder content icons jump up and down.

I think it is because of the removed button, which toggles between text-based and button location bar.
This button needs more space than the text-input field.

antistress (antistress) wrote :

jango : what you've written reminds me of that bug http://bugzilla.gnome.org/show_bug.cgi?id=486839#c7 that has been fixed concerning the file chooser
maybe it can be helpful

Stefan Hammer (j-4) wrote :

i have just installed the new human-icon-theme version 0.34 which came with updates today (September 1st).
There icon for the toggle (between text and button location bar) was made smaller. So the button needy less space.
So this issue is fixed with human-theme, but still is present with other themes.

black (blackborn) wrote :

Nicely spotted jango. I've updated my patch upstream.

I also use GtkSizeGroup for solving the issue. This is like the file chooser commented by antistress. Thanks for the hint ;)

Stefan Hammer (j-4) wrote :

no problem. I will test your patch again :)

Stefan Hammer (j-4) wrote :

tested the new patch - it works fabulous :)
thanks black for fixing the issue!
I hope the patch is reported soon.
jango

Stefan Hammer (j-4) wrote :

Sorry, i found something else: If you already do a search, and you remove the criterion for the location, you can't toggle back to the navigation window! Clicking on the button does nothing!

Stefan Hammer (j-4) wrote :

There is another characteristic which is questionable.
When changing the location in the criterion bar, clicking onto the search toggle opens this new location as a browser window.
It would be logical, if it would bring you back to the folder, where you started the search.

For example:
The Documents-directory is your working place for some documents - then you need a file there and search for it. You change the location in criterion bar, so that it is detectable, and then you want to toggle back to your previous directory. The location chosen in the criterion isn't important any more, it was only for the search.

black (blackborn) wrote :

Updated patch in upstream for comment 19. How do you find the bugs, jango :P

About the questionable behavior. When you change the location in the search, you deliberately change the location. So I think it should go to that location, not a location in the past.

Stefan Hammer (j-4) wrote :

I actively search for them :D

Yea - I personally also can't decide what is the best. Because, if you want back to the previous folder, you can use the back button, too. So maybe it should do something else .

When i tried out your new patch, something interesting happened.
I started a search, and changed the criterion from location to file type. Then, when clicking the "Reload"-button the whole screen flickers black after one second. Can you confirm this? Found no bug-report about this issue.
This also happens in nautilus-2.27.91-0ubuntu3, so it has nothing to do with the patch.

Stefan Hammer (j-4) wrote :

Dennis Laumen [reporter], 2006-02-21 20:00:26 UTC:
"Make the Search button a toggle button (which lets the search bar appear and disappear)
and put a confirm button next to the textbox to execute the search."

What do you think about a "Go"-Button? There would be enough space for it.
There are people in the world, who make everything with their mouse.

black (blackborn) wrote :

@jango: Can't confirm your other bug. It looks like it's related with your graphic card.

Definitively there should be a Go-button. (Where in the process did I forgot an elementary thing like that)
Hope I can make a patch before I go on holiday on next week monday.

Stefan Hammer (j-4) wrote :

This flickering is because of a second partition mounted. If this partition is unmounted, it doesn't flicker.
For every partition mounted the screen gets black once.
I will open a new bug report about this.

I am in holidays for 3 month :D, but i am not able to write C yet.

black (blackborn) wrote :

I'm back. Patch with Go-button can be found upstream :-)
Start your testing engines jango...

Stefan Hammer (j-4) wrote :

wrote my test-result upstream... it is easier so.
It is a problem, that the go button does the same as the reload button now. Or he should do, at least.
Maybe you can unite them into one?
Made a mocup, how it can be. if it is too much work, then ignore it =)

Sebastien Bacher (seb128) wrote :

Not accepting the nominations that's neither a jaunty backport candidate nor a karmic blocker, the right place to discuss the change is the upstream mailing list usually since they get too many bugs and don't read those

Stefan Hammer (j-4) wrote :

I have written a mail to the mailinglist to discuss the decisions.

Stefan Hammer (j-4) wrote :

There is a comment upstram by Alexander.
He reviewed the bug and found only two issues with shortcuts... and some comments and spaces missing.
Let's finish it!

Changed in hundredpapercuts:
milestone: round-1 → r1
black (blackborn) on 2009-11-25
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Stefan Hammer (j-4) on 2009-11-25
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in hundredpapercuts:
assignee: Jean-Louis Dupond (dupondje) → Canonical Desktop Team (canonical-desktop-team)
Changed in hundredpapercuts:
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Sebastien Bacher (seb128) wrote :

unsubscribing the sponsors that change will go in lucid with the next upstream version

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.1-0ubuntu1

---------------
nautilus (1:2.29.1-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Make browser mode the default
    - Add split view mode
    - Browser UI reorganization
    - Better background support on multi-monitor setups
    - Support new "default location" on mounts
    - Add extension api to lookup NautilusFileInfo objects
    - Make the search toolbar button a toggle button (lp: #57210, #392292)
    - Change text selection when using f2 several times (lp: #55996)
    - Ctrl+shift does multiple range selection in list view (lp: #148297)
    - Correctly toggle the show hidden files option (lp: #318151)
    - Opening of unknown files types displays a list of softwares (lp: #435780)
    - Fix the end key action in the image details (lp: #448786)
    - Use correct Borders for the sidebar (lp: #380838)
    - Display tooltips over sidebar bookmarks (lp: #432485)
  * debian/control.in:
    - updated gnome-desktop requirement
  * debian/nautilus-data.gconf-defaults:
    - don't set browser mode there since that's upstream default now
  * debian/patches/01_manpage.patch:
    - the change is upstream now
  * debian/patches/91_correct_rgba_use.patch:
    - change by Cody Russell to fix rgba issue (lp: #491521)
  * debian/rules:
    - updated shlib version
 -- Sebastien Bacher <email address hidden> Wed, 06 Jan 2010 17:14:33 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) wrote :

Fix released in Lucid

Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Low
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.