Warnings in file "/usr/share/applications/nautilus-folder-handler.desktop"

Bug #552388 reported by Laurent Bonnaud on 2010-03-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
openSUSE
Won't Fix
Medium
desktop-file-utils (Ubuntu)
Low
Unassigned
Declined for Lucid by Sebastien Bacher
nautilus (Ubuntu)
Low
Unassigned
Declined for Lucid by Sebastien Bacher

Bug Description

Binary package hint: nautilus

Here is the problem:

# update-desktop-database
Warning in file "/usr/share/applications/nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Warning in file "/usr/share/applications/nautilus-folder-handler.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)

It is annoying because it appears during the execution of many postinst scripts during packages installation/upgrade.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: nautilus 1:2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic-pae 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic-pae i686
Architecture: i386
Date: Wed Mar 31 09:36:24 2010
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nautilus
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2364): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-terminal:2624): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and its file manager better by reporting this bug. I can confirm this issue myself.
The bug was already reported upstream -- at <https://bugzilla.gnome.org/show_bug.cgi?id=612694> -- and I'm adding that as a Bug Watch.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Sebastien Bacher (seb128) wrote :

let's change desktop-file-utils to not display those warnings in lucid, x-directory is still used in nautilus code and now is not the right timing to try if that's creating new issues to change nautilus

Changed in desktop-file-utils (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.16-0ubuntu2

---------------
desktop-file-utils (0.16-0ubuntu2) lucid; urgency=low

  * debian/patches/no_xdirectory_warning.patch:
    - don't display warnings about x-directory types in lucid since
      those are still being used in nautilus (lp: #552388)
 -- Sebastien Bacher <email address hidden> Wed, 07 Apr 2010 16:42:19 +0200

Changed in desktop-file-utils (Ubuntu):
status: Fix Committed → Fix Released
Changed in nautilus:
status: Unknown → Confirmed

Installing firefox via zypper, I see this warning:
Additional rpm output:
Warning in file "/usr/share/applications/nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Warning in file "/usr/share/applications/nautilus-folder-handler.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)

Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=612694

As it's only warnings and nothing is really broken or non-functional (the use is discouraged, but not prohibited) I decide to close as 'upstream bug'.

(Ubuntu for example, as noted in the linked bug, decided to change desktop-file-utils to not bark on this error)

*** Bug 626244 has been marked as a duplicate of this bug. ***

Changed in nautilus:
importance: Unknown → Medium
Changed in opensuse:
importance: Unknown → Medium
status: Unknown → Won't Fix
Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is fixed in oneiric

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.