in suse i am unable to get all directories.

Bug #5326 reported by Luis Carlos Cobo on 2005-12-02
4
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I am not able to see some of the files in suse.if i listed directories, some are in hidden.how can i get it.

Daniel Holbach (dholbach) wrote :

Thanks for your bug report. Which version of Nautilus and Ubuntu do you use?

Changed in nautilus:
assignee: nobody → gnome
status: New → NeedInfo
Sebastien Bacher (seb128) wrote :

Is your issue specific to the desktop?

Luis Carlos Cobo (luiscarlos) wrote :

Up to date Ubuntu Breezy, Nautilus 2.12.1. If "specific to the Desktop" means if I can see this files from the terminal yes, I have no problem dealing with this files from the terminal.

Sebastien Bacher (seb128) wrote :

No, the desktop is the background when you start your session, by oposition to the nautilus windows you can open to browser other directories by example

Luis Carlos Cobo (luiscarlos) wrote :

Oh sorry, no it is NOT specific to the Desktop, actually I never had this kind of files in the desktop, the problem is in normal Nautilus window.

Sebastien Bacher (seb128) wrote :

Do you have the preference option to display hidden/backup files selected?

Luis Carlos Cobo (luiscarlos) wrote :

I tried with and without... and now comes the part where you will think I am joking... actually, I have a directory where I can see the *~ files, and another one where I can't. Both subdirectories of the same directory. Very strange... and I tried changing settings, pressing Ctrl+H and all that stuff... permissions are the same... I don't know where the problem could be.

Luis Carlos Cobo (luiscarlos) wrote :

As additinonal info, even in the dir where I see the *~ files, Ctrl+H doesnt show it (maybe this is the expected behaviour, but I think the 'Show hidden files' command should be 'Show hidden and backup files'). Also, changing the preferences doesn't work on the open window... I mean, I have to check the "Show hidden and backup files" and close the window and open it again to actually see the backup files. Again, with the other dir I never see the backup files, no matter what I do.

Luis Carlos Cobo (luiscarlos) wrote :

I have discovered another folder where *~ are not displayed. Again, I have set "Show hidden and Backup files", I open a new Nautilus windows and from that window I open the folders, and some display that files while other doesn't. I know this is really weird and I have no clue of which could be the problem. I will gladly provide any info or perform any test you think could be useful.

E-B (ebelt9hf) wrote :

this Bug is also in Dapper...

Sebastien Bacher (seb128) wrote :

Could you try that:
- you have the preference option for listing those activated
- have the menu option for the folder activated
- have reloaded the directory

and that you still get the issue? Can you get a simple case creating that behaviour?

Changed in nautilus:
assignee: gnome → desktop-bugs

The behavior is like this for me:

[Spatial Windows]
- As long as I didn't toggle visibility of hidden files via the menu, toggling the preference option works as expected.
- Toggling the menu option has no immediate effect and once I toggled it once, the preference option has no effect either (probably because it's overridden by the menu option).
- Reloading has no effect either, but closing and opening the window updates backup file visibility correctly.

[Browser Windows]
- Here I can't get the menu option to have any effect whatsoever, but the preference option works as expected as long as I _don't_ touch the menu option.
- Once I used the menu option, I have to close and open the window again with the preference option _enabled_ to make it work again.

That's pretty screwded up.

Luis Carlos Cobo (luiscarlos) wrote :

I confirm that behaviour too on spatial window...

Preference option always checked.
Touch something~ in a directory where the menu option IS NOT set (no hidden files). Then I set the option (Ctrl+H): all the files beggining with dot are showing, those ending in tilde aren't. If I leave set the menu option and close the nautilus window. Open it again, both .files and files~ show up. Unset the menu option, .files dissapear, files~ still there.

So, looks like for showing or not files~ we depend on the menu setting when we oppened the window, and once it is open, we are unresponsive to the preference changing.

Luis Carlos Cobo (luiscarlos) wrote :

By the way, I forgot to say I was using Breezy when I reported the bug in the first place, but I am using Dapper now (and the bug is still there).

Gary Coady (garycoady) wrote :

I think that this bug is a combination of two things:

#1: spatial windows remember their "do not show hidden files" and "do not show backup files" settings, and are not overridden by central preferences unless the window is set back to current defaults.
(Note: Both of the above preference settings are toggled by the same item in preferences.)

#2: the "Show Hidden Files" menu option only toggles the "do not show hidden files" option.

With #2 fixed, the behaviour should be a bit more logical...

This fixes the "Show Hidden Files" menu item in browser and spatial windows, so that the backup files are also shown.

To test:
Create "test~" in a directory.
Disable showing hidden files in preferences.
Look at the directory in nautilus.
The backup file visibility should be toggled by "Show Hidden Files".

Changed in nautilus:
status: Needs Info → Confirmed

Thank you for the patch, Gary. This upload fixes the issue:

 nautilus (2.14.1-0ubuntu3) dapper; urgency=low
 .
   * debian/patches/10_rename_desktop.patch:
     - patch by Gary Coady <email address hidden>, make renaming of a .desktop
       work with the language packs too (Ubuntu: #39002)
   * debian/patches/11_backup_files_list.patch:
     - patch by Gary Coady <email address hidden>, fix the backup files not listed
       when the hidden files option is used (Ubuntu: #5326)

Changed in nautilus:
status: Confirmed → Fix Released
moorthy (murali3653) on 2007-11-06
description: updated
Changed in nautilus:
status: New → Invalid
Changed in nautilus:
status: Invalid → Fix Released
Changed in nautilus:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.