Nautilus window quits on unmounting [when partition is launched from places menu]

Bug #530542 reported by Vish on 2010-03-02
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
New
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Steps to reproduce:
1: From Places > Select an unmounted partition
[nautilus window opens with the /media/partition ]

2: Now "unmount" the partition either using the unmount button or from the context menu.

Deviation:
Nautilus window just quits as soon as the partition unmounts

Expected behavior:
The window needs to be redirected to computer://

This seems to be a side-effect of a fix for Bug #386517
Earlier , the partition would just change to /media [tested in karmic install.]

Now , instead if the partition is mounted from the nautilus sidepane , the redirect to computer:// works as intended.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 6c350872f0b430ef8235c693ed2354c1
CheckboxSystem: 5484a8dd99f006173bd2ac53fa4837c2
Date: Tue Mar 2 13:42:24 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20091209)
Package: nautilus 1:2.29.91-0ubuntu1
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: nautilus
Uname: Linux 2.6.32-14-generic i686

Vish (vish) wrote :
summary: - Nautilus window quits on unmounting [when partition launched from places
- menu]
+ Nautilus window quits on unmounting [when partition is launched from
+ places menu]
Chris Coulson (chrisccoulson) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream. Thanks in advance!

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Luke Symes (allsymes) wrote :

Ok, I'm taking a look at this.

Vish (vish) on 2010-03-02
Changed in nautilus (Ubuntu):
status: New → Triaged
Luke Symes (allsymes) wrote :

I've looked through the problem and believe I have a solution. I have tried to test it out with different combinations of mount folders open etc. At the moment, the main reported problem is solved here, I can launch partition from Places and unmount without losing the window. Thus, taking it upstream with patch very soon.

Changed in nautilus (Ubuntu):
status: Triaged → In Progress
Luke Symes (allsymes) wrote :

Still in progress; my quick fix wasn't quite right. I'm discussing with upstream via mailing list about best way to properly implement the fix, which will probably be of the form "don't close window where you unmounted from".

Luke Symes (allsymes) wrote :

Patch series submitted to upstream bugzilla and mailing list email sent.

Working great with my internal hard drive, usb drive, and CD. After upstream discussion I have implemented this so that the window you unmount/eject/safely remove from will not be closed. I also made it so when you press the Eject button, e.g. on your CD drive, no windows are closed. The redirection to computer:// is still there, and maybe working better (not being called twice now).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.92-0ubuntu1

---------------
nautilus (1:2.29.92-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Make view default focus in new windows (lp: #520685)
    - Put tabs at the top again
    - Don't use deprecated gtk widgets
    - Allow Alt-<num> to switch tabs (lp: #521767)
    - Dynamically load tracker support
    - Don't auto-close the window you initiated an unmount in (lp: #530542)
  * debian/control.in:
    - update gtk requirement
  * debian/patches/90_relibtoolize.patch:
    - new version update
  * debian/patches/92_correct_initial_focus.patch,
    debian/patches/93_no_bottom_tab.patch:
    - dropped, the changes are in the new version
 -- Sebastien Bacher <email address hidden> Mon, 08 Mar 2010 17:08:22 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
importance: Unknown → Medium
The Bright Side (me-knowingme) wrote :

This bug occurs again in Ubuntu 11.10, 64 bit, Nautilus 3.2.1. I am running Gnome Shell.

Steps:
1. Insert USB device or mount NTFS partition of hard disk
2. Open Nautilus
3. Click on "Eject" icon next to device

The following behaviours are observed:
a) The USB device (not hard drive partitions) is unmounted and then disappears from the Devices list
b) Nautilus exits immediately upon clicking the "eject" icon

Reproduced: 5/10

Sebastien Bacher (seb128) wrote :

does nautilus exit or does it close a view on the device you eject (which is the normal behaviour since the said view becomes unavailable when the device is not there)

z (fgh4) wrote :

It doesn't exit but closes a view what is looks like a bug anyway.

And this bug is looks like a duplicate of 886327

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/886327

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.