Ubuntu

Translation problem in Nautilus (French version): 21ère

Reported by JF on 2010-02-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
Ubuntu Translations
Undecided
Ubuntu French Translators
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Bonjour.
J’ai noté un petit problème avec la version française de Gnome.
Je crée un nouveau répertoire : il s’appelle « nouveau dossier ».
J’en fais une copie en appuyant sur Ctrl et en faisant glisser l’icône du répertoire : la copie s’appelle « nouveau dossier (copie) ».
J’en fais encore une copie : elle s’appelle « nouveau dossier (autre copie) ».
J’en fais encore une copie : elle s’appelle « nouveau dossier (3e copie) ».
Je continue ainsi jusqu’à « nouveau dossier (20e copie) ».
J’en fais une nouvelle copie et, là, ça devient intéressant : elle s’appelle « nouveau dossier (21ère copie) ».
21ÈRE !!!
J’ai fait quelques centaines de copies, chaque fois que le numéro se termine par 11, je vois « 11e » (en anglais : elevenTH → 11th), alors que, quand le numéro se termine par 1 mais pas par 11, je vois « 1ère » (en anglais : first → 1st).
Il s’agit clairement d’un problème de traduction, l’anglais utilisant « first » là où le français utilise « unième ».
Comme les deux premières copies s’appellent « copie » et « autre copie », on pourrait très bien mettre le suffixe « e » à tous les numéros.

Configuration : Nautilus 2.28.1 sous Ubuntu 9.10

ProblemType: Bug
Architecture: i386
Date: Wed Feb 17 15:57:28 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: nautilus 1:2.28.1-0ubuntu3
ProcEnviron:
 LANG=fr_BE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: nautilus
Uname: Linux 2.6.31-19-generic i686

JF (jf-colson) wrote :
Draycen DeCator (ddecator) wrote :

I just confirmed this bug using Ubuntu 9.10 64-bit with French (France) as the language.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in ubuntu-translations:
assignee: nobody → Ubuntu French Translators (ubuntu-l10n-fr)
Changed in ubuntu-translations:
status: New → Invalid
Draycen DeCator (ddecator) wrote :

English translation of description using GT:

Hello.
I noticed a small problem with the French version of Gnome.
I create a new folder: it's called "New Folder".
I make a copy by pressing Ctrl and dragging the icon directory: copy called "new folder (copy).
I still have a copy: it's called "New Folder (another copy).
I still have a copy: it's called "New Folder (3rd copy).
I still well up to 'new File (20th copy).
I make a new copy, and here it gets interesting: it is called "New Folder (21ère copy).
21ÈRE!
I made a few hundred copies, each time the number ends in 11, I see "11th" (in English: Eleventh → 11th), so that when the number ends with 1 but not by 11, I see "1st" (in English: first → 1st).
This is clearly a problem of translation English, using "first" where the French use "first".
As the first two copies are called "copy" and "another copy", it could very well put the suffix "e" on all issues.

MarcRandolph (mrand) on 2010-02-19
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Download full text (3.7 KiB)

An automatic translation was not a very good idea, it makes things even
less comprehensible. This bug report was intended for the translation
team, therefore I thought they would understand French.

In fact, the problem is that French ordinal numbers don’t behave exactly
as their English counterparts.
FIRST is PREMIER in French (or PREMIÈRE for the feminine), therefore, 1ÈRE
COPIE would be a good translation of 1ST COPY.
But the 1st copy is simply named COPY, so we don’t need that translation.
For bigger numbers, for example 21, in English you say TWENTY-FIRST COPY,
while in French we say VINGT-ET-UNIÈME COPIE.
Using 21ÈRE COPIE in French would be as odd as 21TH (twenty-oneth) COPY in
English.

> English translation of description using GT:
>
> Hello.
> I noticed a small problem with the French version of Gnome.
> I create a new folder: it's called "New Folder".
> I make a copy by pressing Ctrl and dragging the icon directory: copy
> called "new folder (copy).
> I still have a copy: it's called "New Folder (another copy).
> I still have a copy: it's called "New Folder (3rd copy).
> I still well up to 'new File (20th copy).
> I make a new copy, and here it gets interesting: it is called "New Folder
> (21ère copy).
> 21ÈRE!
> I made a few hundred copies, each time the number ends in 11, I see "11th"
> (in English: Eleventh ? 11th), so that when the number ends with 1 but not
> by 11, I see "1st" (in English: first ? 1st).
> This is clearly a problem of translation English, using "first" where the
> French use "first".
> As the first two copies are called "copy" and "another copy", it could
> very well put the suffix "e" on all issues.
>
> --
> Translation problem in Nautilus (French version): 21ère
> https://bugs.launchpad.net/bugs/523236
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Nautilus: Unknown
> Status in Ubuntu Translations (internationalization and localization):
> Invalid
> Status in ?nautilus? package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: nautilus
>
> Bonjour.
> J?ai noté un petit problème avec la version française de Gnome.
> Je crée un nouveau répertoire : il s?appelle « nouveau dossier ».
> J?en fais une copie en appuyant sur Ctrl et en faisant glisser l?icône du
> répertoire : la copie s?appelle « nouveau dossier (copie) ».
> J?en fais encore une copie : elle s?appelle « nouveau dossier (autre
> copie) ».
> J?en fais encore une copie : elle s?appelle « nouveau dossier (3e
> copie) ».
> Je continue ainsi jusqu?à « nouveau dossier (20e copie) ».
> J?en fais une nouvelle copie et, là, ça devient intéressant : elle
> s?appelle « nouveau dossier (21ère copie) ».
> 21ÈRE !!!
> J?ai fait quelques centaines de copies, chaque fois que le numéro se
> termine par 11, je vois « 11e » (en anglais : elevenTH ? 11th), alors que,
> quand le numéro se termine par 1 mais pas par 11, je vois « 1ère » (en
> anglais : first ? 1st).
> Il s?agit clairement d?un problème de traduction, l?anglais utilisant
> « first » là où le français utilise « unième ».
> Comme les deux premières copies s?appellent « copie » et « autre copie »,
> on pourrait très bien mettre le suffixe ...

Read more...

Draycen DeCator (ddecator) wrote :

@JF
Thank you for your input. I do agree that the translation is not the best representation of what this bug is describing, which is why I left your initial description untouched. The translation is simply a means for developers and other bug triagers who may encounter similar reports to have an idea of what is going on, even if they do not speak French.

I especially felt this may be necessary since a member of the Ubuntu French Translators team has determined that this is not a translation issue on their end. If I understand Alexandre correctly, then the issue is in the programming of Nautilus. It seems that Nautilus is setup to use -st, -nd, and -th after certain numbers. When translated, the -st, -nd, and -th endings are replaced by their counterparts in the set language. However, the settings for which ending goes with which numbers remains the same as in English. This results in the behavior that you have described.

Since this is an issue with the programming of Nautilus, the bug has been filed upstream for the GNOME developers to look at. Along with the description that Alexandre provided in English on the upstream report, I thought it may help for the developers to be able to read an English translation of your description. While the translation is not perfect, it may help clarify the points that Alexandre made.

Thank you again for filing this report, and please continue to let us know of any problems you encounter so we can work to make Ubuntu better!

Alexandre Franke (afranke) wrote :

@Draycen
Indeed, you understood me correctly :)

JF (jf-colson) wrote :
Download full text (5.7 KiB)

> @JF
> Thank you for your input. I do agree that the translation is not the best
> representation of what this bug is describing, which is why I left your
> initial description untouched. The translation is simply a means for
> developers and other bug triagers who may encounter similar reports to
> have an idea of what is going on, even if they do not speak French.
>
> I especially felt this may be necessary since a member of the Ubuntu
> French Translators team has determined that this is not a translation
> issue on their end.

I’m a little surprised because they could very easily fix the problem (at
least for French).
I’m aware there are other languages whose ordinal numbers behave in a more
complicated way than in English. Therefore a more general solution to that
problem should be found in Nautilus itself. But for French
 see below:
— 1st: premier / première (*)
— 11th: onzième
— 21st: vingt-et-unième
— 31st: trente-et-unième
— 41st: quarante-et-unième
— 51st: cinquante-et-unième
— 61st: soixante-et-unième
— 71st: septante-et-unième / soixante-et-onzième (**)
— 81st: huitante-et-unième / quatre-vingt-unième / octante-et-unième (***)
— 91st: nonante-et-unième / quatre-vingt-onzième (**)
— 101st: cent-unième
(*) The first form is used for the masculine, the second one, for the
feminine.
(**) The first form is used in Belgium and Switzerland, the second one, in
France and Quebec.
(***) The first form is used in Switzerland, the second one, in Belgium,
France and Quebec, the third one is almost dead.

As you can see, where English uses first, French has three forms: premier
(-ère), unième and onzième.
Premier (-ère) is used only for the very first one, the one where English
simply uses the word “copy”. The translation “ère copie” for “st copy” is
then useless. In ALL other places where English uses “st copy”, French
always uses words with the suffix “-ième”.
So, if “st copy” was translated “e copie”, the problem would be solved for
French.

> If I understand Alexandre correctly, then the issue
> is in the programming of Nautilus. It seems that Nautilus is setup to
> use -st, -nd, and -th after certain numbers. When translated, the -st,
> -nd, and -th endings are replaced by their counterparts in the set
> language. However, the settings for which ending goes with which numbers
> remains the same as in English. This results in the behavior that you
> have described.

That’s what I understood, but I still pretend that the French translation
team could, at least temporarily, solve the problem: if they translated
“st copy” by “e copie” instead of “ère copie”, the problem would instantly
be solved for French.

>
> Since this is an issue with the programming of Nautilus, the bug has
> been filed upstream for the GNOME developers to look at. Along with the
> description that Alexandre provided in English on the upstream report, I
> thought it may help for the developers to be able to read an English
> translation of your description. While the translation is not perfect,
> it may help clarify the points that Alexandre made.
>
> Thank you again for filing this report, and please continue to let us
> know of any problems you encounter so we can wor...

Read more...

Draycen DeCator (ddecator) wrote :

@JF
Thank you for the response. I will let Alexandre explain why the French Translation Team has chosen not to alter their translation since I am not a member of that team.

As for the other bugs you have found, please look at the bugs section of Launchpad to see if they have been reported before. If they have, then you can add your findings to the reports and mark that they affect you. If they have not, then feel free to file new bug reports for them.

Changed in nautilus:
importance: Unknown → Undecided
status: Unknown → New
importance: Undecided → Unknown
status: New → Unknown
Alexandre Franke (afranke) wrote :

I've fixed this upstream. Please see the upstream bug report for further explanation.

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Omer Akram (om26er) wrote :

closing the ubuntu bug also since upstream bug has been closed as fixed for a few months now. if you still face this issue in ubuntu 10.04 or 10.10 feel free to open this bug again. thanks

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.