nautilus has tabs on bottom

Bug #509079 reported by Fernando Miguel on 2010-01-18
148
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Lucid by Steve Markgraf

Bug Description

Binary package hint: nautilus

recently Nautilus 2.29.1 in lucid started showing tabs on bottom.
This is a bad UI, and no other app does this.

ProblemType: Bug
Architecture: amd64
Date: Mon Jan 18 10:44:54 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091130)
NonfreeKernelModules: nvidia
Package: nautilus 1:2.29.1-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: nautilus
Tags: lucid
Uname: Linux 2.6.32-10-generic x86_64

Related branches

floid (jkanowitz) wrote :

This is intentional from the Nautilus crew:
http://arstechnica.com/open-source/reviews/2010/01/ubuntu-1004-alpha-2-brings-pitivi-panel-changes.ars

I'll chime in because I agree it's a bit gratuitously different and likely to confuse users who have managed to get familiar with browser tabs.

It would seem most obvious to put the tabs above the path widget, so that the path widget is a component of each tab (the "Chrome" approach, you could call it). That would make the path 'bounce' visually when going from a view with no tabs to tabs, but I doubt it would be that bothersome.

[And if this attracts attention, I think an even more pressing papercut is that, tabs or panes or spatial, it's still quite hard to distinguish between "/extremely/long/path/to/something" and "/media/mountpoint/extremely/long/path/to/something" in the common case of working with copies. Assigning a subtly different background color to removable devices by default would be one quick fix.]

Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
status: Triaged → Confirmed
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Low → Wishlist
status: Confirmed → Triaged
importance: Wishlist → Low
seanlano (seanlano) wrote :

I think this is a bit of a regression. Why would this be changed? I know the extra pane has been added, but to move tabs from the top to the bottom is a long way! At the very least this should be customisable in the Nautilus preferences.

Seriously, having the tabs at the bottom of the screen is like having the tabs on manila folders at the bottom of the filing cabinet drawer. It just doesn't make sense, when you're changing tabs you're probably going to be changing the file path at the same time, and having to move to the bottom of the screen is stupid and time-consuming.

Steve Markgraf (steve-m) wrote :

Seriously, this is a perfect example of UI changes that make me angry as hell.
Changing default settings is one thing, but what, you can't change it back?!
I mean, seriously, what were they thinking?
This is absolutely awful, _every_ program has the tabs on the top, every browser, Thunderbird 3 etc.

So I can't understand how the Nautilus developers can make a change with such a huge impact regarding user-(un)friendlyness, and don't even offer the user the possibility to change it back.

Remembers me of the Office 2007 menus somehow.

since this isnt going to be reverted upstream, let me add another one:
Nautilus lost Alt+NUM shortcut too.

For years gnome refused to add alt+tab while dragging and now even a simple feature to change the very badly positioned tabs, is also dropped :(

Ivo Wever (ivo-wever) wrote :

It's definitely a change that is hard to get used to. I've searched for a way to move the tabs back to the top, but I've been unable to find one. As this bug wasn't closed, I suppose there really isn't one?

Tom Pino (metalsmith-rangeweb) wrote :

The dual view is very nice but not at all worth it if you have to go to the bottom of the page for the tabs.

Some folks may like this. This is fine.

It slows me down way to much. I have several testing installations and do a lot of work on them through nautilus and I need the tabs where they should be for speed of work. That is at the top.

This really should be configurable.

Plz. no tabs at the bottom. This makes no sense to anybody.

Pretty much all programs has the tabs on the top, even other gnome-apps, except for Nautilus. If this isn't going to be changed upstream I think it's time for a Ubuntu patch to fix it.

VladimirCZ (vlabla) wrote :

Having the tabs only at bottom is a regression and an example of creative idiocy. Every program has the tabs on the top, every browser etc. If someone wants to have it inconsistently at bottom than this should be an option for him / her in the Nautilus preferences. Otherwise it is only a madness trigger for others.

Isak Frants (isakfrants) wrote :

Agreed. This is a huge mistake.

Interesting that the importance differs from wishlist to low when it clearly is an unfriendly forced change that won't be welcomed.

Until it is customizable it is a major change for the worst and if not fixed it should probably be reverted to its original functionality.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.91-0ubuntu2

---------------
nautilus (1:2.29.91-0ubuntu2) lucid; urgency=low

  * debian/patches/89_use_application_indicator.patch:
    - correctly show the menu for the new application indicator (lp: #522807)
  * debian/patches/92_correct_initial_focus.patch:
    - git change, correctly set the focus when opening a new dialog
      (lp: #505678)
  * debian/patches/93_no_bottom_tab.patch:
    - git update to revert the tab at the bottom change (lp: #509079)
 -- Sebastien Bacher <email address hidden> Wed, 03 Mar 2010 15:53:13 +0100

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Jan Nekvasil (jan-nekvasil) wrote :

Having tabs back on top is nice, but it breaks (again) some other things. When You are dragging a file from folder to one of the buttons in breadcrumb navigation, You often go across some other tab. If You are not fast enough (I mean really fast), crossing the tab activates it and the path represented by breadcrumb buttons changes to activated tab's path. Only way to avoid this is to drag upwards across source tab only, carefully around all other tabs, and then to right/left to destination button.

When I first saw the tabs at bottom, thought to myself: Oh, they are aware of this issue and this is supposed to be a fix. I do not declare that tabs at bottom are the ultimate good solution, but at least it solved this. Please, if that's possible, leave a gconf key to choose the tab placement.

On 3 March 2010 22:57, Jan Nekvasil <email address hidden> wrote:
> Having tabs back on top is nice, but it breaks (again) some other
> things. When You are dragging a file from folder to one of the buttons
> in breadcrumb navigation, You often go across some other tab. If You are
> not fast enough (I mean really fast), crossing the tab activates it and
> the path represented by breadcrumb buttons changes to activated tab's
> path. Only way to avoid this is to drag upwards across source tab only,
> carefully around all other tabs, and then to right/left to destination
> button.

Can you not move the mouse back over the wanted tab so it switches back?

Jonathon

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.