Nautilus crashes when there are multiple XScreens

Bug #508890 reported by Marc de Vries on 2010-01-17
270
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Nautilus
Unknown
Critical
nautilus (Ubuntu)
High
Alberto Milone
Nominated for Maverick by Roman Yepishev
Lucid
High
Alberto Milone

Bug Description

Binary package hint: nautilus

I'm under Lucid alpha 2, everything up to date.

nvidia-current 190.53-0ubuntu4

I installed the driver and it works correctly. As soon as I try to use a "Seperate X-Screen" (option in nvidia-settings) I can't start nautilus anymore. After login it looks like nautilus wants to start all the time though (taskbar, flickering on desktop).

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Sun Jan 17 21:22:03 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: nautilus 1:2.29.1-0ubuntu2
ProcCmdline: nautilus
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
Signal: 5
SourcePackage: nautilus
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 _XError () from /usr/lib/libX11.so.6
 ?? () from /usr/lib/libX11.so.6
 _XReply () from /usr/lib/libX11.so.6
 XInternAtom () from /usr/lib/libX11.so.6
Tags: lucid
Title: nautilus crashed with signal 5 in _XError()
Uname: Linux 2.6.32-10-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1745): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1745): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1813): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Marc de Vries (madevr-orange) wrote :

StacktraceTop:
 gdk_x_error (display=0x8d64490, error=0xbfc7785c)
 _XError (dpy=0x8d64490, rep=0x8f48f38)
 process_responses (dpy=0x8d64490,
 _XReply (dpy=0x8d64490, rep=0xbfc779e4, extra=0, discard=1)
 XInternAtom (dpy=0x8d64490,

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

seems similar to bug #508936

visibility: private → public
Marc de Vries (madevr-orange) wrote :

yep I can confirm that it seems to be the same issue.

Sebastien Bacher (seb128) wrote :

could you check if the screens are using the same visual using xwininfo?

Marc de Vries (madevr-orange) wrote :

here's the output from xwininfo on each monitor, seems like they're using different visuals:

primary monitor:
xwininfo: Window id: 0x1a00004 "madevr@madevr-desktop: ~"
  Absolute upper-left X: 3
  Absolute upper-left Y: 48
  Relative upper-left X: 3
  Relative upper-left Y: 23
  Width: 660
  Height: 435
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +3+48 -777+48 -777-417 +3-417
  -geometry 80x24+0+25

second monitor (seperate x-screen):
xwininfo: Window id: 0x4a00004 "madevr@madevr-desktop: ~"
  Absolute upper-left X: 3
  Absolute upper-left Y: 48
  Relative upper-left X: 3
  Relative upper-left Y: 23
  Width: 660
  Height: 435
  Depth: 24
  Visual: 0x13f
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x13e (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +3+48 -697+48 -697-285 +3-285
  -geometry 80x24+0+25

Emanuel Steen (kozz) wrote :

Different visuals here too:

Primary screen:
xwininfo: Window id: 0x2e00005 "Terminal"

  Absolute upper-left X: 622
  Absolute upper-left Y: 237
  Relative upper-left X: 3
  Relative upper-left Y: 23
  Width: 988
  Height: 694
  Depth: 24
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x20 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +622+237 -70+237 -70-119 +622-119
  -geometry 97x35-67+214

Secondary screen:
xwininfo: Window id: 0x3200005 "Terminal"

  Absolute upper-left X: 502
  Absolute upper-left Y: 203
  Relative upper-left X: 3
  Relative upper-left Y: 23
  Width: 818
  Height: 485
  Depth: 24
  Visual: 0x1aa
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x1a9 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +502+203 -600+203 -600-392 +502-392
  -geometry 80x24+499+180

Sebastien Bacher (seb128) wrote :

could one of you rebuild gtk with this change to get extra details on the issue? http://www.gnome.org/~alexl/dual-screen-spew.patch

Sebastien Bacher (seb128) wrote :

could one of you rebuild gtk with this change to get extra details on the issue? http://www.gnome.org/~alexl/dual-screen-spew.patch

let a comment if you need guidance on that or could use a binary version with the change...

Marc de Vries (madevr-orange) wrote :

well a binary or at least a little guidance would be nice... i don't really know how to handle the ubuntu.diff

Emanuel Steen (kozz) wrote :

My Monitor:
kozz@amd:0 > nautilus

** (nautilus:1545): WARNING **: No marshaller for signature of signal 'UploadFinished'

** (nautilus:1545): WARNING **: No marshaller for signature of signal 'DownloadFinished'

** (nautilus:1545): WARNING **: No marshaller for signature of signal 'ShareCreateError'
Initializing nautilus-gdu extension
Creating native window for 0x2136c80 (screen: 1)
attributes->colormap: 0x1e36820 (1), parent: 0x1e368a0, system: 0x1e368a0
attributes->visual: 0x1e32c00 (1), parent: 0x1e35c00, system: 0x1e35c00

Gdk-ERROR **: The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1127 error_code 8 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
[1] 1545 trace trap (core dumped) nautilus

My TV:
kozz@amd:133 > nautilus

** (nautilus:1591): WARNING **: No marshaller for signature of signal 'UploadFinished'

** (nautilus:1591): WARNING **: No marshaller for signature of signal 'DownloadFinished'

** (nautilus:1591): WARNING **: No marshaller for signature of signal 'ShareCreateError'
Initializing nautilus-gdu extension
Creating native window for 0x1142a00 (screen: 0)
attributes->colormap: 0xf628a0 (1), parent: 0xf62820, system: 0xf62820
attributes->visual: 0xf61c00 (1), parent: 0xf5ec00, system: 0xf5ec00

Gdk-ERROR **: The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 674 error_code 8 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
[1] 1591 trace trap (core dumped) nautilus

summary: - Nautilus crashes with Seperate X-Screen (nvidia-current)
+ Nautilus crashes when there are multiple XScreens
Sense Egbert Hofstede (sense) wrote :

Reported upstream.

Changed in nautilus (Ubuntu):
status: New → Triaged
Flávio Etrusco (etrusco) wrote :

Is it my impression or the latest xserver-xorg-core upgrade fixed it?

Emanuel Steen (kozz) wrote :

Which version of xserver-xorg-core do you refer to? My system is fully updated right now but the issue still exists for me with version 2:1.7.3.902-1ubuntu12.

Shame on me for not reporting the version (Yes I meant version
2:1.7.3.902-1ubuntu12).
And I apology too for the false alarm :-/ It seems some lxde/pcmanfm
upgrade hooked out the faulty nautilus process.

davsinc2007 (davsinc2007) wrote :

I am having this same issue. I am not an expert but would be glad to to contribute anything that is needed to resolve this bug.

Alen (cshadow) wrote :

Same problem here. Latest updates didn't help.

Flávio Etrusco (etrusco) wrote :

Too bad neither 'gdm' nor 'gnome-session' have packages for debug symbols.
Anyway dual screen setup isn't that great with metacity/gtk either
(e.g. no easy way to move from screen to another), and I finally got
the panels to work on dual-monitor single-screen setup. The only
annoying part is applications and dialogs' positions...

Luke Dixon (dixonl90) wrote :

I also have this issue:

I have 3 screens, 2 on one card and one on the other using the nvdia driver.

As soon as i log in, "starting file manager" appear in the panel and appears and disappears repeatedly for which seems an endless cycle. The CPU shows almost 100% usage.

I have discovered that selecting to log out forces this to end. A window appears stating that a program is still running, and clicking cancel on the alert window causes the "starting file manager" bug in the panel to end.

When using the two screens on one card on their own, this issue does not occur.

Sense Egbert Hofstede (sense) wrote :

Luke Dixon: Thank you for your comment, I've added it to the upstream bug report.

Roman Yepishev (rye) wrote :

I can confirm this with current Lucid Lynx.

This happens only when nautilus is managing the desktop, i.e. /apps/nautilus/preferences/show_desktop is true.
Regular nautilus processes (i.e. file manager windows) work properly.

Changed in nautilus (Ubuntu Lucid):
importance: Medium → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jason S. Wagner (jasonswagner) wrote :

Reproduced on Lucid Beta 1.

Changed in nautilus (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → Alberto Milone (albertomilone)
status: Triaged → In Progress
Alberto Milone (albertomilone) wrote :

Unfortunately this patch seems to be causing this bug: 91_correct_rgba_use.patch

Disabling it solves the problem. We're not using rgba decorations in Lucid, therefore reverting the patch shouldn't be a problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.92.1-0ubuntu4

---------------
nautilus (1:2.29.92.1-0ubuntu4) lucid; urgency=low

  * debian/patches/91_correct_rgba_use.patch:
    - disable patch as it was causing an endless loop where nautilus
      kept on crashing when attempting to draw the desktop on
      multiple screens (LP: #508890).
 -- Alberto Milone <email address hidden> Sun, 21 Mar 2010 01:07:51 +0100

Changed in nautilus (Ubuntu Lucid):
status: In Progress → Fix Released
Jason S. Wagner (jasonswagner) wrote :

I just received the updated nautilus package and confirmed this resolved my issue. Thanks for looking into this!

Robert Hrovat (robi-hipnos) wrote :

Todays update raised this issue again. After starting up, nautilus is trying to fire up but it keeps reloading and hogging cpu.

Robert Hrovat (robi-hipnos) wrote :

Downgrading with:

 dpkg -i /var/cache/apt/archives/nautilus_1%3a2.29.92.1-0ubuntu4_i386.deb

Solved the problem.

Sebastien Bacher (seb128) wrote :

the change was not commited to the vcs which leaded to get it dropped in the update, I've uploaded an update with it again now

TJ (tj) wrote :

Thanks Sebastien! I've just done a clean Lucid install into encrypted LVMs and configured nvidia-current for two X screens and hit this bug and it took me ages to track down this bug report.

TJ (tj) wrote :

Not wanting to wait for the buildd to publish the updated version (2.30.0-0ubuntu2) to the archives I have built it locally and confirm it does fix the issue.

Roman Yepishev (rye) wrote :

It looks like the problem reappears in Maverick. Again on the same hardware with nvidia 195.36.24-0ubuntu2 Nautilus crashes when it is managing the desktop.

Roman Yepishev (rye) on 2010-06-24
Changed in nautilus (Ubuntu):
status: Fix Released → New
GiBSON (wow-admin) wrote :

Bug nautilus appears as follows:
Open any folder;
Open a second tab;
Install SFTP connections of the second tab;
Create a folder on a remote server and go into it;
switch to the first tab;
Nautilus closes.

Alberto Milone (albertomilone) wrote :

@GiBSON: I think you're experiencing a different bug. Please file a new bug report about it.

@Roman: it looks like Robert Ancell re-enabled that patch (91_correct_rgba_use.patch) in nautilus 1:2.30.1-1ubuntu1

Demetris Mina (bizarrius) wrote :

I was trying to set up X Separate today and i am stuck on this bug. Any answers/fix or anything?
Thank you very much

My distro is ArchLinux

itchy8me (itchy8me) wrote :

problem has returned on maverick, nautilus 1:2.30.1-1ubuntu3

Cody Russell (bratsche) wrote :

So we're going to re-enable RGBA in the testing PPA, for anyone who has that configured. I've added some error handling that improves the stability for most apps I've tested, but I don't currently have two monitors to test this bug for. Can anyone help me figure out if we're still having issues with this one?

Roman Yepishev (rye) wrote :

@Cody, I seem to be unable to find the URL for the testing PPA. I'd like to try it since currently any attempt to re-enable show_desktop ends up in Nautilus being restarted after BadMatch X error.

briancb (brian-bosomworth) wrote :

The peculiar thing is that this was/is happening in Maveric. I was running Lucid on another partition with no problem. This morning after installing startup manager the problem started in Lucid. File Manager started over and over again.

This bug affects me too on a Sony Vayo VGN-Z:

G98 [GeForce 9300M GS]

Distribution: Ubuntu 10.10 (maverick)
Gnome Release: 2.31.6 2010-08-05 (Ubuntu)
nvidia-current (from ppa) 256.44-0ubuntu1

After login nautilus tries to start but always crashes.

I have to
  $> killall nautilus
by hand

If that does not work, I run it this way:
  $> while true; do killall nautilus; done
for some seconds. That works.

The 'bug-buddy' was not able to trace the crash back.

/var/log/messages reports:
Aug 15 14:13:47 vgn-z21mn nautilus: [N-A] Nautilus-Actions Tracker 2.30.2 initializing...
Aug 15 14:13:47 vgn-z21mn nautilus: [N-A] Nautilus-Actions Menu Extender 2.30.2 initializing...
Aug 15 14:13:49 vgn-z21mn kernel: [ 2602.597093] ptrace of non-child pid 8020 was attempted by: gdb (pid 8169)

(here the 'kernel' (third) line reports the failing of bug-buddy)

Then I startet a 'sudo nautilus /' it crashed as well and I became the attached bugreport.

I hope this helps tracing back the problem. I am not sure if this crash of 'sudo nautilus /' has the same reason as the crash of the
'Nautilus Desktop' after login..

hth

I switch between 1 and 2 Xscreens with a special key on my vaio VGN-Z wich causes an acpi event. That event links the /etc/X11/xorg.conf to the one needed for one- or for two X-Screens and restarts the gdm.

I made a workaround to bypass the trouble this bug effects:

I created the file /etc/gdm/PostLogin/Default as follows:

----------------------
#!/bin/sh
#
# workaround for bug https://bugs.launchpad.net/ubuntu/lucid/+source/nautilus/+bug/508890

    show_desktop='true'
    grep Screen1 /etc/X11/xorg.conf && show_desktop='false'
    eval su $USER -c \'gconftool-2 -s /apps/nautilus/preferences/show_desktop -t bool $show_desktop\'
----------------------

.. and made it executable.

This detects if 1 or two X-screens are driven and activates or deactivates the /apps/nautilus/preferences/show_desktop option as required.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.31.6-0ubuntu3.2

---------------
nautilus (1:2.31.6-0ubuntu3.2) maverick; urgency=low

  * debian/patches/91_correct_rgba_use.patch:
    - don't use that change again since rgba is not in maverick now and the
      change is still creating crash issues on dual screen configurations
      (lp: #508890)
 -- Sebastien Bacher <email address hidden> Mon, 16 Aug 2010 11:41:59 +0200

Changed in nautilus (Ubuntu):
status: New → Fix Released

OK. I can confirm that in build 1:2.31.6-0ubuntu3.2 this bug is solved.
Thanks!

Another Issue which is new with dual screen:

Invoking a Nautilus session from a launcher in the start menu or in the launchbar (panel) on Screen1 (the second screen) opens a window in Screen0 (the first screen). That looks definitively like a bug since all other applications are behaving normal (they open in the screen where the menu/panel resides).
When I create a launcher file on the desktop on screen1 (the second screen) and open it, the window apears on that screen as expected.
Do I have to open another bugreport for that?

Changed in nautilus:
importance: Unknown → Critical
Alex (alex112283) wrote :

I'm running 64 bit Maverick (nautilus 1:2.32.0) and this bug is affecting me as well.

Alex Sarmanov (sarmanos) wrote :

I'm running 64 bit Maverick (nautilus 1:2.32.0) too, same problem on two monitors.

dmuir (dmuir) wrote :

This seems to have regressed after updating today (Lucid).
Very frustrating. Is there an easy way to revert back to how things were yesterday?

dmuir (dmuir) wrote :

I had a look in /var/log/messages and I found:
Feb 16 11:29:12 dmuir-laptop kernel: [ 1471.725945] nautilus[6803]: segfault at 8 ip 00007f9dfaed0f4f sp 00007fff7f73e1f0 error 4 in libpython2.6.so.1.0[7f9dfadbc000+23e000]

I removed python-nautilus, and now my desktop is back! So ignore me. I'll got file a bug on python-nautilus.

Sebastien Bacher (seb128) wrote :

the new comments indeed seem a different issue

Anderson (andersonbessa) wrote :

Thanks for the tip Roman Yepishev.
That's solved my problem!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.