(SMB) share not remounted when resuming

Bug #498011 reported by smyrno on 2009-12-17
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

I found a bug which I think is in Nautilus, but concerning samba shared folders and mounting.
Using Ubuntu 9.10, Nautilus 2.28.1.

how to reproduce the bug :
1/mount a shared folder : Network>Hostname>sharedFolder.
2/go into sleep mode : cuts wifi connection.
3/do the same thing as step 1 : click on sharedFolder.
4/ gedit opens, trying to display sharedFolder, and saying this cannot be displayed.

I think that, due to the sleep period, the primarily mounted folder is unusable (login or authentication required maybe timed out.?)
So, to access the remote folder, i have to remount it, which this leads to that behavior with gedit when operating as described.
Unmounting the remote folder with the "eject" button before trying to remount in step 3 works, and should automatically be executed.

ProblemType: Bug
Architecture: i386
Date: Fri Dec 18 00:09:30 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
Package: nautilus 1:2.28.1-0ubuntu3
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: nautilus
Tags: ubuntu-unr
Uname: Linux 2.6.31-16-generic i686

smyrno (pied-henri) wrote :
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Dave Walker (dogatemycomputer) wrote :

smyrno:

When a share is mounted under Ubuntu it should create an icon on your desktop so you can access the share. Is the Desktop icon missing from your machine when returning from standby mode? If it is not missing then what happens when you double-click on it? Does it produce an error?

Changed in nautilus (Ubuntu):
status: New → Incomplete

Yes, when returning from standby mode, the shortcut is still displayed in
the "places" menu (as I don't have a real desktop with UNR) cliking on it
produces an error : It says (translated from french)

unable to mount "remote folder path"
error : invalid argument.

And I just experienced that after closing this error window, cliking again
on the shortcut opens correctly the remote folder.

smyrno:

Can you just confirm BEFORE attempting to open the share (after returning from standby) that you are able to open another network dependent application such as Firefox? I want to make sure your network connection is functional and passing traffic when double-clicking on the share icon found on your desktop.

Can you please take a screenshot of the error?

Could you also execute this from the terminal and post the results:

dpkg-query -W -f='${Package} ${Version} ${Source} ${Status}\n' | grep samba

I believe additional information will be needed there does not appear to be any debug logs created during the mounting/unmounting/accessing of shares. The default installation of Ubuntu does not enable logging of samba traffic and errors either (at least my /var/log/samba/* folder is empty).

Well. I wanted to be as clean as possible, and I restarted my computer. Now
I cannot reproduce the error :
I access without any issue to the folder by re-cliking it in the network
exploration mode and using the shortcut created, after sleeps.

in this experiment, sleeps lasted just few seconds, and I checked the
connection by connecting to google.

last time, I read your post before trying to re-mount as you were asking,
and I obtained the error I described. (I was connected)

I will myself go to sleep now, and try again later to confirm you the bug,
if any.

Results :
h@h-netbook~$ dpkg-query -W -f='${Package} ${Version} ${Source} ${Status}\n'
| grep samba
libpam-smbpass 2:3.4.0-3ubuntu5.1 samba install ok installed
libsmbclient 2:3.4.0-3ubuntu5.1 samba install ok installed
libwbclient0 2:3.4.0-3ubuntu5.1 samba install ok installed
samba 2:3.4.0-3ubuntu5.1 install ok installed
samba-common 2:3.4.0-3ubuntu5.1 samba install ok installed
samba-common-bin 2:3.4.0-3ubuntu5.1 samba install ok installed
smbclient 2:3.4.0-3ubuntu5.1 samba install ok installed

smyrno (pied-henri) wrote :

So, 6 hours of sleep later, I tried to re-access to the remote folder via
the network explorer. It displayed me an error message the first time i
clicked my folder (sorry, I couldn't catch this one). The second time, and
all following times, it opened gedit with the error shown in the
attachement. "smb://remoteFolder is a directory"

Clicking on the shortcut in the left hand side panel brings me to the
content i looked for, and the error doesn't happen again.

I will have to try again to see if cliking the shortcut leads to an error,
and to report the error shown when re-cliking the folder in the explorer.
and what happens when i mount another shared folder from the same server
before mounting the previously mounted folder.

I was able to reproduce the problem on my machine by mounting the share, putting it in hibernation mode, restoring the machine then attempting to access the share. The underlying mechanism should have some methods available for unmounting/remounting then reattempting access without forcing the user to unmount/remount the share manually.

Please keep in mind I am a new volunteer triager. If a developer feels this is not enough information to move forward then they may change the status to 'new' or 'incomplete' and request additional information.

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed

You all make a great work, It's my pleasure to help you!

On Sat, Dec 19, 2009 at 21:33, Dave Walker <email address hidden> wrote:

> I was able to reproduce the problem on my machine by mounting the share,
> putting it in hibernation mode, restoring the machine then attempting to
> access the share. The underlying mechanism should have some methods
> available for unmounting/remounting then reattempting access without
> forcing the user to unmount/remount the share manually.
>
> Please keep in mind I am a new volunteer triager. If a developer feels
> this is not enough information to move forward then they may change the
> status to 'new' or 'incomplete' and request additional information.
>
> Thanks for reporting this bug and any supporting documentation. Since
> this bug has enough information provided for a developer to begin work,
> I'm going to mark it as confirmed and let them handle it from here.
> Thanks for taking the time to make Ubuntu better!
>
> ** Changed in: nautilus (Ubuntu)
> Status: Incomplete => Confirmed
>
> --
> re-mounting a remote windows shared folder after a sleep fails
> https://bugs.launchpad.net/bugs/498011
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu and its file manager Nautilus better by reporting this bug.
I'm marking it as Triaged since our work here is done. I'm reporting this upstream.

summary: - re-mounting a remote windows shared folder after a sleep fails
+ (SMB) share not remounted when resuming
tags: added: resume
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → Invalid

Upstream bug has been marked as duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=559065

Changed in nautilus:
status: Invalid → Unknown
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
importance: Unknown → Medium
Nikolaus Filus (nfilus) wrote :

Still valid in Ubuntu Oneiric with Nautilus 3.2.1. I notified upstream too, but all ears are deaf.

Any chance this will be fixed jointly by Ubuntu and Gnome in the precise cycle?

Shane (shane-shanekillian) wrote :

I'm getting this same bug on 13.10 64-bit with Nautilus 3.8.2. Whenever I click on the icon for the share, it pulls up gedit with the same error that others have reported above. When I hit Ctrl-L and type in the name of the share, it works fine.

Changed in nautilus:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.