Nautilus doesn't prompt for WebDAV password if it is needed for writing only

Bug #493832 reported by Eric Martel on 2009-12-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
High
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

If in Apache I set a Dav directory with the following limit (read is allowed for everyone, but only authenticated users can write to it):

<Limit POST PUT DELETE>
                Require valid-user
</Limit>

Using a dav:// URL, Nautilus will access this directory in read mode, which is OK. However, if I try to put something into the directory, Nautilus won't prompt me for a password and just give me an access denied error.

If I try the same thing using Konqueror (with a webdav:// URL), Konqueror will also give me normal access in read mode, but if I try to put something into the directory then it will prompt me for a password and the transfer will then successfully occur: that is the expected behavior.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
status: New → Invalid
David Ayers (ayers) wrote :

The original report was marked as a duplicate of this one.

Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → High
status: Unknown → New
Changed in nautilus:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.