List view in Nautilus does not allow dragging a selection by mouse

Bug #49348 reported by Adam Lindberg on 2006-06-11
150
This bug affects 29 people
Affects Status Importance Assigned to Milestone
GTK+
New
Undecided
Unassigned
Nautilus
Confirmed
Wishlist
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

When viewing files in Nautilus one can drag a rectangle around them to mark certain files. This is not possible in the list view of Nautilus even though there is usually a large white space in folders with few files that can make a user believe that dragging with the mouse there would produce the same rectangle as in icon view. I do it all the time by habit, and it is very annoying.

Proposal:
* Make it possible to drag a rectangle in list view. The problem is that starting to drag on a list item moves that item. Konqueror has solved this that you have to drag on the item name itself to move, else a rectangle marquee is started. Personally I find this quite efficient but may be annoying for less experienced users...

Adam Lindberg (eproxus) on 2006-06-11
description: updated
Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=138931

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unknown → Confirmed
zewsk (zewsk) wrote :

Not sure If I should open a new thread on this, as this is related to file display modes.

in the wishlist category, and relating to being able to select files with the rubber band box, I would like to see a view option offering a compact text listing of files, with just file names, in columns. As a programmer I view directories with hundreds and sometimes thousands of files in them, and I like to see as many as possible at a glance.

This is basically one of the file view modes used in, ahem, one of those other operating systems. i.e. "list view" on, dare I say it, Windows. It's pretty useful and I think it would be a good addition to nautilus.

Changed in nautilus:
status: Confirmed → In Progress

I noticed that the file panel in Brasero has this feature. But it is not very well done.
Indeed, you have to first clic on the file to drag n drop it, otherwise it makes a rubber band. This is very annoying.

I prefer the MS Windows way (or Konqueror according to Adam), which makes the difference according to the start point of the rubber band (on files : dnd, outside files list: rubberband)

Changed in nautilus:
status: Confirmed → Triaged
rCX (rcx) wrote :

For clarity here are the steps to reproduce it...
1. Open a folder in Nautilus using "Icon View" or "Compact View"

2. Hold down the left mouse button and drag the cursor so that a selection box appears. Use the box to easily highlight multiple files.

3. Switch to "List View" and try step 2.

4. Be very annoyed as no selection box appears.

To workaround this users have to...

A. ...swith to "Icon View" or "Compact View" and perform step 2.

B. ...remember the Ctrl hotkey. Hold down Ctrl and select the files one at a time.

C. ...remember the Shift hotkey. While holding down the Shift, choose the 1st and last file. All files between (including the 1st and last) should be highlighted.

I also think drag-select should be allowed in "List View". This will reduce the frustration level in newbies like me :-)
 while making nautilus easier to use.

Idea at brainstorm:

 http://brainstorm.ubuntu.com/idea/4371/

Threads at ubuntuforums:

 http://ubuntuforums.org/showthread.php?t=147490

 http://ubuntuforums.org/showthread.php?t=460516

 http://ubuntuforums.org/showthread.php?t=257373

 http://ubuntuforums.org/showthread.php?t=720424

 ... and many more ...

(From a duplicate.)

"This is a new feature, not a trivial usability fix, so it is not considered a paper cut."

"Implementing the rectangular select in list view would involve writing and testing new code. I agree that it would be a great fix to make, and it affects usability greatly, but it requires new code, which is what I mean by it being a new feature. It's not a feature that you would advertise if you were selling Ubuntu, but it is a feature nonetheless."

Changed in hundredpapercuts:
status: New → Invalid
Changed in nautilus:
importance: Unknown → Wishlist
ttosttos (ttosttos) wrote :

Four years and no fix :-(

7 years and a half...

It should be great to add this new feature, because it affects seriously the usability.

Jens (jens-launchpad-net) wrote :

"It's not a feature that you would advertise if you were selling Ubuntu"

This is not a feature, it is what is commonly called a "hygiene factor" in engineering.
Hygiene factors are things that nobody notices when they exist but everybody will complain about when they are missing or broken.
Selecting objects via rubberband (almost) everywhere but *especially* in the file manager is so commonplace nowadays that this is an absolute must have.

This is THE single feature in file management that every single person I introduced Ubuntu to complained about within ten minutes of usage. (In contrast: absolutely nobody currently cares about touch features, where a lot of effort seems to go.)

Please reconsider and prioritize.

Changed in nautilus:
status: In Progress → Confirmed
Jens (jens-launchpad-net) wrote :

It seems nothing is being done on this bug (or is this a duplicate and the party is somewhere else?).

So if this cannot be considered a bug due to some formal or bureaucratic reason, please tell us whether this has been fixed and/or implemented in future Ubuntu releases. Rubberband selection in list views is such an important basic operating system feature that people shake their heads when trying Ubuntu for file management, as in "what do you mean this doesn't work? Why not?"

If there is a big show stopper (as in, major bug in some dependant library that nobody has figured out in eight years), please also tell us.

Thank you!

Fordi (fordiman) wrote :

Nine and a half years and counting, guys. Please implement the feature from 1998 that was missing 2006. The failure of this to work makes Ubuntu look amateurish every time someone messes with my desktop.

dino99 (9d9) on 2016-01-11
affects: hundredpapercuts → gtk
Changed in gtk:
status: Invalid → New
Thang Duong Bao (nothingctrl) wrote :

2018, this is very useful feature but still missing in Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.