Forward/back mouse buttons don't work in list view

Bug #486358 reported by Arthur Blair on 2009-11-21
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

To reproduce (assuming you have back/forward buttons on your mouse):

1) Open your home folder
2) Open any subfolder
3) Make sure folder view is set to "Icon view"
4) Use the back button on your mouse to go back to your home folder
5) Open the subfolder again
6) Make sure folder view is set to "List view"
7) Try and use the back button on your mouse to go back to your home folder

Related branches

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
This will help us to find and resolve the problem.

btw that works fine for me here.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

To reproduce (assuming you have back/forward buttons on your mouse):

1) Open your home folder
2) Open any subfolder
3) Make sure folder view is set to "Icon view"
4) Use the back button on your mouse to go back to your home folder
5) Open the subfolder again
6) Make sure folder view is set to "List view"
7) Try and use the back button on your mouse to go back to your home folder

On Mon, Nov 30, 2009 at 2:59 PM, Pedro Villavicencio <email address hidden>wrote:

> Thank you for taking the time to report this bug and helping to make Ubuntu
> better. Please answer these questions:
> 1. Is this reproducible?
> 2. If so, what specific steps should we take to recreate this bug? Be as
> detailed as possible.
> This will help us to find and resolve the problem.
>
> btw that works fine for me here.
>
> ** Changed in: nautilus (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: nautilus (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: nautilus (Ubuntu)
> Assignee: (unassigned) => Ubuntu Desktop Bugs (desktop-bugs)
>
> --
> Forward/back mouse buttons don't work in list view
> https://bugs.launchpad.net/bugs/486358
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nautilus” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: nautilus
>
> Forward and back mouse buttons can't be used to navigate when files are
> displayed in list view. They work fine in icon or compact view.
>

Changed in nautilus (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=598328 ; looks like that bug, linking it , thanks for the detailed instructions Arthur.

Changed in nautilus (Ubuntu):
status: New → Triaged
description: updated
idokibovito (idokibovito) wrote :

On my Lucid the buttons are interpreted as if I left clicked: marking the entry under the mouse pointer.

idokibovito (idokibovito) wrote :

Addon to prev. comment: they _almost_ act like left click. Drag and drop doesn't work with the back/forward buttons. Not that I'd like them to..

Changed in nautilus:
status: Unknown → Invalid
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Expired

The upstream bug report claims this to have been fixed, but I'm still experiencing this with an up to date maverick installation.
In fact this has been broken for me since lucid.
There's also https://bugzilla.gnome.org/show_bug.cgi?id=605217 which might be related, though it doesn't work at all in list view.

Arthur Blair (adblair) wrote :

This bug is not fixed for me in Natty Beta 1. Here is another relevant Bugzilla report: https://bugzilla.gnome.org/show_bug.cgi?id=629635

Changed in nautilus:
importance: Medium → Unknown
status: Expired → Unknown
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → New
adrianl. (gyo) wrote :

This bug affects me as well on an ubuntu 11.10 install.

I didn't even realise that it's working in icon view until I found this bug description.

Is there anything I could do to help fix this as I find it very annoying??

Changed in nautilus:
status: New → Invalid
Sebastien Bacher (seb128) wrote :
Changed in nautilus:
importance: Critical → Unknown
status: Invalid → Unknown
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.1-0ubuntu1

---------------
nautilus (1:3.4.1-0ubuntu1) precise-proposed; urgency=low

  * New upstream version:
    - Don't display comment field for desktop files
    - Fix off-by-one error in file operation counts
    - Fix mouse hardware back/forward buttons not working correctly
      (lp: #486358)
    - Fix "Undo Trash" for files with non-ASCII characters
    - Fix name corruption for untitled files under some circumstances
  * debian/patches/revert_desktop_comment.patch,
    debian/patches/git_utf_undo.patch,
    debian/patches/git_no_freespace_cpu_look.patch,
    debian/patches/git_copy_off_by_one.patch:
    - dropped, those fixes are in the new version
 -- Sebastien Bacher <email address hidden> Mon, 16 Apr 2012 18:45:41 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.