Deleting a file in tree view crashes the Nautilus instance

Bug #48078 reported by Pete Morgan on 2006-06-02
10
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Unknown
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

1) within a directory create a sub directory
2) create a "subsub" dir or add a file to the sub directory
3) Switch to tree view
4) select the subdir and select "move to Wastebasket"
5) the instance of Nautilus crashes, the files are however deleted..

* a folder
** sub dir << deleteing this in tree view panel crashes app
*** subsub dir or file(s)

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? Could you install nautilus-dbg and get a backtrace (the bug-buddy dialog to send the bug upstream has it)?

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Pete Morgan (pm-daffodil) wrote :
Download full text (5.1 KiB)

Ubuntu Dapper (live online update of Breezy)
Gnome 2.14.1

Have installed nautilus-dbg? where do I go from here.. tried to start nautilus-dbg from the command line but not there.. ug buddy is also installed but see no errors..(relative newbie to Linux on desktop)

Can u point me in the right direction ?

Backtrace was generated from '/usr/bin/nautilus'

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1225439552 (LWP 4887)]
[New Thread -1227236432 (LWP 4890)]
0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb75228c4 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb76cf7d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3 0xb76cfca8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4 0xb7bd36d5 in IA__gtk_main () at gtkmain.c:1026
#5 0x08079e26 in main (argc=125, argv=0xbfa98a04) at nautilus-main.c:406
#6 0xb7477ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#7 0x080672a1 in _start () at ../sysdeps/i386/elf/start.S:119

Thread 2 (Thread -1227236432 (LWP 4890)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb75228c4 in poll () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0xb76cf7d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3 0xb76cfca8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4 0xb77b170e in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5 0xb76e85d2 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6 0xb7732341 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#7 0xb752c4ee in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.

Thread 1 (Thread -1225439552 (LWP 4887)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb75228c4 in poll () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0xb76cf7d8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3 0xb76cfca8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4 0xb7bd36d5 in IA__gtk_main () at gtkmain.c:1026
 tmp_list = (GList *) 0x81644e8
 functions = (GList *) 0x0
 init = (GtkInitFunction *) 0x81c7150
 loop = (GMainLoop *) 0x822dc88
#5 0x08079e26 in main (argc=125, argv=0xbfa98a04) at nautilus-main.c:406
 kill_shell = 0
 restart_shell = 0
 no_default_window = 1
 browser_window = 0
 no_desktop = 0
 startup_id = <value optimized out>
 startup_id_copy = 0x81621c8 "h\033\026\bèÛt·h\033\026\bçÝt·h\033\026\b-ùt· "
 geometry = 0x0
 perform_self_check = 0
 popt_context = (poptContext) 0x81644e8
 args = (const char **) 0x0
 application = (NautilusApplication *) 0x81c7150
 program = (GnomeProgram *) 0x815dc28
 context_as_value = {g_type = 68, data = {{v_int = 135677160,
      v_uint = 135677160, v_long = 135677160, v_ulong = 135677160,
      v_int64 = 1356771...

Read more...

Sebastien Bacher (seb128) wrote :

That backtrace doesn't look like a crash. Are you sure that's not simply a bug #36500 (the window being closed because the directory it represents is moved away)?

Pete Morgan (pm-daffodil) wrote :

Have been pursuing this on Gnome's bugzilla where the issue has finally been fixed and closed. Expected fix with next release of Nautilus

Its not so much a bug, rather a feature (hence no errors) and had been corrected when deleteting directories. ONLY in the tree..

Cant find the issue in Bugzilla.gnome. (very slow site is down at the moment).
But as far as I'm concerned this issue can be flagged as closed.

Sebastien Bacher (seb128) wrote :

could you point the upstream bug? Are you sure that's not a duplicate of bug #36500?

Pete Morgan (pm-daffodil) wrote :

Here's my report on Bugzilla.gnome
http://bugzilla.gnome.org/show_bug.cgi?id=343696

Which is a duplicate report of
http://bugzilla.gnome.org/show_bug.cgi?id=336724

Which has the patch and the magic words..

"The attached patch was committed to HEAD and will be included in Nautilus 2.16."

thanks Christian Neumair

I love OSS ;-)

Pete Morgan (pm-daffodil) wrote :

Its NOT a bug, its something to do with "spatial" mode although I dont know what that means ..

Sebastien Bacher (seb128) wrote :

you really don't want to read my comments and reply about the duplicate question, anyway it points to the same upstream bug so marking it as duplicated

Changed in nautilus:
status: Needs Info → Rejected
Sebastien Bacher (seb128) wrote :

note that the bug is already fixed to edgy and is not a crasher, just an unexpected behaviour

Changed in nautilus:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.