Emblems get cut when scaled to a zoom >= 150% (refresh issue)

Bug #46846 reported by Flavio on 2006-05-26
108
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Humanity
Undecided
Unassigned
Nautilus
Fix Released
Low
One Hundred Papercuts
Low
Marcus Carlson
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

If I set my default zoom level greater than 150%, I see my emblems (which are located on the right upper side of the icons) cut on the right side. So half of the emblem is hidden/(cut off).
Zooming a level up or down, the issue vanishes. But on each opening of a folder, the emblems get cut. That's awful to see! :-/

Related branches

Flavio (flavio-guerra) on 2006-05-26
description: updated
Flavio (flavio-guerra) on 2006-05-27
description: updated
Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? What icon theme? Do you use the compact mode? Text behind icons or not? Could you make a screenshot of the issue?

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
Flavio (flavio-guerra) wrote :

I installed dapper (may 22 release), I switched several times my icon theme from osx to nuoveXT, and then back to default (human); but I see the bug with all of them. I installed dapper also on another pc, it has the same problem.

Sebastien Bacher (seb128) wrote :

is the issue fixed by scrolling too?

Flavio (flavio-guerra) wrote :

The issue doesn't remain after I scroll up and down in order to "hide" the icon for a moment under the "controls". (I hope you understand what I mean)

screenshot of the bug

Sebastien Bacher (seb128) wrote :

The description is clear and it happens on my dapper installation too, I've forwarded that upstream: http://bugzilla.gnome.org/show_bug.cgi?id=343540

Changed in nautilus:
status: Needs Info → Confirmed
Spelley (spellman) wrote :

This bug has existed for years. Makes scaling icons over 100% nearly impossible. Wish someone would get around to fixing it.

nyékhelyi gábor (n0gabor) wrote :

It's a shame that they're developing useless fancy effects like 'nice effect when launching an application' from panel, and bugs like this exists for years. Another rendering bug when using background in nautilus, and switching from normal view to listview than back to normal, the background image'll be totally distorted. These kind of bugs makes GNOME (and Ubuntu) feels really unprofessional, so 'Low' importance should be reconsidered.

pheeror (pheeror) wrote :

Yeah, I must agree with you. I've just realized this bug, and I'm really surprised it's been there for such a looooong time.

pheeror (pheeror) wrote :

Besides, are you sure this bug is upstream issue as it looks from assigning it to http://bugzilla.gnome.org/show_bug.cgi?id=343540 ?
I just can't believe that so obvious bug would not be confirmed for such a long time.

Sebastien Bacher (seb128) wrote :

there is thousand of bugs open on nautilus, there is likely not so many users using a zoom nor emblems, not a surprise it's a low priority and not being worked

nyékhelyi gábor (n0gabor) wrote :

Then it has more sense to remove these almost unused, and unmaintained features...

Changed in nautilus:
status: Confirmed → Triaged
pheeror (pheeror) wrote :

Hi,
I tried some icon themes and and I've realized that the problem occurs only with some themes (and Human is one of them). With default gnome theme and tango icon theme emblems aren't cut off. Thus, it looks more like a theme issue.
I dug a little into freedesktop icon spec and created "not-even-a-workaround":

just create file /usr/share/icons/Human/scalable/places/folder.icon with this content:
[Icon Data]
AttachPoints=0,800

nyékhelyi gábor (n0gabor) wrote :

Tango and GNOME Default icon themes're cut at my install (Hardy alpha). When I'm using the 150% default iconview .

I can confirm this bug is present on Intrepid Alpha 6 (screenshot attached).

Sreejith Kesavan (semk) wrote :

I'm using Hardy and I'm also facing this issue.

Mark (mlvarnell) wrote :

I am using Ubuntu 8.10 (intrepid), and the problem still exists. If you click and drag over the icons, the emblems are redrawn. Also you can ctrl-2, ctrl-1 and they are also redrawn. Maybe the actual problem is in the zoom function. I have settled by using 100% zoom. Another annoyance is that you cant set a colored background for any of the side panels except the information side panel.

Gigi (gigi33) wrote :

I can confirm this bug using Ubuntu 8.10 (intrepid).

Changed in nautilus:
status: New → Confirmed
Guillaume Hain (zedtux) wrote :

I can confirm this bug using Ubuntu 9.04 (jaunty).

MerceRudy (rudymills) wrote :

I can confirm this as well with Jaunty. It would be great for this to finally get fixed.

Jan Nekvasil (jan-nekvasil) wrote :

With more than three years opened, widely known, reported upstream and still not fixed, this bug is a true oldtimer and deserves our respect and love. Lot of new Ubuntu users had been going through three phases of Meeting the Nautilus File Manager's features:

1) Wow, such a nice emblems! Let's put some of them on my files and folders for better orientation! Ubuntu rocks!
2) Even more wow, customizable zoom level! Let's set it for some of my folders for better navigation! Ubuntu rocks!
3) Eww, what's this mess now? Looks that I must decide which one of these two I like best... hmm... maybe neither, never mind. Maybe it's my own fault to demand such a things. Ubuntu... well... rocks anyway, it's definitely my fault.

Dapper. Edgy. Feisty. Gutsy. Hardy. Intrepid. Jaunty. Karmic Alpha 2.

I can't even believe it myself, can You?

Let's fix it for good. In One Hundred Papercuts project.

This may not strictly be a usability bug, but it detracts greatly from overall polish of the default experience and should be simple to fix, so I've confirmed it in hundredpapercuts.

Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-3
arnau (arnaullv) wrote :

Still present in Karmic alpha 5, anybody working on it?

Guillaume Hain (zedtux) wrote :

Still present in Karmic alpha 6 also

arnau (arnaullv) wrote :

This bug is present in Gnome since 2007 and it seems that nobody is working on it.
I think we should disable 150% view or fix this bug, otherwise gnome gives the a bad impression to the end user.

Ole Jon Bjørkum (oj88) wrote :

This bug has annoyed me for many years, and it is amazing that it has not been fixed.

I use symlinks alot, and they get an emblem icon, and this bug makes me feel that the system is not polished. I can't understand that this is so difficult to fix? Bugs like this makes users feel that Ubuntu is messy and buggy in the user interface.

Vish (vish) wrote :

Could someone post a screenshot of this bug with the default Humanity theme ?
We are in the process of fixing an issue with emblems, So we could have a look at this bug too.

Changed in hundredpapercuts:
status: Confirmed → Incomplete
Vish (vish) wrote :

Could someone post a screenshot of this bug with the default Humanity theme ?
We are in the process of fixing an issue with emblems, So we could have a look at this bug too.

Ramón Rocha (ramon.rocha) wrote :

This is at 200% zoom level. The error is only visible after moving the icon. Drawing a selection box over the icon fixes the emblem.

Vish (vish) wrote :

So the problem with the 150% zoom no longer arises with the default humanity theme?

But only with the 200% ?

Changed in humanity:
status: New → In Progress
Changed in hundredpapercuts:
status: Incomplete → In Progress
Ramón Rocha (ramon.rocha) wrote :

It is also a problem on 150%, but in that case it is just a sliver of the emblem that is misaligned. It is there, just more subtle.

Daniel Fore (danrabbit) wrote :

I believe this is a problem with Nautilus and not with the theme, so I'm marking as invalid for Humanity.

Changed in humanity:
status: In Progress → Invalid
Daniel Fore (danrabbit) wrote :

However, we're experimenting with emblem placement and we think we have somewhat of a workaround.

arnau (arnaullv) wrote :

I'm sorry to say that the bug is still present on 150% zoom with Humanity theme (also with others)
It took me not so much time playing with the windows (minimize, refresh, move, unfocus windows, etc) to make it appear.
I took a screenshoot.
Hope it helps

is shit linux
_________________________________________________________________
Nouveau Windows 7 : Trouvez le PC qui vous convient. En savoir plus.
http://clk.atdmt.com/FRM/go/181574580/direct/01/

GodLikeCreature (ultrachem) wrote :

Yup, this problem very much is alive in both Jaunty and Karmic.

I know other burning topics must be priorities now, but come on, this one has been there forever, it deserves action!

Changed in hundredpapercuts:
milestone: round-3 → r2
assignee: nobody → Marcus Carlson (0-launchpad-mejlamej-nu)
asphixmx (ubuntomanos) wrote :

I can't believe this annoying bug is still present in Karmic. Has lived for at least 3 versions. For a new ubuntu user, it is a disappointment.

tekstr1der (tekstr1der) wrote :

This is still an issue after Lucid beta 1. Any chance a fix could make it in for release?

asphixmx (ubuntomanos) wrote :

The bug has so many years, that I think I'm begining to love this little bug. But hope it could fly away from the Ubuntu home.

For info; I just attached a patch on upstream bugreport. Feel free to try it out and comment. Works for me (tm) :)

Guillaume Hain (zedtux) wrote :

What a awesome news !!! :)

Cool, and thanks Marcus !
You maybe will close an historical bug ! Great job ! \o/

As I understand this can be worked around by adding a *.icon file for each folder and file icon with attach points [1] as the rendering is working for that (could be a good workaround for lucid if you don't want to patch nautilus).

[1] http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html

Fixed upstream :)

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: In Progress → Fix Released
Vish (vish) wrote :

Not released yet

Changed in hundredpapercuts:
importance: Undecided → Low
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.30.0-0ubuntu4

---------------
nautilus (1:2.30.0-0ubuntu4) lucid; urgency=low

  * debian/patches/91_git_middleclick_crash.patch:
    - git change to fix a crasher when opening non-available bookmark locations
      (lp: #444368)
  * debian/patches/92_git_emblems_cut.patch:
    - git change to fix emblem being cut sometime when zooming
      (lp: #46846)
 -- Sebastien Bacher <email address hidden> Wed, 07 Apr 2010 11:51:00 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2010-04-09
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.