drag and drop images or video into subfolder will prevent folder from loading

Bug #454297 reported by bluebyt on 2009-10-17
258
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
High
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
Karmic
Low
Sebastien Bacher

Bug Description

When I drag a picture on a folder, if I go to this folder, I don't see the image thumbnail and the mouse is busy.

I don't see the thumbnail files until I kill nautilus.

Thumbnail preview must be enable.

The bug occurred on both of my computer.

Same thing happened with videos

ProblemType: Bug
Architecture: i386
Date: Sat Oct 17 19:06:04 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: yelp
Uname: Linux 2.6.31-14-generic i686

Related branches

bluebyt (bluebyt) wrote :
Erik B. Andersen (azendale) wrote :

I tried to reproduce the problem, but I didn't totally understand what to do. Maybe you could provide before, during, and after screenshots or even a video? That would make it really easy to understand what to do to make it happen again.

affects: ubuntu → nautilus (Ubuntu)
bluebyt (bluebyt) wrote :

I have attached a video that explain how to reproduce the problem.

This is a link of the thread in Ubuntu forum about the problem:

http://ubuntuforums.org/showthread.php?t=1272898&highlight=nautilus

zombiepig (nyall-zombiepigs) wrote :

I see this same behaviour - if i drag and drop a video file to move it from my downloads folder to the video folder on the sidebar, then switch the folder to the video folder, this file won't have a proper thumbnail - just the 'generating thumbnail' icon. If I then refresh the view of that folder, the file disappears, and the mouse cursor gets stuck on the busy cursor.

cariboo (cariboo) wrote :

I have the same problem when moving .avi files into one of the Videos subfolders. When I check the directory directly after moving a file, there are no files showing in the directory. If I check an hour or so later all the files show up in the directory.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
summary: - Nautilus drag and drop images or video
+ Nautilus drag and drop images or video into subfolder will prevent
+ folder from loading.
summary: - Nautilus drag and drop images or video into subfolder will prevent
- folder from loading.
+ drag and drop images or video into subfolder will prevent folder from
+ loading
Dan Andreșan (danyer) wrote :

Attaching a video showing the bug is one of the best ideas I saw recently.
With people speaking so many languages and maybe interpret differently what someone is saying, the video on the other hand shows perfectly the bug.

Congratulations! Now let's hope that GNOME people will be quick to act and fix it.

Thanks, English is not my native language but i am improving everyday!
It is not always easy to describe a technical issue! but I always happy to
help find bugs.
Bruno

2009/10/20 Dan Andreșan <email address hidden>

> Attaching a video showing the bug is one of the best ideas I saw recently.
> With people speaking so many languages and maybe interpret differently what
> someone is saying, the video on the other hand shows perfectly the bug.
>
> Congratulations! Now let's hope that GNOME people will be quick to act
> and fix it.
>
> --
> drag and drop images or video into subfolder will prevent folder from
> loading
> https://bugs.launchpad.net/bugs/454297
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Nautilus: Unknown
> Status in “nautilus” package in Ubuntu: Triaged
>
> Bug description:
> When I drag a picture on a folder, if I go to this folder, I don't see the
> image thumbnail and the mouse is busy.
>
> I don't see the thumbnail files until I kill nautilus.
>
> Thumbnail preview must be enable.
>
> The bug occurred on both of my computer.
>
> Same thing happened with videos
>
> ProblemType: Bug
> Architecture: i386
> Date: Sat Oct 17 19:06:04 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/yelp
> NonfreeKernelModules: nvidia
> Package: yelp 2.28.0-0ubuntu2
> ProcEnviron:
> LANG=en_CA.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> SourcePackage: yelp
> Uname: Linux 2.6.31-14-generic i686
>

manzur (sl-solaris) wrote :

sometimes this is happening just when I press F5 to refresh

zombiepig (nyall-zombiepigs) wrote :

Some more information -
After this bug is triggered and a folder view is missing files, if you then switch to another folder with missing thumbnails, then back to the first folder, all the missing files are displayed again with proper thumbnails.

Changed in nautilus (Ubuntu):
milestone: none → ubuntu-10.04
milestone: ubuntu-10.04 → karmic-updates

From upstream nautilus developer:

Fixed by commit e487552287e5970dbbb39199b55026f2788bb42b on master and
cherry-picked to gnome-2-28.

will this be included in Karmic updates, then?

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus (Ubuntu Karmic):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Changed in nautilus (Ubuntu):
milestone: karmic-updates → none
Dawid M. (dawid.mlyn) wrote :

I observe the same behavior as described above, but it's not limited to images or videos - it also happens with TXT files. Often it's enough to save a file, then rename it and press refresh and either all the files from that folder disappear or nautilus doesn't show the file that has just been renamed.

This bug seems to be a duplicate of more generic bug #383927, where Alastair Carey wrote in comment #19: "now it's very common in Nautilus - any time I move a file that is represented by a thumbnail from one folder to another, Nautilus can't show the entire contents of the destination folder - sometimes Nautilus won't show anything, other times it shows everything but the file just moved. Any file that uses a thumbnail seems to be able to set this off - not just videos, but PDFs, and document files if an OpenOffice thumbnailer extension is installed. Closing and restarting Nautilus doesn't seem enough to reliably fix it."

As to my experience this behavior didn't happen "every time I was moving a file", but it was frequent enough to make me select an option to never create thumbnails for TXT files or any other files that can be previewed with a thumbnail.

Changed in nautilus (Ubuntu Karmic):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Sebastien Bacher (seb128)
Changed in nautilus (Ubuntu Karmic):
status: Triaged → Fix Committed

Accepted nautilus into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
VPablo (villumar) wrote :

The patch works for me. Thanks.

By the way, what program did you used for recording the video?

 I used xvidcap!
bluebyt

2009/11/23 VPablo <email address hidden>

> The patch works for me. Thanks.
>
> By the way, what program did you used for recording the video?
>
> --
> drag and drop images or video into subfolder will prevent folder from
> loading
> https://bugs.launchpad.net/bugs/454297
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Nautilus: Unknown
> Status in “nautilus” package in Ubuntu: Fix Committed
> Status in “nautilus” source package in Karmic: Fix Committed
>
> Bug description:
> When I drag a picture on a folder, if I go to this folder, I don't see the
> image thumbnail and the mouse is busy.
>
> I don't see the thumbnail files until I kill nautilus.
>
> Thumbnail preview must be enable.
>
> The bug occurred on both of my computer.
>
> Same thing happened with videos
>
> ProblemType: Bug
> Architecture: i386
> Date: Sat Oct 17 19:06:04 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/yelp
> NonfreeKernelModules: nvidia
> Package: yelp 2.28.0-0ubuntu2
> ProcEnviron:
> LANG=en_CA.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
> SourcePackage: yelp
> Uname: Linux 2.6.31-14-generic i686
>

I'd suggest caution before applying this patch. I did so and starting the new nautilus apparently destroyed all data that was on my desktop. Not a great start.

VPablo (villumar) wrote :

Thanks bluebyt.

My desktop is normal for me, with all the shotcuts and data.

FMaz (fmaz008) wrote :

This bug also affect me,
Ubuntu 32Bits, Karmic Koala.

greenxgene (greenxgene) wrote :

I experienced the problem recently in Karmic.

The problem arose when I moved PDF files in to a folder within a linux partition .

I guess the problem is especially due to nautilus trying to generate the thumbnail of the files.

c4pp4 (c4pp4) wrote :

I've got that problem with ext4 fs but I can't execute the problem with ext3 fs. Can anyone confirm/refuse it?

VPablo (villumar) wrote :

I had this problem with ext3 filesystem.

By the way, after aplying this patch I have another problem in the directory affected. The icons are ordered in a random way, but when I click in the Refresh button (Recargar) they are ordered correctly. And this behavior repeats later when returning to this directory.

Can anyone confirm this side effect?

I have both Karmic Koala and Jaunty on same machine. Problem folder belongs to Karmic Koala. However, if i use Jaunty to watch that very same folder --- surprise: Folder and files are displayed ok.

Tom (tom-rummel) wrote :

I don't have this problem when I use Dolphin.

Danny Wood (danwood76) wrote :

Tom the bug is in Nautilus so I would expect it to work in dolphin!

I have not noticed this since updating to the fixed nautilus package.

Michael Noyce (miken) wrote :

Eek... Sorry, unintentionally changed the status of this bug report. Please ignore! Still getting to grips with Launchpad. Sorry.

Changed in nautilus (Ubuntu Karmic):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Sam Chau (schau) wrote :

I've just installed the fix. All good. Thanks guys!

Martin Pitt (pitti) on 2009-12-03
tags: added: verification-done
removed: verification-needed

I'd also like to help with testing but unfortumately I lost my test situation / problem. At least I have not been able to produce that problem any more after the day I watched that folder using Jaunty instead of Karmic. Strange and does not make sense for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.28.1-0ubuntu3

---------------
nautilus (1:2.28.1-0ubuntu3) karmic-proposed; urgency=low

  * debian/patches/91_git_change_correctly_update_counters.patch:
    - git change to fix thumbnailing blocking directories loading
      in some cases (lp: #454297)
  * debian/patches/92_git_change_correctly_unfreeze_after_renaming.patch:
    - git change to fix a crasher (lp: #407768)
 -- Sebastien Bacher <email address hidden> Mon, 23 Nov 2009 11:37:46 +0100

Changed in nautilus (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to lucid.

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Michael Noyce (miken) wrote :

Just to confirm that since installing the update I have not had a re-occurrence of this problem. Thanks!

Nick Lutsiuk (nickl) wrote :

Any chance the fix gets backported into 2.26 and Jaunty?

Sebastien Bacher (seb128) wrote :

The issue is not known to affect jaunty, we started received bugs about it in the karmic cycle, jaunty is also not a lts and the issue would be low priority for a backport there since users who follow 6 month cycles are expected to run karmic now

Jim Walsh 3 (jimwalsh3) wrote :

I am using "karmic": You are using Ubuntu 9.10 - the Karmic Koala - released in October 2009 and supported until April 2011.

This bug affects me.

I don't understand the post above, "the issue would be low priority for a backport there since users who follow 6 month cycles are expected to run karmic now" unless it means that there is no reason to fix earlier versions (let them who don't upgrade eat cake). If it means that, yikes. It is cold.

Anyway, when can we expect a fix in any version?

Sebastien Bacher (seb128) wrote :

The issue has already been fixed in karmic if you run the update and still has it you are commenting on the wrong bug and should open a new one rather than asking when this one will be corrected since it already did.

Changed in nautilus:
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.