Nautilus doesn't remember folder view when opening folder link

Bug #428386 reported by Alex Vaystikh on 2009-09-12
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

When, for example, setting a folder to be sorted by modification date, and later reopening the folder - nautilus will always fall back to its default sort, by Name.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 6d0055ce191d99393fe8482696710e1a
CheckboxSystem: 47a7b64affed4ab6e614aa72ee18d9c9
Date: Sat Sep 12 16:34:02 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
NonfreeKernelModules: nvidia
Package: nautilus 1:2.27.92-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
SourcePackage: nautilus
Uname: Linux 2.6.31-10-generic x86_64

Alex Vaystikh (bornio) wrote :
Alex Vaystikh (bornio) wrote :

Clarification: it seems to be failing to remember the view, only when opening a symbolic link to the destined folder.

Matthew Woerly (nattgew) wrote :

I can confirm this... when opening a link to a folder, it will not remember any changes to view. That means both in sorting or in the format (Icons/List/Compact).

Changed in nautilus (Ubuntu):
status: New → Confirmed
summary: - Nautilus doesn't remember folder view (2.27.92)
+ Nautilus doesn't remember folder view when opening folder link (2.27.92)
summary: - Nautilus doesn't remember folder view when opening folder link (2.27.92)
+ Nautilus doesn't remember folder view when opening folder link
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Sense Egbert Hofstede (sense) wrote :

It has been a while since you've last indicated you have this issue and meanwhile Ubuntu Karmic has been released. I cannot confirm this bug, can you still? It would be nice to know if it still happens before we start telling upstream.

Matthew Woerly (nattgew) wrote :

In Karmic it seems to keep separate settings for the link. If I open the link and select a view, it's remembered.
If I visit that folder through its path, though, it has separate settings.
So I can no longer reproduce this in Karmic.

Sense Egbert Hofstede (sense) wrote :

In that case I'm marking this bug as Fix Released. If it does come back in Lucid, please feel free to reopen this bug. Thanks for your participation.

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
Changed in nautilus:
status: New → Fix Released

I can still confirm this bug in Karmic with Nautilus 2.28.1
If the link links to another harddisk no changes of view will be saved, but if the link is on the same harddisk it's work perfect. Very strange...

Sense Egbert Hofstede (sense) wrote :

In that case I'm setting the status back to Triaged and wait for the response of the initial reporter or confirmation from someone else.

Changed in nautilus (Ubuntu):
status: Fix Released → Triaged
Alex Vaystikh (bornio) wrote :

I can confirm the bug still exists.

Sense Egbert Hofstede (sense) wrote :

I'm reporting this upstream.
Does it have to be on a different hard disk, or does the bug also occur when the link points to a directory on a different partition on the same hard disk?

Changed in nautilus:
importance: Undecided → Unknown
status: Fix Released → Unknown

Yes, the Bug also occurs when the links points to a different partition on the same hard disk.

Sohail Mirza (mirzmaster) wrote :

I too can confirm this bug still occurs in Karmic.

nautilus version:
--------------------
GNOME nautilus 2.28.1

uname -a:
------------
Linux <Machine_Name> 2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:53:52 UTC 2009 x86_64 GNU/Linux

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Expired
Changed in nautilus:
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.