Its impossible to open a text file on a FAT volume with its assigned application

Bug #426457 reported by Oded Arbel on 2009-09-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

When accessing a FAT volume, all the files have the execute bit set. When you double click (or right click and choose "Open") a file that has a text MIME type, nautilus assumes it is a script and offers to run it (or run in a terminal or display it), regardless of what application is assigned to actually open the file.

Use case: an SRT file is stored on a USB memory stick that comes formatted as FAT out of the factory. The user has Gnome Subtitles set as the default application for SRT files (which are a type of text file). The user plugs the USB memory stick into the computer and double clicks the SRT file and expect Gnome Subtitles to open the file. Instead they get a "Run or Display" dialog.

In such a case, even the "Open With" list does not include the needed application - if the user wants to open their SRT file they must right click the file, choose Open With->Other Application, search for Gnome Subtitles and select it. Of course Nautilus does not actually "remember" this setting and the user has to do this again for the next file.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=598557

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

Do you still have that issue in newer versions?

Changed in nautilus (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.