Ubuntu

Nautilus needs to use "gtk_image_menu_item_set_always_show_image" for icons representing applications/locations

Reported by Vish on 2009-08-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Gnome 2.28 will have menus_have_icons=false by default. <http://bugzilla.gnome.org/show_bug.cgi?id=557469>

However, some menu items should have icons regardless of the value of that setting. The Human Interface Guidelines already allude to this: "Show icons for bookmark entries on the Bookmarks menu that indicate the
type of the bookmark, even if the user has globally turned off icons for other
menu items on the desktop" <http://library.gnome.org/devel/hig-book/stable/menus-standard.html.en#menu-standard-bookmarks>. In future there will be expanded guidelines on this <http://bugzilla.gnome.org/show_bug.cgi?id=588668>.

These menu items in Nautilus should have always-show-icons set:
* all applications in the "Open With" submenu (patch available at <http://bugzilla.gnome.org/show_bug.cgi?id=546916#c11>)
* "Home Folder", "Computer", "Templates", and other named locations in "Places"/"Go" (but not "Search for Files...")
* all bookmarked locations in "Places"/"Bookmarks"
* all history locations in "Go".

Vish (vish) on 2009-08-03
description: updated

See http://bugzilla.gnome.org/show_bug.cgi?id=546916 or https://bugs.launchpad.net/hundredpapercuts/+bug/387796 for a patch to show applications icons in the open with list in nautilus.

Vish (vish) on 2009-08-03
summary: - Nautilus need to use "gtk_image_menu_item_set_always_show_image" for
+ Nautilus needs to use "gtk_image_menu_item_set_always_show_image" for
essential icons.

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
description: updated
Changed in nautilus (Ubuntu):
status: New → Confirmed
summary: Nautilus needs to use "gtk_image_menu_item_set_always_show_image" for
- essential icons.
+ icons representing applications/locations
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
Vish (vish) on 2009-08-04
Changed in nautilus:
status: New → Unknown
Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.27.91-0ubuntu1

---------------
nautilus (1:2.27.91-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #418405)
    - Migrate old-style nautilus metadata to gvfs metadata
    - Fix viewing of very small image files
    - Respect disable_command_line option
    - Reverse mouse button used for back/forward to same as firefox
    - Always show menu icons for menu items representing files (LP: #387796) (LP: #408384)
    - Inhibit suspend during file operations (LP: #49258)
    - Cancel audio preview when deleting the previewed file (LP: #36196)
  * debian/patches/01_lpi.patch:
  * debian/patches/02_autoconf.patch:
  * debian/patches/18_signal_curtain.patch:
  * debian/patches/90_relibtoolize.patch:
  * debian/patches/99_ltmain_as-needed.patch:
    - Refreshed

 -- Robert Ancell <email address hidden> Tue, 25 Aug 2009 13:15:20 +1000

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Changed in nautilus:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.