desktop icons aren't aligned automatically in RTL languages (Hebrew, Arabic, Persian)

Bug #404363 reported by Uri Shabtay on 2009-07-24
106
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Hi all,

In my Mom's computer the localization is in Hebrew, meaning that all menus, folders, and Desktop icons are RTL.
As an End-User, every time my Mom downloads something, or drags a file/shortcut to the desktop, the icon doesn't align itself to the grid of the other icons automatically, but instead "lands" in one area (usually the top right).

Yet, the bug doesn't stop there. If that icon is left there, the upcoming icons that will be added to the desktop will land right on top of it, creating a lovely stack as shown in the pic:
http://img146.imageshack.us/img146/5637/bug1p.jpg
http://img91.imageshack.us/img91/9945/bug2d.jpg
(credits to Shezif for posting the pics..)

Considering that many users prefer the localize system language, and not plain English, i hope this is solvable quickly..

In any case, thanks in advance..

Regards,

Uri

tags: added: rtl
Eyal Levin (eyalev) on 2009-07-24
tags: added: l10n
Sense Egbert Hofstede (sense) wrote :

Thank you for trying to help make Ubuntu better with reporting this bug.
However, before we can properly process this bug we need to need some more information to determine what caused this problem.
Could you please attach the screenshots to this bug report on Launchpad so people that aren't registered on the Ubuntu IL forums can access them as well? Next to that we'd like to know what version of Ubuntu is affected.
If you're not sure about this you can find it under the Ubuntu logo in System->About Ubuntu.
Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
Uri Shabtay (uri.shabtay) wrote :

you're more than right. i haven't noticed that it's linked to the forum.

http://img146.imageshack.us/img146/5637/bug1p.jpg

http://img91.imageshack.us/img91/9945/bug2d.jpg

The version is undoubtedly Jaunty 9.04, Gnome desktop.

Sense Egbert Hofstede (sense) wrote :

Thank you for the additional information. This is a bug in Nautilus. I've reported it upstream.

affects: ubuntu → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Uri Shabtay (uri.shabtay) wrote :

bug is still active using Karmic 9.10 fully updated..

Yaron (sh-yaron) on 2010-03-08
summary: desktop icons aren't alighned automatically in RTL languages (Hebrew,
- Arabic)
+ Arabic, Persian)
Changed in nautilus:
status: Unknown → Invalid

can anyone test this on Lucid to see if it's still active?

aviramof (aviramof) wrote :

this problem still exist in lucid i have been using lucid almost from the start and it's still there.

the problem is that there is no auto arrange option in nautilus and in hebrew at least icons piles up one on top of the other

when you download files or shortcuts from desktop and etc and i'm hopping it would be fixed as soon as possible.

Changed in nautilus:
status: Invalid → Unknown
Changed in nautilus:
status: Unknown → New
Bruno Girin (brunogirin) on 2010-04-21
summary: - desktop icons aren't alighned automatically in RTL languages (Hebrew,
+ desktop icons aren't aligned automatically in RTL languages (Hebrew,
Arabic, Persian)
aviramof (aviramof) wrote :

Any news on the matter?

aviramof (aviramof) wrote :

By the way the problem still exist in ubuntu 10.10 so please fix it as soon as possible.

Tom (intelamd17) wrote :

i have this bug too

description: updated
tags: added: desktop grid icons
tags: added: nautilus
tags: added: desktop-icons
tags: added: nautilus-desktop-icons
removed: desktop-icons
Changed in nautilus:
importance: Unknown → Medium
hatul (amiadb) on 2011-03-08
tags: added: arabic hebrew i18n persian
Rex Tsai (chihchun) on 2012-09-18
tags: added: precise
Rex Tsai (chihchun) wrote :

Confirmed this issue still exist in Ubuntu 12.04 Precise.
* nautilus 1:3.4.2-0ubuntu4

Ibrahim Saed (ibraheem5000) wrote :

This problem still exist in Ubuntu 12.10 beta1.

Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.