Nautilus crashes with empty location in edit bookmarks

Bug #402927 reported by Pierre Chef on 2009-07-22
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Go in Edit Bookmarks
Empty the location textbox of a bookmark
Click somewhere (except in the useless gray of the Edit Bookmarks window)

Nautilus crashes with exit status = 134 and error
ERROR:nautilus-file.c:350:nautilus_file_new_from_filename: assertion failed: (filename[0] != '\0')
Aborted

Ubuntu 9.04
Nautilus 1:2.26.2-0ubuntu2

Related branches

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Pierre Chef (pierre.chef) wrote :
Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

confirming, will send upstream.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=589375 ; Thanks for reporting.

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
Pavel-II (dzy4) wrote :

Changed:
ctrl+l -- backspace -- enter

A. Walton (awalton) wrote :

Fixed upstream.

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.28.1-0ubuntu1

---------------
nautilus (1:2.28.1-0ubuntu1) karmic; urgency=low

  * New upstream version:
    - Translation updates
    - Correctly position icons for file drops
    - Fix lingering unmount menu item
    - Update tracker support for version 0.7
    - Fix crashes (lp: #389888, #402927)
    - Set correct recent files info
    - Make changing visible list view columns instant (lp: #401414)
    - Allow focusing the list view by clicking outside a line
    - Use right gconf key for the disable_tabs setting
  * debian/patches/90_relibtoolize.patch:
    - new version update

 -- Sebastien Bacher <email address hidden> Tue, 20 Oct 2009 14:37:08 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Critical
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.