Image tags break properties window

Bug #396279 reported by Mr. Blonde on 2009-07-06
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
nautilus (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact:
the properties dialog is geometry gets a wrong geometry depending on the content of some of the tabs

Test Case:
- download the image from https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/401061/+attachment/630742/+files/img-files.tar.gz (unpack the first jpg somewhere)
- right click on it in nautilus
- select "properties" in the menu

the properties dialog get stretched to accomodate the image infos, it should not

Regression potential:
some labels in the properties dialog would be wrongly formatted

---

There's no line break for the key tag, so if an image has many keywords it breaks the properties window (window is stretched to display all keywords).

Possible solutions:

- only display a certain amount of keywords and put (...) to indicate that there are more
- introduce line breaks after a set amount of characters

Release: 9.04 - Ubuntu jaunty

edit: same goes for the description tag

Mr. Blonde (mr.blonde) on 2009-07-06
description: updated
summary: - Image keyword tag breaks properties window
+ Image tags breaks properties window
summary: - Image tags breaks properties window
+ Image tags break properties window
Felix Crux (felixc) wrote :

Hi, thanks for reporting this issue. Could you please provide a bit of clarification as to where you are seeing this problem? Is this in the Properties window that you get from the menu when right-clicking on an image icon? If so, please update the bug so that it is marked as affecting the package "Nautilus." Thank you!

Changed in ubuntu:
status: New → Incomplete
Mr. Blonde (mr.blonde) on 2009-07-07
affects: ubuntu → nautilus (Ubuntu)
Mr. Blonde (mr.blonde) wrote :

Example picture from Wikipedia:

http://upload.wikimedia.org/wikipedia/commons/6/66/AH-64D_Apache_Longbow.jpg

If you save it to your computer and open the nautilus properties window, you should see the bug.

Felix Crux (felixc) wrote :

Thanks for clarifying! That is indeed incorrect behaviour, so I am marking the bug confirmed. Wrapping the lines would seem to be the best option.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for the report, that's known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=566411

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
John Struse (j883376) wrote :

I'm now having this same problem in 10.04 Lucid Lynx. The properties window becomes several times longer than the screen and makes things like the emblems tab difficult to work with, since they're spread out over the length of several screens.

Changed in nautilus:
importance: Unknown → Low
Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
description: updated
Changed in nautilus (Ubuntu Precise):
status: Triaged → Fix Committed

Hello Mr., or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

It all works wonderfully, thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu3

---------------
nautilus (1:3.4.2-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_bookmark_place_dnd.patch:
    - "places-sidebar: allow dropping of files to bookmarks" (lp: #874386)
  * debian/patches/git_image_properties_wrapping.patch:
    - "image-properties: set the description label to wrap" (lp: #396279)
 -- Sebastien Bacher <email address hidden> Wed, 13 Jun 2012 18:52:04 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Looks like this was fixed from upstream in 1:3.5.2-0ubuntu1.

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.