Nautilus gives no error message if an application fails to start

Bug #386037 reported by Markus Ilmola on 2009-06-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Expired
High
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

If I try to run an application by double clicking it in Nautilus and the application for some reason fails to start I get no error message. If I try to run the same application in the Terminal, I always get an error message such as "Segmentation fault (core dumped)", "error while loading shared libraries: xxxxxx.so.0: cannot open shared object file: No such file or directory" or "./a.out: Permission denied". Without an error message it is impossible to tell what went wrong and if the application did something or not. Nautilus should show the error messages too. Even better it should give a solution to the problem such as offering to install a missing package or asking if the user want's to give the file execute permission.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in nautilus (Ubuntu):
status: New → Invalid
Markus Ilmola (markus-ilmola) wrote :

There is no crash report because nothing has crashed. This bug report simply reports that Nautilus does not give informative error messages like the Terminal does.

Changed in nautilus (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

Confirmed, gnome should at least say something when a program fails to start. Right now they just fail silently.

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen if you don't reply to questions

Changed in nautilus (Ubuntu):
status: Confirmed → Incomplete
Markus Ilmola (markus-ilmola) wrote :

> Is this reproducible?

Yes it is.

> If so, what specific steps should we take to recreate this bug?

1. Take an application. Any application will do. Compile a simple "Hello World"- example if you don't have any.
2. Do something to make the application not to run. Such as remove its execution permissions or remove a package it depend on.
3. Double click the application on Nautilus in order to run it -> No error message is given!
4 Try to run the same application from the Terminal and a proper error message is given.

To fix this bug simply make Nautilus show error messages like the Terminal does.

ps.
There seems to be discussion about this bug in the Ubuntu brain storm:
http://brainstorm.ubuntu.com/idea/18989/
http://brainstorm.ubuntu.com/idea/14832/

Changed in nautilus (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

did you create a launcher or just run the binary directly?

Markus Ilmola (markus-ilmola) wrote :

> did you create a launcher or just run the binary directly?

I tried just to run the binary directly.

Trying again, this time with the latest version of Ubuntu (9.04), it seems that in the case of missing execute permission it does indeed show an error message, but not on the two other cases I tested (missing shared library and segfault).

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Victor Vargas (kamus) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
http://bugzilla.gnome.org/show_bug.cgi?id=590292

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus:
status: Unknown → New
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Medium
Changed in nautilus:
status: New → Incomplete
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
status: Incomplete → New
Changed in nautilus:
status: New → Invalid
Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → High
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.