Ubuntu

"Home Folder" has 3 different names

Reported by Mat Tomaszewski on 2009-06-02
312
This bug affects 60 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
One Hundred Papercuts
Medium
Unassigned
Unity
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

"Home Folder" is called "Home Folder" in the Places menu, "Home" in nautilus toolbar and by user's name everywhere else.
It should use a consistent name across the whole system..

Design Spec: http://wiki.ubuntu.com/OneHundredPaperCuts/Spec/382703

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, do you have any suggestion on what naming should be used there?

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

There is some upstream bugs about that; http://bugzilla.gnome.org/show_bug.cgi?id=341894 for example

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
status: Unknown → New
Mat Tomaszewski (mat.t.) wrote :

I think it should be "Home Folder" throughout, using the user's name means that the same functionality has a different name every time. Open for discussion though.

Mat Tomaszewski (mat.t.) on 2009-06-10
Changed in hundredpapercuts:
importance: Undecided → Medium
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Where do you have home used in a toolbar? Changing the label would be easy but replacing the username not because that's how the directory is named on the disk and the filebrowser lists the disk content and doesn't try to change the names to display, nautilus could be patched to change the real name but that every application browsing the filesystem is not going to be doing that soon so that will still not be coherent

I would call it 'Home' everywhere

'Home' is best, 'Home Folder' is about as bad as 'My Documents' besides, the folder is /home/user

dapado33 (dpdorn33) wrote :

I agree that "Home" sounds the best. "Home Folder" just sounds too formal.

Julian Alarcon (alarconj) wrote :

And.. how do you will translate Home, for example.. to Spanish?? "Casa"??? "Inicio"?? This don't sound good..
The best is Home Folder.

Julián Alarcón wrote:
> And.. how do you will translate Home, for example.. to Spanish?? "Casa"??? "Inicio"?? This don't sound good..
> The best is Home Folder.
>
>
I agree that "Home" in English sounds better than "Home Folder". This
will not be the case in other languages, not only Spanish - we could
again run into danger of inconsistent translations...

Any other suggestions?

Nicolò Chieffo (yelo3) wrote :

Well, if in other languages it sounds bad, it souldn't be translated.
For instance in Italian we don't translate "mouse", and I think we are not going to translate "home" too.
It's up to the translation team

Nicolò Chieffo (yelo3) wrote :

Or maybe we could name it "Personal Folder" which is translatable without problems

pinzia (pinzia) wrote :

"Personal" ?
Personal Folder vs. Private Folder and Pubblic Folder.
or "username"?

kenden (kenden) wrote :

The problem with "Home" is that is can be confused with /home. Plus it sounds like a buzzword, like Start.
I would call it user folder or user directory.

Aníbal Deboni Neto (adneto) wrote :

I agree that the translation is a problem. Translate "home" to portuguese 'cause the same problems that spanish. I strongly believe that the best solutions is to call it "username".

Ante Karamatić (ivoks) wrote :

In Croatian we translated Home folder as Personal folder. 'Home anything' just sounds plain stupid when translated in Croatian.

Photon (photon-ubuntu) wrote :

The same translation (Personal folder) is used in French. Same remark as Ante, "Home" is not relevant in French.

Alan Pope ㋛ (popey) wrote :

Given no other bookmarks under Places have 'folder' appended to them, why should 'home' ?

If I'm articulating to someone how to find their "home folder" or answer the question "Where's my stuff?", then saying "Click places, then home" sounds logical and succinct. By clicking 'Places' I'm saying I want to 'go to a place', and that 'place' might well be home. Makes sense in my head anyway. :)

If we _did_ add 'folder' to home then by extension surely all the bookmarks under Places should also get the added suffix. That would bloat the places menu width-wise and look very messy.

Mat Tomaszewski (mat.t.) wrote :

Alan Pope wrote:
> Given no other bookmarks under Places have 'folder' appended to them,
> why should 'home' ?
>
> If I'm articulating to someone how to find their "home folder" or answer
> the question "Where's my stuff?", then saying "Click places, then home"
> sounds logical and succinct.

This applies to the English localizations nicely, what about languages
in which "home" doesn't translate well?

Mat

Ante Karamatić (ivoks) wrote :

Alan Pope wrote:

> Given no other bookmarks under Places have 'folder' appended to them,
> why should 'home' ?

I understand your logic and ti does make sense... in English :)

I doubt 'Homme' in French makes sense. Home is a house, flat, not a
directory on a computer (which is inside of a home). 'Kuća' in Croatian
is also very... I said it already :)

There's also Spanish. Casa? And if you think for a second, it's not that
smart in English too. It's just that we got used to it calling it home.

In you example, 'Where's my stuff?', you could easily say 'Click Places,
then click My-Super-Cool-Folder' and it would still have the same effect
as calling it Home/Flat/World. That's cause you didn't answer to the
question, you explained the steps to the solution. Real world answers
would be:

'In your home folder/directory.'
'In your home.'
'In your personal folder/directory.'

Which one of those sounds most reasonable?

Ante Karamatić (ivoks) wrote :

Ante Karamatić wrote:

> I doubt 'Homme' in French

*blush* *blush*

Maison :)

Ante Karamatić (ivoks) wrote :

Mat Tomaszewski wrote:

> This applies to the English localizations nicely, what about languages
> in which "home" doesn't translate well?

Right. Big difference is that 'Home', actually, can't be translated in
most of the languages. Home, in English, represents 'warm environment
where you sleep and eat, where's your family, etc...'. Where Casa,
Maison, Haus, Kuća are buildings.

Nicolò Chieffo (yelo3) wrote :

Home can't be translated so there are only 2 options:
- use "personal folder"
- let the translator translate "home" into "home" if in the target
language the translation doesn't seem ok, like in Italy we do for
"mouse"

Baldur (baldurpet) wrote :

It's ridiculous that people are complaining over how the word "Home" doesn't sound right when translated into other languages.

"Home" sounds perfectly all right in English, that's a good reason for calling it "Home" in the English version- that in no way forces translators to make exact translations of "home" into their respective languages!

In Icelandic "Heimamappa" (Home folder) would sound better so I would personally stick to that translation even though the English string would be changed to 'Donkey'- get my point? The whole point of being a good translator is NOT to translate verbatim but to translate so it the translations fits and sounds good in the other language.

Nicolò Chieffo (yelo3) wrote :

I think you are are right

Phil (pmagnone) wrote :

Though it sounds a little goofy to experienced users, I think it would be easier for new users to understand "Home Folder" as opposed to just "Home." If I'm helping a friend, I'm going to say "go to Music in your Home Folder." Using "Home Folder" tells the user that it is the folder they should be putting all of their files in. While "Home" is close to that, "Home" is also used too often for a main screen or menu system for devices and interfaces, as opposed to a location for storing files. "Home Folder" would be more descriptive and easier to understand. Like it or not, that's why "My Documents" has persisted for so long; it tells the user exactly what that location is for.

Anyway, just my 2 cents. I do think the naming should be more consistent either way though.

Whilst I find 'Home' the cleanest way to say it (in English anyway), it's not entirely accurate.

The directory it takes you to is not '/home' it's '/home/<username>'

The name for this folder via command line is '<username>', so for consistency (and accuracy) I feel it's best to keep it the same for the GUI - as it already is in one of the three locations in question - this would also solve the translation problem :)

MKdx (my-subscribtions) wrote :

"User Home" would be a good compromise. Although I think "Home" by itself is better.

IMHO, the issue is that users both use shortcuts from the menu, and have to browse the filesystem. If we use "Home" as a shortcut label in the menu, they may think that browsing to /home using Nautilus will lead them to the same place as the "Home" shortcut -> usability issue.

BTW, making a bridge between Windows approach and Ubuntu/Gnome one may be a good idea, to make new Ubuntu users' life easier : the "My documents" concept is very well known and understood.

The only way to addresse both of these issues (help users to make a link between the menu shortcut and their filesystem "~" directory + be "wording-compatible" with Windows) , is to use both the username and "documents" term in the shortcut label. This would give "Yann's documents", for example.

Martin Albisetti (beuno) on 2009-06-18
Changed in hundredpapercuts:
status: Confirmed → Triaged
Ivanka Majic (ivanka) on 2009-06-19
Changed in hundredpapercuts:
assignee: nobody → Ivanka Majic (ivanka)
status: Triaged → In Progress

'Home' in english is best solution, for other languages it is not bad translate home, but also a user name is good alternative.

Tim Macdonald (tsmacdonald) wrote :

..."Your Home" ?

Changed in hundredpapercuts:
milestone: none → round-1
Dana Goyette (danagoyette) wrote :

I have an interesting idea for home folder name: compare the short username to the first-name in "About Me", and if it maches (besides case), then display the name with capitalization as in "About Me". For example, I have my username as "dana" (lowercase), and we could display the folder name as "Dana".

Here's what I see right now:
Gnome "Places" menu: "Home Folder"
Icon on desktop (if gconf key set to show it): "dana's Home" -- this might be good, if we fix the capitalization.

Also, I have had desktop_as_home_dir set until just now, so the following may not match the out-of-box configuration:
Location bar in nautilus: /home/dana
Sidebar in nautilus: (not present)

Following up on what Dana mentions, I suggest we use the user's first name, which can be determined from user information in About Me if it is provided, or by taking the first word in the long username.

Examples:

User A: Full name is "Johnny Appleseed", username is "haxxor", directory is /home/johnny, label is "Johnny".
User B: Full name is "Jamshed Kakkar", username is "jkakkar", directory is /home/jkakkar, label is "Jamshed".
User B: Full name is "Sarah Ann Leonard", username is "saleonard09", directory is /home/saleonard09, label is "Sarah".

If the user adds his/her first name information in About Me, we would update the labels to use the user's preferred name.

Craig Hewetson (craighewetson) wrote :

Would it not be better to make use the user's first name by default? And allow it to be modified in About Me as an option.
Besides, most users aren't going to modify it unless it bothers them.

The use of the word "Folder" is a bit redundant because there is already a very descriptive folder icon. (also the home emblem on the icon will give more clues that its the "home" directory)

Alex French (grackle) wrote :

"Home Folder" is not redundant, because "Home" is a *concept*, not the actual name of the directory. "Home" is the directory "/home."

So, the discussion here should be limited to the following:

Which is better?
1) Using a generic reference to a specific location ("Home Folder" means "/home/<user>")
pros:
The name is generic. If someone needs to refer to your home directory, they can say "Home Folder," and it means the same thing no matter what your username is.
cons:
The way the directory is referred to in Places is inconsistent with the other directories found there.
2) Using the location's proper name ("Alex" means "/home/alex")
pros:
consistent with other items in the Places menu
cons:
A generic way to refer to that folder is still necessary. If such a generic name is no longer defined, references to it in discussion will be inconsistent.

I vote for the generic solution, but I don't care a whole lot either way, as long as it's consistent and makes sense. It's all bikeshed anyway...

@Alex French > If such a generic name is no longer defined, references to it in discussion will be inconsistent.

Do you really think so ? Imagine we're on phone. If I want to tell you to go to /home/alex (e.g.), I just have to tell you "Open the Places menu, and select your folder". If there's an item called "Alex's documents", it will be fine...

Another generic alternative, which would make sense, would be to go for a... Windows cloning : "My documents".

grofaty (grofaty) wrote :

Hi,
what I hate about name "Home" or "Home folder" is that new users are asking which folder is it. Is it /home/user or /home? /home is also home folder, but it is not Home folder.

I suggest to remove "Home" and variants in the first place.
Regards

Changed in hundredpapercuts:
assignee: Ivanka Majic (ivanka) → nobody

I agree with grofaty. The folder we are talking about *is called* /home/username. We could refer to it as "Username's Home".

Bryce Harrington (bryce) wrote :

This is filed against hundredpapercuts, however it's not clear from the discussion what the design decision is. That should probably be done before this is accepted as a papercut.

nunogt (nunogt) wrote :

I like the generic approach. The user's first name, properly capitalized, is a pretty good solution, as it's not misleading nor cryptic. No unfamiliar terms whatsoever, and if their name is there, then it must be their area. It's kind of intuitive.

It's also a nice bridge between the Windows world - in Windows Vista and later the the start menu reference for /Users/username is the user's first name, and My Documents, My Images, My Music, etc, are all subfolders inside it.

Vish (vish) wrote :

"Username's Home" seems a sane choice...
 It doesnt get away from the present labels and it is an appropriate label since it is actually the user's home directory... :)

Johan (deberghes-johan) wrote :

And what about "Username's Data" ? This is easy to translate, there is no way to think it is the /home folder, and it's relatively consistent with the /home/username folder...

Ante Karamatić (ivoks) wrote :

virkang wrote:

> And what about "Username's Data" ? This is easy to translate

Regarding translation, "'s" is common only in English, if I'm not
mistaken? Other languages are more complicated than that - they have
genders.

As for Slavic languages, I guess they'll just ignore English perception
and translate it as 'Personal folder' or something like that (or in
worst case just 'Username'). Cause, if user is female it would be
'Ivankini podaci' (Ivanka) and if it's male, it would be 'Petrovi
podaci' (Petar) - no, even 'Data of ${username}' isn't unique for both
genders. In my language it's almost impossible to translate
"${username}'s" and we always look how to avoid it.

Dr. Dabbles (drdabbles) wrote :

Just to add my comments to the din-

I think "Foldername", "User's Folder", and then "Home" would be my preference in order. I think adding "folder" is redundant and not needed. As already stated, there is a folder icon already notifying the user that this is, in fact, a folder.

I think using "Foldername" is the best, since the bookmark name and the folder in question will have the same name. Where we can control the shortcut's name, simply using an upper-case letter is an easy thing to do. In applications we don't modify, the folder still has the same name without the capitol letter. This gives consistency within any app that allows the user to brows the /home folder for their particular repository of data. This also avoids using inconsistent translations between languages, since it is clear that "Home" would not be used in all languages.

Using "User's Folder" is impractical, as many applications that offer a file browser will not use the default Gnome browser. Several apps within the repository simply default to the /home or /home/username folder. Again, the above plan would appear consistent to newer users. "User's Folder" would simply fall down in this scenario.

Using "Home" or "Home Folder" to me is not really an option. The directory /home already exists in the LSB specs, and referring to any other folder by that name is a bit confusing to a new user that is exploring. In addition, there are the previously mentioned translation issues and the lack of bookmarks in every file browser dialog for every windowing kit.

Just my two cents.

augias (augias) wrote :

My vote goes for "Username". Period. It's simple, logical, no translation problems, no conflict with /home directory, simple to explain, and fun.

Just call it "My Files" or "My Data". The latter may sound too technical. That is what you are looking for. That is the root directory of where all your personal data is stored. There is nothing else there but files. My is a much shorter word for Personal. Personal is also more vague although everybody knows what personal means. Home has a lot of issues with translations and it does sound more like really home as in the beginning. To my feeling, a synonym for Home is Top in this case. It also feels more like how Home is used in a browser. A very broad term to say starting point.

"My Files" if it was up to me :) Easily translated and it really captures what you can find in your personal home directory... files!

Ante Karamatić (ivoks) wrote :

Bungaman wrote:

> "My Files"

+1 from me :)

kenden (kenden) wrote :

Even Microsoft changed "My Music", "My Document", "My Pictures" into "Documents", "Music", etc in the last versions of Windows, because that was patronizing to the user.
I am sure the design team has received enough suggestions now to make decisions now.

Ivanka Majic (ivanka) wrote :

@Kenden Ineed we have :-)

We recommend using the short username.

Mat Tomaszewski (mat.t.) on 2009-06-25
description: updated

Is it worth using the Ubuntu Brainstorm website as a method of polling users to get an idea of what most people would want? Or would you prefer to make the decision internally to this discussion?

Christian Kujau (christiank) wrote :

To make the lists of suggesstions even longer:

* I don't really like spaces in filenames when they can be avoided. "Home Folder"....why?
* why not just the user's name (login name)? Apple does it in MacOS X....and nobody has to translate a thing (internally we refer to it with $HOME or ~ anyway)

So, Ivanka: +1 on the short username!

Michael Rooney (mrooney) wrote :

On Thu, Jun 25, 2009 at 12:37 PM, Christian Kujau wrote:
> So, Ivanka: +1 on the short username!

I also prefer this solution, glad to hear it is the one being
considered. The user is very likely to understand and recognize their
own username and it doesn't need to be translated. Plus it will be
consistent with the actual directory structure of /home/username!

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Just a test...

Michael Rooney a écrit :
> On Thu, Jun 25, 2009 at 12:37 PM, Christian Kujau wrote:
>> So, Ivanka: +1 on the short username!
>
> I also prefer this solution, glad to hear it is the one being
> considered. The user is very likely to understand and recognize their
> own username and it doesn't need to be translated. Plus it will be
> consistent with the actual directory structure of /home/username!
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkpD4aQACgkQKPYCdhn2v2wjBQCghMQSdFKZLq24Wa+B3y5QLNJj
sqUAnA32f14BwG5IjOoaVxhuBbFkeOAg
=M8Ue
-----END PGP SIGNATURE-----

Changed in hundredpapercuts:
milestone: round-1 → round-7
Waldir Leoncio (wleoncio) wrote :

I don't know if it is too late for this, but I'd like to register this anyway: +1 for short username!

Waldir Leoncio (wleoncio) wrote :

I don't know if it is too late for this, but I'd like to register it anyway: +1 for short username!

l-x-l (labouie) wrote :

+1 for short username

Phylum (metus-m) wrote :

This could be useful.
I was pretty confused when I first used Linux (Ubuntu).
Really, it should be the username all across, not "home"

johnk (johnk-riceball) wrote :

"Home" is terrible. Home directory is a concept, and "home" is the unixy terminology. (Remember $HOME?)

"Home Folder" is also not good. It's hung up on the concept.

The first name is a bad idea, because if you have two users named John, it'll get confusing.

The full name is good, because it's likely to be unique. However, there's one level of indirection going from the name to the username.

The username is very good, because there's a simple mapping from the directory to the username. Usually, the home directory is named the same as the username.

username's Folder is also pretty good. The mapping is not that confusing, and there's an element of explanation there. However, anything less than a 1:1 mapping between names is generally negative. It always leaves the question of whether one name is equivalent to another name.

I think "username (home folder)" within Nautilus could work. It's verbose, but explanatory, and the mapping between /home/username and "username (home folder)" is pretty close. The format also mirrors the old email convention where you'd have "username (Full Name)" in the "To:" header.

Following up on the email idea, perhaps "Home Folder <username>" would be an acceptable label within Nautilus. The angle brackets denote the "computer's identifier". The problem is that it looks too much like an email address.

Personally, I prefer the short username.

Alex Bruce (alexbruce7) wrote :

Just reading some of the comments (including johnk above) I think some people are confused over what is being discussed.

the convention /home/username (ie username= johns therefore home = /home/johns) isnt going anywhere. this will always be the case as every username on a Linux system must be unique therefore every folder is unique. This is the same for Windows and Mac

This is just to discuss how it is refereed to in the Places menu or other locations, just the name of the Launcher effectively.

Personally I think it should be a standard name such as "Home". I can understand the multi-language problems but am wondering if completely different words can be used (not just a direct translations of the word Home). Sorry I don't speak any other languages so cant provide any examples, the philistine that I am. 8)

The main reason I +1 to "Home" is support. telling someone (over the phone etc) to go to their home folder, if the home folder is called JohnS etc will confuse some people.

Ive come across this when supporting Windows users when the environment was changed that every "My Computer" Icon was renamed to the hostname of the computer. This meant a lot of users just didn't even know where they were going and asking them to go to "My Computer" meant they couldn't find it. Some users were fine with it but it caused a lot of problems.

really the Home Folder should be the same place relative to any user that uses an Ubuntu PC. Just like in the terminal any user can type "cd ~" and they are taken Home. Although it is a different folder name (/home/username etc) obviously for every user, the user should never have to think that it is a different folder.

There are some other advantages as well. Although not a common operation you might want to use a copy of a home folder generated under UserA for UserB (similar to editing the /etc/skel folder). although this can be worked around by other means (as a lot of things can in Linux) there is a chance that the username references, UserA, will remain in the now UserB profile complicating the process.

anyway +1 for "Home"

Hassan Williamson (hazrpg) wrote :

+1 to username

The whole "Home Folder" concept is daft, because to me that means /home. Although I know "Home Folder" is /home/*username*. If everyone turns to Windows Vista (even though I hate it so much) it has changed "My Documents" to "*username*" in the start menu and the sub-directories inside of it is "Documents", "Music", etc etc...

You could have it "*username* folder" or just "*username*"... without having the apostrophe s ['s], that way translation isn't a problem because the name of the actual folder is *username* in the /home/*username* location. Simple (right?). :)

Hernan Rodriguez (h01) wrote :

Julián Alarcón wrote:
> And.. how do you will translate Home, for example.. to Spanish?? "Casa"??? "Inicio"?? This don't sound good..
> The best is Home Folder.
 in spanish home folder resive the name "carpeta personal"

komputes (komputes) wrote :

I don't think it should be called "Home Folder".

Either "Home" or username in the Places menu and the nautilus toolbar is good. As long as there is a home/house emblem, there should be little chance of confusion with /home. "Home" is short, easy and clean. username is consistent with save/open menus in applications. I see validity in both options.

bdoe (bdoe-att) wrote :

I don't know if it's too late to add my own two cents -- if so, then it's free. :p

When I first switched to Linux two years ago, the idea of the home directory kinda threw me as well, but then Windows Vista ran with the concept. Now, I don't have a lot of good things to say about Vista, but one thing I feel they did get right was changing the structure of its users' personal folders, so now it closely resembles how Ubuntu does it. I also like how Vista addressed the naming of this folder, to a degree.

This is how I feel Ubuntu should handle the current "Home Folder" naming mess: From a filesystem standpoint, the users' home folders should remain named their login name. On Nautilus, in Gnome's "Places" menu (and other desktop managers that handle shortcuts), and anywhere else where the user's home folder is referenced in a GUI, it should be listed as the user's full first and last names, if both are available -- otherwise fall back to the user's login name.

My reason for using the full name approach when available is simple: Being called by your real name is more personal. Being called by whatever screen name you've been arbitrarily assigned by your administrator (or have given yourself in order to prevent spaces in your login name) is just not as personal. To me, it seems cold and abstract.

So, in summary (since I have a tendency to ramble):
Home references in shell/cli: value of $USER
Home references in GUI (Nautilus, Places, etc.): First Name + Last Name, if BOTH are available; otherwise fall back to value of $USER.

yman (s-y-schwarz) wrote :

Right now Nautilus seems to be using my user-name for ~, while the Places menu uses Home Folder. I think for consistency's sake it would be better to mount or link to ~ under the name Home, let's say /tmp/username/Home would link to /home/username. Use /tmp/username/Home instead of /home/username as the Home folder when starting a session, and you get consistency across all applications (except any that are stupid enough to use /home/$USER instead of $HOME) AND get to call it whatever you want, regardless of what the real Home folder is called.

As to what it should be called, we are trying to help new users here who aren't in on all this information. So from a support POV it would be better to call it Home, and when talking about it call it Home folder, same as Documents being discussed as Documents folder, or Places being referred to as the Places menu or Places sidebar.

Jennie Petoumenou (jennie) wrote :

I just finished reviewing the Greek translation of nautilus and I'd like to add my opinion after having spent some time dealing with the problem.
It has been said a few times already, but let me stress this once again:
Home (or home folder) is translated "personal folder" in most languages (including Spanish, French, German, and Greek). So, for most languages other than English, home is neither the shortest nor the prettiest choice. For those languages, the real choice is between the user name and a rather long two-word phrase signifying personal forder (ES: carpet personal, FR: fichier personnel, DE: Persönlicher Ordner, EL: Προσωπικός φάκελος). Personally, I would go for the username, since most people choose a username which is short and meaningful.
For the record: the Greek team decided to change the phrase "Username's home", which appears on desktop shortcuts, to "Username". Once again, we thought that a three-word shortcut is not a pretty sight. Aside from the fact that in Greek (and Russian, I think), the possessive Username's is not a gender neutral construct, so you actually have to add both the feminine and the masculine version. Whatever happens, please do not use the possessive 's!

Consider this: If the user even *knows* where in the filesystem their files are kept is, then they probably also know that it is different from just "/home", and they probably also know that "home directory" is the proper name. If they don't, it takes all of 30 seconds for them to find out.

So, I'd say it should show up as exactly one of the following, in order of preference:

"Home Directory"
contents of $HOME, e.g. /home/vanessa
"Home"
"My Home"

Whatever you do, don't just use the user's first name. It pre-supposes that the user has put in a valid first name, and really, it gets confusing if the user has more than one directory related to their name.

As for the amount of space an entry takes up on the screen... I'm using a 13 point font (as my vision isn't the greatest), on a 19" LCD at 1280x1024, and "Home Directory" still only about 4 cm wide here in this comment editor.

I can't say much about the need to translate, except to say that, since you are already learning a new OS, you're eventually going to have to learn where your stuff is kept. You may as well just learn that the term for it is "home directory".

Changed in hundredpapercuts:
milestone: round-7 → r1
description: updated
description: updated
Tyson Williams (bender2k14) wrote :

+1 for short username

avdzm (alecos85) wrote :

I believe that a new user to linux might not understand user name alone.
I think it should be <user> Files, I don't think there is a translation issue, in Greek it works.

oliver (oliver-schinagl) wrote :

I've been using my desktop in the english language for years and even still found 'home' to be a bit off.

I've noticed a lot of people mention personal folder and I must say I quite like that. Even in our dutch language, it's called "Persoonlijke Map" which is also personal folder. Whereas we do also have 'thuis' meaning home, the warm comforting feeling the english have with 'home'. But I don't store my files in my home. I suppose using 'home' came more from the very old '/home' from the old unix world.

Making it shorter though, just Personal I do think might be a bad idea, Personal Folder is somewhat longer, but just works better imo.

Ferk (ferkiwi) wrote :

The "username" idea is not practical.

What if you want to give instructions to teach your friend?
How would you tell him to go to his home folder?

- Go to Places then "Mike".

What if the vendor who installed the system to him chose some generic username to him? what if instead of "Mike" he put "Michael"? There won't be a consistent way to call it, how would he call it when he doesn't know that it's the "home" folder? he will call it "Mike's" folder? kinda weird.

We need a generic name for the folder so that it can be referred in a generic sense without knowing the username of the specific user account.
I vote for "User Home", or if you don't like white spaces call it "Userhome" (Username is also lacking the whitespace, isn't it?).

augias (augias) wrote :

>Ferk wrote 2 hours ago: #70
>What if you want to give instructions to teach your friend?
>How would you tell him to go to his home folder?

- "Go to the folder that has your name"

>What if the vendor who installed the system to him chose
>some generic username to him? what if instead of "Mike"
>he put "Michael"? There won't be a consistent way to call it,
>how would he call it when he doesn't know that it's the "home" folder?
>he will call it "Mike's" folder? kinda weird.

- He'll call it the user's folder / the folder with the user's name on it

>We need a generic name for the folder so that it can be referred
>in a generic sense without knowing the username of the specific user account.

- N (where n = username)

>I vote for "User Home", or if you don't like white spaces call it
>"Userhome" (Username is also lacking the whitespace, isn't it?).

-This doesn't translate well at all: Hogar del Usuario / Nombre del usuario.

each session is a personalized experience. the person who logs in knows who he is and understands that a folder with his name on it is probably where all her or his things are. karmic solved this very well and i don't understand why it's still considered a papercut.

Ante Karamatić (ivoks) wrote :

augias wrote:

> each session is a personalized experience. the person who logs in knows
> who he is and understands that a folder with his name on it is probably
> where all her or his things are. karmic solved this very well and i
> don't understand why it's still considered a papercut.

I'm quite sure that person will be confused by some many 'usernames' at
the panel. You would have username button (with IM icon!) that shuts
down machine (with IM icon, remember?), restarts machine, changes IM
status, changes password, and then you would have another username
button (with folder icon) which brings you to your directory, but not to
your files (cause your files are in Documents, Music, Downloads, etc).

'Click your username' (it sounds stupid already)
'Ok, now I can shutdown machine'
'Oh, sorry, the other username, the one under Places'
'Ok, now I see the same folders that were under Places menu. Why didn't
I just click the right folder under Places menu?'

If you want to call is 'username', then put it under existing 'username'
button and don't confuse user with same button title that does different
things.

avdzm (alecos85) wrote :

I agree with Ferk, +1

Beni Cherniavsky (cben) wrote :

> I doubt 'Homme' in French makes sense. Home is a house, flat, not a
> directory on a computer (which is inside of a home). 'Kuća' in Croatian
> is also very... I said it already :)

By same logic:
I doubt 'Home' in English makes sense. Home is a house, flat, not a
directory on a computer (which is inside of a home).

What people frequently forget about silly-sounding translations of English
computer terms is that they are just as silly in English! Non-native English
speakers have just accepted their double normal/technical meaning
because they were foreign.

WRT to the bug, note that:
- GNOME puts a house emblem on the folder, so if you change the name,
  you should also change the emblem.
- The filesystem has them under /home, and sooner or later may users are
  exposed to that. Be careful of names like "User Folder" lest users look
  for it under /usr :-)
  Renaming it for UI consistency risks users facing a bigger inconsistency later.
  (The real fix is renaming fixing FS names, like Mac OS X. But that's controversial.)

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Sebastien Bacher (seb128)

This should be fixed. If we can't do this work upstream, then we should figure out how to at least make it consistent in Ubuntu. Please note the priority is Low, and I have not changed it.

Seb128 - please comment on the feasibility of making this happen based on https://wiki.ubuntu.com/OneHundredPaperCuts/Spec/382703

Sebastien Bacher (seb128) wrote :

The change are feasible, it would be nice if somebody from the hundredpapercut project would email the proposal to the nautilus upstream list though so they could comment on it too rather than changing strings in a distribution specific way

Roshan George (roshan-george) wrote :

Red Hat something used to use "username's home" which worked just fine. That's my suggestion.

Vish (vish) on 2010-06-11
Changed in hundredpapercuts:
milestone: lucid-round-1 → maverick-round-1-file-management
Changed in nautilus:
status: New → Confirmed

I suggest "Home" in "Places" and "Nautilus toolbar" but it should remain user's name everywhere else. As $HOME variable maybe changed from terminal, but "user" folder should remain accessible otherwise as well

Keith Allcock (keith-allcock) wrote :

Amazingly long discussion .. no doubt someone will be upset after the change ..

+1 on the short username!

Vish (vish) wrote :

No one is actively working on this bug atm. upstream has a patch which needs work.

Changed in hundredpapercuts:
status: In Progress → Triaged

+1 actual username (as in: the same name the folder actually has)

Whenever I install ubuntu for a new user; they _always_ ask about this.
So here is my reply:

<<

       Well, there is this folder, where you keep your files.
       It's name is your username. Every user has its folder like that, in a folder called 'home'.

       It's called something differently in a lot of situations.
       Personal files (dutch translation!) in this translated application.
       Home folder in this other non-translated application, eventhough it's not the same folder as 'home'

       You can best just try, and remember visually the places where you click and where they go.
       Expect no consistency.

>>

Here's a rule of thumb.
No folder may have more than one name.

I don't care what the folder is called by default.
But it should be called the same thing:

  - when browsing in the /home folder in nautilus (as any user)
  - in the nautilus crumble bar
  - in the nautilus crumble bar, when on literal mode (control+L)
  - in search-dialogs
  - nautilus sidebar
  - nautilus go-menu
  - terminal commands
  - gtk-open dialogs
  - location-menu
  - non-native file dialogs (like Java apps & wine apps)

So, how did this situation get so messy?
Well, because appearantly, there are people out there, that believe that we should be managing the names of folders in language-packs. They apparently don't know what a filesystem does.

Folders are complicated enough for people to begin with.
And every application and place having a discussion about what their translation should be, isn't helping.

This should be in the HIG: You may never, put a folder name in a translation-file.
If you think other names are more 'usable', go argue to change the default name.
But not in the application's language-packs. The file-system is quite capable of managing the actual name of the folder.

For example, it would a smart idea to rename /media to /devices, so wouldn't need this fake 'this computer' folder.
Try going a level up from a mount. It's doesn't even go back to this fake 'this computer' folder.

It's so confusing. One file-hierarchy to rule them all, please.
With one name per folder. Predictable, consistent.

And yes, maybe the default folder names of things should be changed.
But we should never put that change into applications or language-packs.

Changed in nautilus:
importance: Unknown → Low

Here are the options I see. Every one just gives new papercuts.

1. Change the folder it points to to the actual /home folder
 - which is a folder a normal user wouldn't care about.

2. Ad " 's folder" to username
- This would assume too much about what a username is. If I have a username "cars" for some reason, the folder would be labeled "cars's folder". Languages have too many crazy rules for this to work even in english.

3. Simply use the username as is
- Thus we would be going to Places>nathan. Aside from being uncapitalized (by necessity, think iTunes vs ITunes), this is a poor metaphor for a desktop. It forces the user to think of "nathan" as a directory, rather than a name.

4. Leave the bug untreated, or at best combining both to Home Folder.

---
4 isn't even treating the issue.
1 and 2 make new problems which aren't easily overcome
3 is thus the least bad, and I think the only real solution we have available without changing the way we organize files.

kumar (lovesyou-kumars) wrote :

On Tue, Nov 9, 2010 at 10:53 PM, <email address hidden>
<email address hidden>wrote:

> Here are the options I see. Every one just gives new papercuts.
>
> 1. Change the folder it points to to the actual /home folder
> - which is a folder a normal user wouldn't care about.
>
> 2. Ad " 's folder" to username
> - This would assume too much about what a username is. If I have a username
> "cars" for some reason, the folder would be labeled "cars's folder".
> Languages have too many crazy rules for this to work even in english.
>
> 3. Simply use the username as is
> - Thus we would be going to Places>nathan. Aside from being uncapitalized
> (by necessity, think iTunes vs ITunes), this is a poor metaphor for a
> desktop. It forces the user to think of "nathan" as a directory, rather than
> a name.
>
> 4. Leave the bug untreated, or at best combining both to Home Folder.
>
> ---
> 4 isn't even treating the issue.
> 1 and 2 make new problems which aren't easily overcome
> 3 is thus the least bad, and I think the only real solution we have
> available without changing the way we organize files.
>
> --
> "Home Folder" has 3 different names
> https://bugs.launchpad.net/bugs/382703
> You received this bug notification because you are subscribed to
> nautilus in ubuntu.
>
> Status in One Hundred Paper Cuts: Triaged
> Status in Nautilus: Confirmed
> Status in “nautilus” package in Ubuntu: Triaged
>
> Bug description:
> "Home Folder" is called "Home Folder" in the Places menu, "Home" in
> nautilus toolbar and by user's name everywhere else.
> It should use a consistent name across the whole system..
>
> Design Spec: http://wiki.ubuntu.com/OneHundredPaperCuts/Spec/382703
>
>
>
>
>

Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-1-file-management → nt4-nautilus
max (maxozilla) wrote :

Actual first name's Home, eg. Joe's Home. If the user hasn't registered a first name, then their username instead, eg. jblogg's Home.

David (david.regev) wrote :

Max makes a great point. People are known by their personal names. In the example, Joe’s friends know him as ‘Joe’. Almost no one would call him ‘Joe Blogg’, and absolutely no one would call him ‘jblogg’—except, oddly, his computer. That is not humane. What Joe should see is his personal name. If, however, there are more than one Joes registered on the system, it should display his full name (or perhaps just ‘Joe B.’). Finally, only if Joe has not given the system his name should it display his username.

A similar point can be made for the Me Menu. It lacks an option to display only one’s first name (which should be the default).

David Klasinc (bigwhale) wrote :

Changing underlying *nix mechanisms would complicate things too much and could bring a lot of confusion. I believe that the best solution is something in the line of:

if directory_name == os.environ['HOME']:
  icon_name = _("Home")

There is nothing wrong with the term 'Home' for a home directory. In unix world this is your home, everything that is yours should be there. :) When I want to see my files I want to go to my home not to BigWhale's Home. Referring to myself in third person feels a little bit silly.

I vote for "Home" all around. Places, file dialogs and nautilus windows.

Dooitze de Jong (dooitze) wrote :

I think the cause of this problem is the translation of the three names.

Eric Mill (konklone) wrote :

I think nathanlee sums it up pretty well in #82. The least bad option is to go with "[username]".

This folder name does *not* have to be literal, it just needs to be *consistent*. It can be a concept that people adjust to after they see it for the first time "oh, 'eric' means all my documents and stuff". People can figure this stuff out, and we should respect their intelligence. It's when it's inconsistent that they give up on trying, which is totally understandable, and what this bug is all about.

glomboi (glomboi) wrote :

"My Documents" should not be used as most of the files in "My Documents" would not be "Documents" (eg. music, videos).

"Home" or "Home Folder" is incorrect, since this implies /home, not /home/[user].

Using "[User]" (or "My Files", "[User]'s Files" or similar) would lose the meaning of the /home/[user] structure. This would be the best option if /home/[user] was, perhaps, replaced by /users/[user]. This loses continuity with other Linux distros though that isn't necessarily a bad thing - users ofter refer to Ubuntu separately to Linux anyway! Compatibility wouldn't be lost with other distros since ~/ would redirect to /users/[user]. Difficulty comes with transferring /home partitions to/from other distros or older versions of Ubuntu.

"[User]'s Home" is the best option using the current /home/[user] system. It makes the "home" meaning clear whilst not confusing (indeed emphasising) new users with the difference between /home and /home/[user].
This issue with this comes with the translation. However, each translation could choose its own option, just use "User", or "My Home", or their own translation, or just the English word "Home" - after all, Ubuntu isn't an English word and yet we all know what it means, "Home" could be known by everyone to be the cosy place you go to while it looks after all your files!

As far as the English version of Ubuntu is concerned, I believe "[User]'s Home" is by far superior to the other options.

glomboi (glomboi) wrote :

Note: using [User] not [username] is the only option as mentioned in numerous posts.

Wouldn't the me menu label (currently "[username]") have to be changed if the Home Folder was named simply "[username]"?

bdoe (bdoe-att) wrote :

What about just calling it "My Home"? Sure, it's a bit Windows-esque, but it's a concept the widest audience is already familiar with, does away with the question of using User Name vs. username, has no translation issues, still lends a personal feel to the desktop experience, and can be consistently applied across the board.

ubby (kostas-sytske) wrote :

OS X also use the username. I think using the username will be a good idea.

mitch (mitch-embry) wrote :

+ 1 for username. Surely even the most naive user could deduce from common sense that the folder with their username is their 'main' folder. I know that we're trying to spread Linux to the masses here but we have to realistic about the type of users that are likely to convert and I would venture to say that someone who would be confused by that most likely would never even consider converting from windows and OSX users are likely familiar with Unix naming conventions so it probably wouldn't be an issue for them anyway.

Elias Julkunen (eliasj) wrote :

Using only the username shouldn't be any confusing as there is the home folder icon just next to the username. The tooltip could be something like "Your Home Folder" and that would make it even more clear.

Jacky Alciné (jackyalcine) wrote :

So true; this issue is mainly rooted in the GNOME desktop environment and
Nautilus..

Who's willing to start? I'd follow. :D

Vish (vish) wrote :

w00t! this has now been fixed upstream!

Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

This is fixed now.

Changed in nautilus (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
status: Fix Committed → Fix Released
Timothy Arceri (t-fridey) wrote :

Now it seems Unity wants to call it "Home Folder" instead of "Home"

Changed in hundredpapercuts:
status: Fix Committed → Confirmed
Omer Akram (om26er) wrote :

no need to open a closed bug. see bug 761093 for Unity or report a new bug report.

Changed in unity:
status: New → Invalid
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Timothy Arceri (t-fridey) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.