navigating in nautilus causes external drives to spin up

Bug #376053 reported by Alexander Krivács Schrøder on 2009-05-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
New
Low
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.26.2-0ubuntu2
  Candidate: 1:2.26.2-0ubuntu2
  Version table:
 *** 1:2.26.2-0ubuntu2 0
        500 http://ftp.uninett.no jaunty-updates/main Packages
        100 /var/lib/dpkg/status
     1:2.26.2-0ubuntu1 0
        500 http://ftp.uninett.no jaunty/main Packages

PROBLEM:

Mounting my external drives and not using them for a while causes them to spin down. After this happens, trying to navigate in any open nautilus window will cause both of them to spin up. Navigating the file system in a terminal does not cause this behavior.

I'm worried this useless spin-up behavior is reducing my drives' life times. Navigating nautilus while they are spun up does not appear to cause any file access on them (their 'activity' indicators are unaffected) so I can't tell what's up.

WHAT YOU EXPECTED TO HAPPEN:

As long as I'm not actually browsing my drives, and nothing needs to access them, I expect them to stay spun down.

WHAT HAPPENED INSTEAD:

Any use of nautilus when the drives are spun down causes them to spin up.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. What sort of disks are those? Do you get the issue in nautilus only or a fileselector in gedit does the same for example?

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

One is a Maxtor Onetouch III, the other is a Seagate FreeAgent Desktop. If it matters, they are both cryptsetup LUKS disks.

I just tested in gedit, and using the file selector did not cause the drives to spin up. Then I tried navigating nautilus again, and this time, just the Maxtor disk spun up. Then I let it spin down, and I tried navigating again, and this time, neither of them spun up.

This flaky behavior makes it a lot harder to figure out what the trigger is, I'm afraid...

Sebastien Bacher (seb128) wrote :

changing to new, to send to the software writters on bugzilla.gnome.org by somebody having access to a buggy configuration

Changed in nautilus (Ubuntu):
status: Incomplete → New
BirD (bird22) wrote :

I also have the same issue, using a WD 500gig drive.

Pedro Villavicencio (pedro) wrote :

It looks like bug http://bugzilla.gnome.org/show_bug.cgi?id=536088 ; could someone comment there? reporter stated that it was fixed with 2.26. thanks.

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
status: Unknown → Fix Released

Closing since no further information has been provided.

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released

I've experienced this bug in Jaunty and now in Karmic. I have 5 Western Digital external USB drives (quite a lot, I know). I did a clean install of Karmic, and after plugging in the drives I notice significant lags in these operations:

  - Starting up GNOME. I'm running on an SSD, so time to desktop normally is around 10 seconds from GRUB. With the drives plugged in, it takes an additional 10-15 seconds while each drive spins up.

  - Opening the "Places" menu. Nautilus insists on spinning up each drive when opening the Places menu.

  - Opening "Computer".

  - Occasionally in Save or Open dialogs.

This is not fixed in GNOME 2.26. Can someone else confirm and reopen this bug?

I'd be happy to provide any logs, just let me know which ones.

As the fellow who originally issued this report did:

$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.28.1-0ubuntu2
  Candidate: 1:2.28.1-0ubuntu2
  Version table:
 *** 1:2.28.1-0ubuntu2 0
        500 http://us.archive.ubuntu.com karmic-updates/main Packages
        100 /var/lib/dpkg/status
     1:2.28.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/main Packages

I think this report should be reopened since the bug still exists.

Changed in nautilus (Ubuntu):
status: Fix Released → New

The upstream reporter stated at https://bugzilla.gnome.org/show_bug.cgi?id=536088 that the issue is fixed for him; that is why they closed the bug (and accordingly, we did). Please comment on that upstream bug, since this is where the developers will read it. Thanks.

Reported upstream, thanks.

Changed in nautilus (Ubuntu):
status: New → Triaged
status: Triaged → New
status: New → Triaged
davidy (davidyang102) wrote :

same here. I have a WD elements 1tb drive, which has no off switch. As a result every time i use nautilus i have to wait 6 seconds before it responds. Of note, the disk is mounted under /extern5/, perhaps if i mounted under /media it would not spin up. I'll try soon

Changed in nautilus:
importance: Unknown → Low
status: Fix Released → New
Sebastien Bacher (seb128) wrote :

Do you still get that issue in newer Ubuntu versions?

Changed in nautilus (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.