nautilus "open with" property no longer available for folders

Bug #366963 reported by Ari on 2009-04-25
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Nautilus
Won't Fix
Medium
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: nautilus

After upgrading to ubuntu 9.04 (amd64), nautilus "open with" property is no longer available for folders.

How to reproduce:
- open a nautilus window
- right click on any folder icon and choose properties
- observe that there is no longer a tab called "Open With"

All previous ubuntu versions had this property tab so I think this is a bug.

I need the "Open With" property tab to be able to delete entries in Nautilus' "Open With" context menu.

For example, I use nautilus' context menu to open (associate) a media folder with my music player (audacious), so that the player plays all the music files in that folder. Similarly with photograph folders and so on.

With Jaunty, there is no way I can find to remove any of the "Open With" entries in nautilus context menu for Folders. Note that the "Open With" property tab still works fine for regular files; the only problem now is with folders.

Please give us back the "Open With" property for folders!

Ari (ari-reads) on 2009-04-25
description: updated
Ari (ari-reads) on 2009-04-25
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the tab has been removed on purpose because it's not possible to change the default associations for directories now which didn't make sense, your request is sort of a corner case, to send to bugzilla.gnome.org

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
status: New → Confirmed
Ari (ari-reads) wrote :

If it didn't make sense, then why does nautilus offer "Open With" with folders? I still can (and do) open folders with audacious, banshee or showfoto.

Something is wrong with the assumption that it didn't make sense.

I opened a bug with gnome bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=580309

Sebastien Bacher (seb128) wrote :

Changing the default doesn't make sense because when double clicking on a directory in nautilus you get whatever sofrware started rather than the directory open when you do that change

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Ari (ari-reads) wrote :

correct - changing the default doesn't make sense, but having the tab does: nautilus lets you add entries in the "open with" context menu but offers no way to remove them. That is what I described in gnome bugzilla's bug.

Thanks

Sam_ (and-sam) wrote :

Hi, just a follow up, to sort out and avoid misconceptions.
I came along finding users having the problem that places menu open with a specific application, e.g. Totem, VLC, which wasn't expected, (especially after a dist-upgrade).

Hence I think, this might be one reason for removing this tab, because making a file to open with a certain app results in an entry in ~/.local/share/applications/mimeapps.list and has something to do with inodes.
For some it helped to remove the entry there, others open places -> computer to right click on a folder to choose 'open with folder' again. On the other hand users with Jaunty miss the tab now in case to correct misbehaviour.

It appears there are two separate scenarios. This command:
xdg-mime query default inode/directory
results in
nautilus-folder-handler.desktop
and here:
~/.local/share/applications/mimeapps.list
is e.g. the entry
inode/directory=totem.desktop;nautilus-folder-handler.desktop;nautilus.desktop;

If my thoughts go the wrong path please correct me, thanks.
Though I asked myself, why I was never affected by this. It occurs I never right click e.g. a music file to open it with a different app. I either double click on the file or I open an app and choose file or directory from within the app.
The question is/was how do users open their files and is it rational to have many different choices, regarding the underlying concept.
##Note: I'm not familiar with correlations, rather were looking for a helpful answer for someone else with all the mentioned issues.

References: [search query 'places open with']
https://answers.launchpad.net/ubuntu/+question/46377
https://answers.launchpad.net/ubuntu/+source/rhythmbox/+question/63127
http://ubuntuforums.org/showthread.php?s=220797f0cf76d8ab80b32f643c88b2fa&t=1138140

#27, #28
http://forums.fedoraforum.org/showthread.php?s=a8b9c59f3b70d2835b903b085962824d&t=194031&page=2

Changed in nautilus:
status: Unknown → Won't Fix
Changed in nautilus:
status: Won't Fix → New
Alex (alex112283) wrote :

This bug affects me as well. I tend to have DVDs stored in their file format on my hard drive (eg Caddyshack/VIDEO_TS/). Because of this, I set folder to open with totem--that way I can quickly open DVD folders in totem via a right click. Because there is no longer an "open with" option in the properties tab now, I can't remove open with associations that I used to be able to in the properties menu.

Thus, I have a question and a suggestion. As for my question, how do I remove the "open with application x" (say I set it to use vlc but I no longer want to see "open with vlc") from the little menu that pops up during a right click. As for my suggestion, I think that it would be best if the nautilus "open with" returned to the folder properties. Also, I have not heard of any new users being confused by having an "open with" tab in the folders property. The way it is set up now certainly does confuse people, myself included obviously, because there is a visible way to make folders "open with" but no visible way to undo / edit that "open with" for folders. In the end, this has just become needlessly complicated and can be remedied by simply returning things to as they were.

Sam_ (and-sam) wrote :

> say I set it to use vlc but I no longer want to see "open with vlc"
Concerning Karmic 9.10, has the right click option of
properties -> tab "open with"
and the ability to remove e.g. "VLC" from the list.

JEDIDIAH (jedi) wrote :

I would just like to chime in with a "me too" since I just had to tidy up something by directly manipulating mimeapps.list.

I also use this feature and would like to see it continue to be available and also to be something that can be fully utilized without resorting to manually dinkering around with XML files. The idea that you might want to process or open an entire directory is not a terribly unusual one. I have been using alternate "directory browsers" since I was using dfm (before GNOME).

A flexible system allows the end users to easily come up with all sorts of interesting things that maintainers might never think of.

BTW, I am running 9.10. I would like to be able to edit the "Open With" properties of directories the same as I can do for files/filetypes.

Alex (alex112283) wrote :

@Sam

Unfortunately, VLC, and some other programs, cannot be removed from this list. Does anyone know how I can get rid of the ""open with VLC" dialogue when I right click a folder?

Ari (ari-reads) wrote :

@klemperal

you wil need to manually edit: ~/.local/share/applications/mimeapps.list

Not very user-friendly nor intuitive. Sometimes (only sometimes) the rationale used by gnome developers to add or remove features escapes us simple mortals.

SebastianK (s-j-k) wrote :

I absolutely agree with Sam. It may be a serious problem for (new) users, when the places menu is broken.

We have at least 15 threads calling for help in the german speaking forums (ubutuusers.de). It is also is hard for them to get help, because the behavior of the bug may be different (e.g. opens applications XY which may not even have a GUI).

An alternative bugfix could be to force directories to be opened by nautlius. (At least when opened via places menu).

sorry for my english ;-)

SebastianK (s-j-k) on 2010-05-17
tags: added: open with
tags: added: open-with places-menu
removed: open with
Sebastien Bacher (seb128) wrote :

not sure what the new comment is about but this bug has nothing to do with the places menu, could people having an issue with this one open a new bug?

Doug McMahon (mc3man) wrote :

Do not believe bug # 603833 is a dupe - separate issue

Changed in nautilus:
importance: Unknown → Medium
Doug McMahon (mc3man) wrote :

The 'issue' here (on maverick and probably lucid, as noted in the duped bug) has been resolved by not allowing :Remember this application for "Folder" files to be enabled when using "Open with Other Application" on dir.'s

The checkbox is enabled by default and when enabled changes the default folder handler to app chosen, in effect the same as properties -> open with.

At a min. setting this to false at least keeps the box disabled unless the user changes and results in expected behavior - the chosen app opens the dir., is added to the"Open With" menu and nautilus remains the default

gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (dialog->details->checkbox), FALSE);

A fresh ( no inode/directory= line) mimeapps.list after opening a dir. with vlc - nautilus is automatically added to front of line, any other apps used from the "Open with Other Application" dialog are added to end of line, ect.

inode/directory=nautilus-folder-handler.desktop;vlc-audio.desktop;

Doug McMahon (mc3man) on 2010-10-04
Changed in nautilus (Ubuntu):
status: Triaged → Confirmed
Doug McMahon (mc3man) wrote :

Why you want to''Triaged" something you can fix in about 5 sec's is beyond me
(if the bug I see keeps getting duped to this one then just go ahead and take care of this
(that is if you have any concerns about the 'quality' of desktop usage

TommyBoy (thomaslloyd) wrote :

Seconds Dougs Analysis.

I have a valid use case for open with for folder containing music to add an album. So i would prefer the default to be disabled make permanent.

Doug McMahon (mc3man) wrote :
Sam_ (and-sam) wrote :

> this bug has nothing to do with the places menu

Sebastien,
the correlation is, when a user changed in any way (incl. by accident) the folder_open_with handling, afterwards is wondering and hence asking in forums, why places menu /home now opens with eog, vlc, totem, firefox or whatever app instead with Nautilus.
I've got about 10 links of such questions in englisch e.g.
https://answers.launchpad.net/ubuntu/+question/110117
Others collected german questions.
http://forum.ubuntuusers.de/topic/problem-mit-persoenlicher-ordner-ueber-orte/2/#post-2491261
Above is just the tip of the iceberg compared to query in google which outputs 233,000 results.
http://www.google.com/search?client=ubuntu&channel=fs&q=ubuntu+open+places&ie=utf-8&oe=utf-8

poacheR (tpapastylianou) wrote :

Apologies if this is a different bug altogether.
I agree there is a perfectly good use case for retaining the ability to open folders with other applications, as with files.
For instance, I like to open movie or music folders (not necessarily as a default action though) with totem, so that all the files contained in the folder appear in the playlist. This is particularly useful for multiply nested folders. I have been doing so since Edgy, I believe.

My problem now, since the introduction of these new 'features' is twofold.
1) While I still have the ability to right-click on a folder and choose 'Open With Other Application', and, say, select Totem to open the folder, this option does not automatically become part of an 'Open With' list of associated viewers (even if the 'Remember' tickbox is checked). I have to physically fire up the 'Open With Other Application' dialog and look up Movie Player from the list every time I want to do this.
2) Since there is no 'Open With' tab in the 'Properties' section for folders anymore either, I cannot add Totem as an option this way either. (Note I obviously don't want totem to be my default folder viewer, but I *do* want it to be an easily accessible associated viewer for when dealing with particular folders)

Also, I seem to remember that opening an app with a different program (and checking the 'remember' tickbox) didn't necessarily make that program the default, unless you specified it in the properties section ... am I making this up? Was that changed on purpose? If so, then my suggestion would be to somehow be very explicit what 'Remember this app' does, or perhaps add another dependent checkbox, like so:

[x] Remember this app (i.e. add it to the list of default handlers, but not necessarily as *the* default viewer)
     [ ] Make this app the default handler for this filetype (tickbox greyed out if the first one is unchecked)

This way, the user knows exactly what will happen with that viewer, and I believe is a reasonably user-friendly way of doing it.
(i.e. not inundated by checkboxes.)

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Confirmed → Triaged
Revup (revups) wrote :

I just installed 11.04.
Tried to play a music folder by right clicking, and clicked 'other application'
selected VLC, OK, no problem. Did not notice at the time that the tickbox at the bottom was defaulted to 'remember this application'.

Thereafter, when opening homefolder, desktop, documents, or any other folder, VLC opened instead.
Deinstalled VLC and Rhythmbox opened in its place.

After several minutes thinking, I right-clicked a file at random (in a mounted external drive on desktop, apparently unaffected), clicked 'open with', making sure 'remember this application' wasw selected, and chose file manager. Problem solved.
Reinstalled VLC, problem has not returned.

Sorted, but way too buggy.

David Tolnay (dtolnay) wrote :

Ubuntu Tweak exposes the "open with" setting for folders. Click on System -> File Type Manager in Ubuntu Tweak's sidebar, choose "All" for the category, find "folder" in the list of file types, and click Edit. This fixes problems similar to Revup's in a slightly more intuitive way, but it would still be nice for this setting to appear in Nautilus itself.

It is worth noting that even if you use Ubuntu Tweak to pick something other than Nautilus as the default application to open folders, (most?) file managers will continue to function as normal. For example, even after choosing VLC as the default application, I could still browse through directories structures in Nautilus, Dolphin and Thunar. The only changes were that VLC appeared as an "open with" option in the context menu for folders, and that gnome-panel Places used VLC to open folders. So at least in my case Sebastien Bacher's justification that "Changing the default doesn't make sense because when double clicking on a directory in nautilus you get whatever sofrware started rather than the directory open when you do that change" seems contradictory to what actually happens.

Changed in nautilus:
status: New → Won't Fix
Sebastien Bacher (seb128) wrote :

upstream closed the bug with that comment

"We don't show the open with menu for folders. Nor do we offer the ability to
customize the open with menu."

Changed in nautilus (Ubuntu):
status: Triaged → Won't Fix

I'm not a nautilus developer, however I reopened the bug because I think it has been closed in error. If I've reopened it in error, I think the developers will close it again. Here's the link to the comment I wrote while re-opening:
https://bugzilla.gnome.org/show_bug.cgi?id=580309#c14

Changed in nautilus:
status: Won't Fix → New
Changed in nautilus:
status: New → Won't Fix

Although this was fixed in Ubuntu 12.04, it has returned again in Ubuntu 13.04:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1178697

Shingo L. (kingshingo) wrote :

In search for a solution, I ended up here. Sort of sad to see that the decision seems finalized in not including the feature.

I wish Nautilus could have this feature as an option in the properties. The team can make the default to not allow open-as for directories, but those who adore the feature can still simply enable it. Nautilus has not much options available in its properties but I suppose that is so to keep things simple, and I do respect the decision.

I understand that decision making is very hard.
I thank the team developing Nautilus for all of their hard decision making and their effort to bring a great tool for everyone.

Thank you.

The workaround that I found is using the nautilus-actions package. It makes it possible to define actions to take for files that match a specific criteria (even folders). When a file is right clicked, if it matches a predefined criteria, the specified action will appear under a menu called "Nautilus-Actions actions" in the popup menu. This is the closest to the original functioning that I've been able to find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.