Removing any entry from the left pane closes Nautilus

Bug #36500 reported by markba on 2006-03-24
122
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

This happens when deleting a folder from the left (tree) pane. When a
folder is removed from within the main pane, everything works as expected. Nautilus just closes, does not seem a a crash with a bug buddy and all that...
Nautilus version: 2.14.0

Sitsofe Wheeler (sitsofe) wrote :

I see this too:
nautilus 2.14.0-0ubuntu3

Steps to reproduce:
1. Go to Places -> Home folder .
2. Press Ctrl-Shift-n and type new .
3. Press the right mouse button on new and go to Browse Folder .
4. If the side pane is not visible press F9. If the side pane is not on tree, click on the dropdown arrow in the side pane and choose tree.
7. Press the right mouse button on new in the side pane and choose Move to Wastebasket.

markba:
The question is, when you have a folder that is open and you delete it, what do you expect to happen?

markba (mark-baaijens) wrote :

"The question is, when you have a folder that is open and you delete it, what do you expect to happen?"
Ofcourse, I expect it to be deleted (I think you mean with your question that the folder is opened in the *right* pane).

Strange thing is though, crashing does *not* occur when the folder to be deleted does not have focus on the right pane. I guess this (focus) is the critical factor...

Sitsofe Wheeler (sitsofe) wrote :

markba:
I think my question wasn't clear:

What do you expect to happen to the *window* after you delete the folder that is currently displaying in the right hand/main pane?

More generally, if the folder being displayed in a window goes (for whatever reason) what do you expect to happen to that window?

Sebastien Bacher (seb128) wrote :

Thanks for your bug. I've forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=336724

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
GonzO (gonzo) wrote :

I would expect the Tree view to shift to the folder above it, and then I'd expect the right pane to reflect the contents of this new folder.

I think the behavior I just outlined is not only expected, but practiced by nearly every other file manager on the planet, and none of them close (crash) when a folder is deleted.

Sebastien Bacher (seb128) wrote :

The current behaviour probably makes sense for the spatial mode but not for the browser, I've updated the upstream bug to write that and copied your comment too

GonzO (gonzo) wrote :

Oh, awesome! Thanks a lot. (Took me a while to find this bug, because I kept looking for ways to get a debug on Nautilus... but it wasn't crashing, it was closing, and apparently this is planned behavior.)

Sitsofe Wheeler (sitsofe) wrote :

Sebastien:
It was GonzO who said "the parent folder should be displayed" not the original bug submitter markba (from the upstream bug: "Distribution bug submitter commented:"). markba has yet to reply to my revised question...

Sebastien Bacher (seb128) wrote :

right, doesn't make a real difference for upstream anyway

Changed in nautilus:
status: Unconfirmed → In Progress
markba (mark-baaijens) wrote :

Sitsofe Wheeler: "More generally, if the folder being displayed in a window goes (for whatever reason) what do you expect to happen to that window?"

I expect that the entry (cursor position) in the left window is going to move to the one on the bottom of the deleted entry. Next, the right window should be updated with information about the newly positioned folder-entry. I don't expect the right window to be closed, that wouldn't make sense. So, in my point of view, a folder displayed never actually goes (for whatever reason), it is simply refreshed by information about an other folder-entry.

Changed in nautilus:
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in nautilus:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

this upload fixes the issue:

 nautilus (2.15.4-0ubuntu1) edgy; urgency=low
 .
   * New upstream version:
     - New permission dialog with recursion and selinx support (Ubuntu: #24460)
     - Improve extension interface
     - Add complete session management
     - Handle removal of the displayed location more elegantly (Ubuntu: #36500)
     - Use proper nautilus-cd-burner icon
     - Support dropping uris, urls and text to subfolders
     - Fix leaks and warnings
   * debian/control.in:
     - updated eel requirement according to configure
   * debian/patches/01_lpi.patch:
     - updated

Changed in nautilus:
status: Fix Committed → Fix Released
André Klitzing (misery) wrote :

Is it possible to add this patch to dapper?

Daniel Holbach (dholbach) wrote :

I think that chance are pretty slim.

Sebastien Bacher (seb128) wrote :

that's not really a bug but a small behaviour annoyance, it's not frequent to remove the directory you are browsing and the patch is not trivial, so it's not likely to be used for dapper

Changed in nautilus:
importance: Unknown → Low

I would like to re-open this bug as it happens to me now in Ubuntu 11.10. Could this regression be related to the recent transition to GNOME3?
I'm using Nautilus 1:3.2.0-0ubuntu5 64-bit with the Unity interface.

To recreate:
Open Nautilus
Create new folder in Nautilus
Click: View > Sidebar > Tree
Expand the tree to show your new folder
Right click on the new folder in the Sidebar tree
Delete folder

Nautilus closes all of its open windows without warning.

Also requested for re-opening upstream: https://bugzilla.gnome.org/show_bug.cgi?id=336724#c12

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.