The selection should not change when using back or forward navigation

Bug #362091 reported by positivek on 2009-04-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

This is a very frustrating bug that remains in Gnome 2.24.1: Nautilus
2.24.1. I think this is a bug and not really a wishlist item.

Reproduce it:
1. Open home dir in Nautilus.
2. Select a subdirectory of home, say "my_dir".
3. Open that dir by hitting Enter or Ctrl+o.
4. Click Nautilus' "BACK" button.
5. BUG: Actual Behavior is that the selection is cleared. Expected behavior is
that the selection remain from the last time I viewed that directory.

Caveat and inconsistency:
1. Open home dir in Nautilus.
2. Select a subdirectory of home, say "my_dir".
3. Open that dir by hitting Enter or Ctrl+o.
4. Click Nautilus' "UP" button.
5. The behavior that I would expect for going BACK is is found! The
subdirectory ("my_dir") is now in the selection. In fact, would say this could
be another bug as well. I expect the "UP" action to act as if I am navigating
to a new directory, a fresh start. I do not want the directory I was in to be
selected.

Perhaps the code for BACK and UP got swapped accidentally?

Example use case: I want to examine a directory's contents before doing
something with it (copying, moving, deleting, etc.):
1. Open my home directory in Nautilus.
2. Double-click some directory, say "my_dir" to view its contents.
3. I see that it's some stuff I want to copy to a flash drive.
4. Use Nautilus' "Back" button to go back to my home directory.
5. Assuming that the "my_dir" directory remains selected, I can easily pick it
out in the long list of files without worrying if I got the right one or not.
I can even do a Edit->Copy without having to find "my_dir" again and reselect.

This bug may be related to Bug #64287 (spatial nautilus should remember selected items), but that deals with "spatial" nautilus and with closed windows.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.24.1-0ubuntu2
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.27-11-generic x86_64

positivek (anonyhole) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

there is also http://bugzilla.gnome.org/show_bug.cgi?id=557462 about a similar request

Changed in nautilus (Ubuntu):
status: Invalid → Triaged
summary: - Selection not remembered when navigating back/forward in browser mode
+ The selection should not change when using back or forward navigation
Changed in nautilus:
status: Unknown → New
Omer Akram (om26er) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue , in the default Ubuntu 9.10 install , that affects many people and is quick and easy to fix. So this bug can't be addressed as part of the project.

feature request is not a papercut.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Changed in nautilus:
importance: Unknown → Wishlist
Changed in nautilus:
status: New → Invalid
Paul White (paulw2u) wrote :

Upstream bug marked as a duplicate of #650455 so changing link
Partially fixed as in nautilus 3.26 back works but forward does not

Changed in nautilus:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.