'Empty trash' on flash drive leaves unnecessary '.Trash' folder

Bug #362050 reported by Bill Smith on 2009-04-15
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Low
nautilus (Ubuntu)
Low
Unassigned

Bug Description

This is a follow-up to bug 12893 -- it is not a duplicate!

When you go to unmount a USB flash-drive you are automatically prompted to Empty Trash. After doing so, however, there is a left-over folder, e.g. ".Trash-1000" which is hidden on Linux but visible on Windows. Since the folder is unused can't it be removed, too?

Sebastien Bacher (seb128) wrote :

thank you for your bug report, the folder has to be added manually on some filesystem to specify that you want to use a trash, deleting the directory would mean the user has to do that every time and not once, that would create issue for no real benefit

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
Bill Smith (bsmith1051) wrote :

Please don't mark this as Invalid. I'm not saying the folder is unnecessary whilst the drive is mounted. However, the user does not expect it to be there and so I am requesting that it be removed automatically in this specific situation: Where the user has requested an unmount AND requested emptying the trash.

In this situation I see no problem with the system also removing the ".Trash" folder that it had created unbeknownst to the user.

Surely this falls under 'Correctness' ? Surely all the previous reports and bugs complaining about this leftover folder demonstrate that the system is doing something that users don't expect or want?

Sebastien Bacher (seb128) wrote :

did you read my comment before? there is filesystem where you will have no such directory until you create one manually to say that you want one, if the system was to delete if for you every time you unmoun the drive you would have to do this work every time you plug the key, not really a win for users, the microsoft folder is already available under linux and nobody at microsoft will modify their os to delete their special directory that's not much different, that seems extra trouble, work and issue for a small cosmetic change

Bill Smith (bsmith1051) wrote :

Sorry, but I don't understand your explanation. You seem to be saying that *I* am manually creating this folder? This is not true.

All I know is that I can take a 'clean' flash drive, copy some files onto it from my Windows machine, then transfer the files to my Ubuntu machine and delete them from the drive. The next time I mount the drive on my Windows machine, there's this unexpected 'system' folder. Surely you can understand how this is undesirable?

Or, are you saying that it's extra work for Ubuntu to have to delete the folder after Empty Trash, then recreate it again if/when I delete something else? Frankly, it's a computer so I expect it to be able to handle a little automation :-)

Sebastien Bacher (seb128) wrote :

what I'm saying is that on some filesystems format you need to create the directory manually because the permissions are not handled correctly and your suggested changes would mean user using such formats would have to redo the work every time they use they device because the system tries to be clever and delete the directory

Bill Smith (bsmith1051) wrote :

Ah, I get it.

So then my suggestion would be that Ubuntu delete the .Trash folder ONLY when:
1. the OS has created the folder during the same mount session, and
2. the user has emptied the trash, and
3. the user has requested an unmount

Fortunately computers are good at keeping track of 'all' those things, right?

Vadim Peretokin (vperetokin) wrote :

I don't see a reason for leaving .Trash-1000 on the users drive either, after they were even asked to clean up they trash, and they -did-. Not all OS's respect the period either, so to the user it seems like Ubuntu didn't do it's job of cleaning properly to begin with.

Changed in nautilus (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

you should open a bug on bugzilla.gnome.org where the people writting the software will read it rather than argue on a distribution bug tracker if you have strong opinions about the way it's working

Changed in nautilus (Ubuntu):
status: New → Incomplete
Changed in nautilus (Ubuntu):
importance: Low → Wishlist
status: Incomplete → New
Changed in nautilus (Ubuntu):
importance: Wishlist → Low
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
importance: Unknown → Low
Adolfo Jayme (fitojb) on 2012-12-13
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.