Ubuntu

Folders have wrong default program and the association can't be changed

Reported by seguso on 2006-03-18
30
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
shared-mime-info
Won't Fix
Medium
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

When I was using Breezy, I had associated a few program to the "folder" mimetype, so I could select them with a right-click on any folder: cervisia, kdirstat, konqueror, plus a shell script (invoked by gnome-terminal -x script.py ).

Then I upgraded to dapper months ago, and all worked well. Until a few days ago, when something strange happened:

1. some associations have gone, namely the script and kdirstat.

2. Those associations can't be readded.

3. If I right click on a folder and choose properties->open-with, I see that Cervisia is now the default action for folders. THere are only two other choices: "open folder", which should be the default, and konqueror.

4. If I click on "open folder", in order to set a good default, my click is ignored. I can't change the default association in any way.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. I've forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=335161

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 shared-mime-info (0.17-0ubuntu10) dapper; urgency=low
 .
   * debian/patches/110_no_directory_alias_fix_open_with.patch:
     - don't set an alias from "inode/directory" to "x-directory/normal",
       fix nautilus "open with" associations when selecting a directory
       (Ubuntu: #35463)

Changed in nautilus:
status: Confirmed → Fix Released
seguso (maurizio-colucci) wrote :

DEO GRATIAS !

Changed in shared-mime-info:
status: Unconfirmed → Confirmed
Changed in shared-mime-info:
status: Confirmed → Needs Info
Changed in shared-mime-info:
status: Needs Info → Rejected
Changed in nautilus:
status: New → Invalid
mvdberg112 (sp1471) wrote :

Have same problem:
[QUOTE]" Could not open location 'file:///home/myuser'
" There was an error launching the default action command associated with this location." [/QUOTE]

See also dicussion:
http://ubuntuforums.org/newreply.php?do=newreply&p=3931757

How to install the fix?
I see a 'Completed' action on 20-01-2008 for "gnome-bugs #335161", but not sure where and how it is implemented. Let me know if this might be actually a different bug.

I am using Ubuntu 7.10 Gutsy Gibbon - should this be fixed in the mean time.

Cannot change the default action in Nautilus or GNome.
The precise steps are:
 Open a folder in Nautillus (for example with Places -> Computer);
 browse to the folder that does not behave properly (in my case file:///home/myuser)
 Select File -> Properties -> Open With; here one should be able to add and remove items. It is possible to Add items, but they cannot be selected. Two items cannot be removed: 'Open Folder' and 'Open Folder with Thunar', which is selected by the radio button. It is not possible to move the radio button and select any other option.

Changed in shared-mime-info:
importance: Unknown → Medium
status: Invalid → Won't Fix
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Expired
Changed in shared-mime-info:
importance: Medium → Unknown
David Robert Lewis (afrodeity) wrote :

This problem has re-emerged after last two updates in Maverick 10:10. Right-clicking on properties in Nautilus does not show "Open With" option. No immediate way to change the default helper applcation.

David Robert Lewis (afrodeity) wrote :

Ok, problem solved, a wee bit more complicated than the previous solution:

1. Open Home folder

2. Right click on problem folder

3 Choose Open With

4. Choose Other Application...

5. Make sure "remember this application for folder files" is clicked

Anybody out there know why we can't do this in three steps, via File > Properties?

Changed in shared-mime-info:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.