Ubuntu

hidden files not included in directory 'properties'

Reported by Duncan Lithgow on 2006-03-06
136
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Nautilus 2.13.91 under Dapper Flyer 4 and Nautilus 2.12.1 under Breezy.

Expected behaviour
* upon right clicking a directory and choosing properties the numbers in the 'contents' will include all files and folders.

Actual behaviour:
* lists only non-hidden files

Workaround
* open the directory, set 'show hidden files' to 'yes', choose select all, select properties.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=329879

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Changed in nautilus:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue is fixed in the new nautilus gvfs version now

Changed in nautilus:
status: Confirmed → Fix Released
Duncan Lithgow (duncan-lithgow) wrote :

Shouldn't this be marked 'Fix Committed' and not 'Fix released'? Nautilus in Ubuntu 8.04 does not fix this bug (although I see in the upstream comments that it's fixed in Ubuntu 8.10)

Sebastien Bacher (seb128) wrote :

the bug is fixed in intrepid so it's correctly closed, backport tasks can be opened if the fix should be backported to stable

Pedro Villavicencio (pedro) wrote :

this is not fixed yet, I'm getting the same results with latest Intrepid and GNOME trunk, we also have a new duplicate (bug 260540) of this bug with Intrepid, re opening, thanks you.

Changed in nautilus:
status: Fix Released → Triaged
staho (staho) wrote :

still not fixed in karmic beta

Since there is an option in nautilus: "show hidden files", one could use it. Or, better, always show both files, eg.: "12 items, totalling 30.4 KB (of which 355 B in 3 hidden files)"

Duncan Lithgow (duncan-lithgow) wrote :

@staho: 'show hidden files' does not make the hidden files included in the directory size count. Indeed this is clearly not fixed.

f3a97 (f3a97) wrote :

I can confirm that it's still there on Karmic!

Changed in nautilus:
importance: Unknown → Medium
dreamon (dreamon) wrote :

I confirm this bug for Ubuntu 10.04 Lucid Lynx and Nautilus 2.30.1. The preferences window doesn't show the right file size and the workaround provided in the description doesn't change this. Even with View -> Show hidden files enabled the file size & file count in the preferences window are still wrong. This is extremely confusing and annoying behaviour and should be fixed asap. Not being able to tell how large a folder really is makes it nearly impossible to calculate space requirements for backups and the such.

Bausparfuchs (bausparfuchs) wrote :

I can confirm that annoying bug in Natty

Norbert (nrbrtx) wrote :

Bump! It's 2012!
Same on 11.04.

Marinus (mbjunk21) wrote :

Bump! It's 2013!
Same on 13.04.

I don't know it this is related but if you set show 'hidden files' and then select the all the dot files in home followed by show properties Nautilus gets stuck in a loop counting files. It counts ~7300 files then restarts at 0, after about 30 minutes it stops at ~14000 files but the 'working' (the spinning circle thing is still spinning) is still going. This only happens if I select all dot files and folders.

Dominik (dominik.k) wrote :

@Marinus: Your problem is another one -> see bug 1131571

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.