Ubuntu

New windows of nautilus get unfocused

Reported by Fernando Miguel on 2009-02-23
410
This bug affects 97 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
metacity
Fix Released
Low
gtk+2.0 (Ubuntu)
Low
Unassigned
Nominated for Jaunty by Martin Olsson
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Jaunty by Martin Olsson

Bug Description

Binary package hint: nautilus

New windows of nautilus get unfosed

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.25.91-0ubuntu1
  Candidate: 1:2.25.91-0ubuntu1
  Version table:
 *** 1:2.25.91-0ubuntu1 0
        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
        500 ftp://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

$ apt-cache policy libindicate0
libindicate0:
  Installed: 0.1.1-0ubuntu2
  Candidate: 0.1.1-0ubuntu2
  Version table:
 *** 0.1.1-0ubuntu2 0
        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
        500 ftp://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: nautilus 1:2.25.91-0ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: nautilus
Uname: Linux 2.6.28-8-generic x86_64

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

the bug description doesn't really makes sense the notifications have nothing to do with nautilus

yes it is reproducible

Changed in nautilus:
status: Incomplete → New
Don Zavitz (dzavitz) wrote :

i can reproduce this on my amd64 machine...clicking focus to audacious, to xchat, to Places and then Videos for example...opens videos unfocused...but sometimes not on the first go...it takes anywhere from 1-4 times over to get the window to open unfocused

Igor Vatavuk (igor-vatavuk) wrote :

I can also reproduce this Nautilus behaviour but I think it has nothing to do with notifications or indicator applet.
My example - open firefox make it full screen, then go to places->home and for me it opens in background.

Martin Olsson (mnemo) wrote :

confirming. this is a really annoying bug.

using "xdg-open ." in any directory would open a new focused nautilus window on intrepid. today on jaunty the nautilus window is created behind all the other windows.

It seems more like a window manager issue. I cannot reproduce the issue consistently.

I've tried with metacity (with & w/o compositing) and compiz the presence or the absence of notify-osd, and/or of a notify-osd notification on display does not consistently result in having the nautilus window being opened in the background.

In fact, in most of my tests, the window stayed in the background when notify-osd was *not* running, and was raised when either notify-osd was running and/or displaying a notification.

David Barth (dbarth) wrote :

Setting as 'invalid' because I really doubt it's notify-osd' fault. But happy to revisit this status if we get a test case that consistently triggers the anomaly.

Changed in notify-osd:
status: New → Invalid
David Barth (dbarth) wrote :

Setting as 'invalid' because I really doubt it's the fault of the indicator-applet. But happy to revisit this status if we get a test case that consistently triggers the anomaly.

Changed in indicator-applet:
status: New → Invalid
description: updated

On Wednesday 25 February 2009 12:05:06 Mark Shuttleworth wrote:
> Is this a result of notify-osd?

I dont know. But for my untrained eye it would seem that it is at least related to the focus prevention that spec mentions.
Plus it started happening around the same time, as indicators hit the repo.

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Sebastien Bacher (seb128) wrote :

I've seen that behaviour too but not every time and usually opening a view on a mounted disk for example fix it for the session

Martin Olsson (mnemo) wrote :

FWIW, this is 100% reproducible for me while opening a terminal and running "xdg-open ." inside my normal home dir on a plain ext3 fs. On this system I never mount any other file systems and I don't use any external USB harddrives etc.

Sebastien Bacher (seb128) wrote :

could somebody having the issue in a reliable way open a bug on bugzilla.gnome.org?

Martin Olsson (mnemo) wrote :

I did some additional testing now and it's not 100% reliable for me either but it's not hard to repro either. Having gnome-terminal and some other app up at the same time and then ALT-TABing betwwen that other app and the terminal seems to make the bug trigger a bit more easily.

I also tried it in gnome-stracciatella-session and it repro's there as well.
I will file an upstream bug tomorrow if none beats me to it.

Martin Olsson (mnemo) wrote :

I've upstreamed this bug at:
http://bugzilla.gnome.org/show_bug.cgi?id=573922

If anyone can find a solid set of repro steps, please post them here asap.

Chris Coulson (chrisccoulson) wrote :

Thanks for sending upstream martin

Changed in nautilus:
status: New → Triaged
Changed in nautilus:
status: Unknown → Confirmed

Easy reproduce.
Login and on start up open firefox, not maximised. Then open places>home folder.

Folder opens under firefox and not on top every time for me.

David Barth (dbarth) wrote :

It may be an issue with compiz that was fixed recently, where compiz introduced a regression with the way focus_on_map was dealt with with respect to focus stealing. See https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/333284

Can you try the latest version of compiz a confirm if you can still reproduce the issue? Thanks

Tuomas Aavikko (taavikko) wrote :

David Barth wrote 58 minutes ago: (permalink)
It may be an issue with compiz that was fixed recently, where compiz introduced a regression with the way focus_on_map was dealt with with respect to focus stealing. See https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/333284
Can you try the latest version of compiz a confirm if you can still reproduce the issue? Thanks

This doesn't need compiz to take effect.
Running metacity with composite extension will suffice.

On Fri, Apr 3, 2009 at 6:52 AM, David Barth <email address hidden>wrote:

> Can you try the latest version of compiz a confirm if you can still
> reproduce the issue? Thanks
>

David, could you please specify the specific version you are referring to?
With different mirrors getting updates at different times, there are
different "latest" versions. I have 1:0.8.2-0ubuntu5 which
packages.ubuntu.com reports as the latest, and I seem to be still
experiencing this.

I havent seen this in a while.
Using Compiz.

$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.26.1-0ubuntu1
  Candidate: 1:2.26.1-0ubuntu1
  Version table:
 *** 1:2.26.1-0ubuntu1 0
        500 ftp://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status
     1:2.26.0-0ubuntu7 0
        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
$ apt-cache policy compiz
compiz:
  Installed: 1:0.8.2-0ubuntu5
  Candidate: 1:0.8.2-0ubuntu5
  Version table:
 *** 1:0.8.2-0ubuntu5 0
        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
        500 ftp://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

I am using compiz (0.8.2-0ubuntu5) and still have this after updating and
restarting. It is easy to reproduce as philinux says: log on, start firefox,
go to places->home, and it will open under firefox.

I am using compiz 0.8.2-0ubuntu6 from compiz packagers PPA, but I still see the problem. In particular I can reproduce it as philinux says.

mikio (dete) wrote :

i have the same problem. i can reproduce it 100%. i do not run compiz. not sure if this is relevant: i am opening nautilus with a mapped key combination.

Photon (michael-kogan) wrote :

I think it would make more sence to post comments here since the bug is upstreamed: http://bugzilla.gnome.org/show_bug.cgi?id=573922

Zied ALAYA (zied.alaya) wrote :

I don't think it's nautilus.

some times when I have firefox open and maximized, if I open a new window the window is open but don't show up.

try this: open firefox, alt-F10, open gedit, copy some thing from firefox to the gedit document, come back to firefox and now open your home folder from Places. The new window will be in the background.

but I think it's not nautilus, if you see the attatchment, when I click to view appointments and tasks I have the same behavior.

Damiano Dallatana (damidalla) wrote :

As for the Calendar Popup, I opened bug #355330.

Chris Coulson (chrisccoulson) wrote :

Upstream say this is a metacity bug and have re-assigned the upstream report to metacity now.

affects: nautilus (Ubuntu) → metacity (Ubuntu)
Hew McLachlan (hew) wrote :

That seems unusual since both metacity and compiz are affected.

Chris Coulson (chrisccoulson) wrote :

Good point. I suppose the same bug could affect both. Perhaps you could mention that on the upstream report?

Michael Rooney (mrooney) wrote :

If it is a WM bug then we need a compiz task to track this as multiple people have confirmed this in compiz.

Changed in compiz (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

upstream commited a gtk workaround now

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+2.0 - 2.16.0-1ubuntu3

---------------
gtk+2.0 (2.16.0-1ubuntu3) jaunty; urgency=low

  * debian/patches/093_git_change_fix_focus_issue.patch:
    - upstream git change to fix a timestamp issue leading to get nautilus
      dialog opening sometime unfocussed for example (lp: #333366)

 -- Sebastien Bacher <email address hidden> Wed, 08 Apr 2009 16:58:25 +0200

Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Fix Released
Martin Olsson (mnemo) wrote :

You're freakin' awesome seb! This fixes the last bug in jaunty that really bugged me.

It makes me think about a scene from the McGyver theme song where he slips through the gate just before it's closing (about 1:11 into the intro theme: http://www.youtube.com/watch?v=3w-oDZSLUrY ). Again, thanks!!

Simon (simonbcn) wrote :

I updated the system now but it continues to fail: Open firefox and open home folder from "Places".
Can this bug be the causer also of: https://bugs.launchpad.net/ubuntu/+source/zenity/+bug/272083 ?

Colin Watson (cjwatson) wrote :

gtk+2.0 (2.16.0-1ubuntu4) jaunty; urgency=low

  * debian/patches/093_git_change_fix_focus_issue.patch:
    - updated version which should really fix the issue (lp: #333366)

 -- Sebastien Bacher <email address hidden> Thu, 09 Apr 2009 10:41:37 +0200

Chris Coulson (chrisccoulson) wrote :

Simon,

Please don't open tasks for what appears to be a completely unrelated problem. There is already a bug report open for the zenity problem

Changed in zenity (Ubuntu):
status: New → Invalid
Simon (simonbcn) wrote :

And are not they related?
And why no one says anything on the Zenity bug about the problem?

Zied ALAYA (zied.alaya) wrote :

Is this bug still open ?
in my case it's fixed and I don't have this issue any more.

neither do I

2009/4/30 Zied ALAYA <email address hidden>:
> Is this bug still open ?
> in my case it's fixed and I don't have this issue any more.
>
> --
> new nautilus window stays in background
> https://bugs.launchpad.net/bugs/333366
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Nautilus: Confirmed
> Status in Notify OSD: Invalid
> Status in “compiz” source package in Ubuntu: Confirmed
> Status in “gtk+2.0” source package in Ubuntu: Fix Released
> Status in “indicator-applet” source package in Ubuntu: Invalid
> Status in “metacity” source package in Ubuntu: Triaged
> Status in “zenity” source package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: nautilus
>
> New windows of nautilus get unfosed
>
> $ apt-cache policy nautilus
> nautilus:
>  Installed: 1:2.25.91-0ubuntu1
>  Candidate: 1:2.25.91-0ubuntu1
>  Version table:
>  *** 1:2.25.91-0ubuntu1 0
>        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
>        500 ftp://archive.ubuntu.com jaunty/main Packages
>        100 /var/lib/dpkg/status
>
> $ apt-cache policy libindicate0
> libindicate0:
>  Installed: 0.1.1-0ubuntu2
>  Candidate: 0.1.1-0ubuntu2
>  Version table:
>  *** 0.1.1-0ubuntu2 0
>        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
>        500 ftp://archive.ubuntu.com jaunty/main Packages
>        100 /var/lib/dpkg/status
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: nautilus 1:2.25.91-0ubuntu1
> ProcEnviron:
>  SHELL=/bin/bash
>  PATH=(custom, no user)
>  LANG=en_US.UTF-8
> SourcePackage: nautilus
> Uname: Linux 2.6.28-8-generic x86_64
>

--
Mind is like a parachute - useless if closed.

Changed in metacity (Ubuntu):
status: Triaged → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in nautilus:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Changed in metacity:
status: Unknown → Confirmed
Changed in metacity:
status: Confirmed → Fix Released
Changed in metacity:
importance: Unknown → Low

Please, reopen this cause that very annoying bug has reborn in the 11.10 and 12.04.

Dries Cox (driescox) wrote :

Is it already reopend? I experience the same bug (12.04)

summary: - new nautilus window stays in background
+ New windows of nautilus get unfocused
Changed in nautilus:
status: Invalid → Confirmed
affects: notify-osd → compiz
Changed in compiz:
status: Invalid → Confirmed
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Changed in compiz:
milestone: none → 0.9.8.0
Changed in nautilus:
importance: Undecided → Unknown
status: Confirmed → Unknown
Daniel van Vugt (vanvugt) wrote :
no longer affects: indicator-applet (Ubuntu)
affects: metacity (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Invalid → Confirmed
no longer affects: zenity (Ubuntu)
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
palimmo (palimmo) wrote :

This problem (windows that don't get focus) occurs not only with nautilus, but also with pop-up windows (browsers) and with update manager.

Doug McMahon (mc3man) wrote :

That patch has already been applied in nautilus (1:3.5.2-0ubuntu3) quantal and seen here to be somewhat effective but not 100% with nautilus
one instance where focus isn't given is commented here
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/781931/comments/46

What is 100% here in 12.10 is not allowing nautilus to handle the desktop in which case the patch doesn't matter

Daniel van Vugt (vanvugt) wrote :

palimmo,

This bug is specifically about nautilus. If you have problems with other windows, please log a new bug. Or if you have a duplicate already, please let us know which one it is that should not be a duplicate of this bug.

palimmo (palimmo) wrote :

Daniel Van Vugt,
yes, since yesterday this bug
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/781931
has been reported as a duplicate.
But, as you can read, it involves pop-up windows (browsers) and update manager (as far as I know) too.

Daniel van Vugt (vanvugt) wrote :

The description of bug 781931 only mentions it being a problem with nautilus.

Please log a new bug with other window types.

no longer affects: compiz
no longer affects: compiz (Ubuntu)
Colin Law (colin-law) wrote :

I don't know whether it is relevant but I am seeing the same issue with Tomboy (bug #1025166)

Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

This was fixed as part of bug #781931 in August for Ubuntu 12.04 LTS and Ubuntu 12.10. However, the 13.04 (raring) development version has a variation of the same problem again, for which I filed a new bug #1098533.

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.